Foro de la Comunidad SIU

SIU-Mapuche => Soporte de Instalación => Mensaje iniciado por: ebombara en septiembre 26, 2020, 10:23:08 pm

Título: Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: ebombara en septiembre 26, 2020, 10:23:08 pm
Hola,
Estoy realizando la actualización de mapuche de la versión 3.4.4 a la 3.11.1 y al momento de instalar las dependencias:
$ composer install --no-dev
Aparece el siguiente error:

> composer run-script post-install-cmd -d ./vendor/siu-toba/framework/
Do not run Composer as root/super user! See https://getcomposer.org/root for details
> yarn install --non-interactive --modules-folder www/js/packages/
Usage: yarn [options]

yarn: error: no such option: --non-interactive
Script yarn install --non-interactive --modules-folder www/js/packages/ handling the post-install-cmd event returned with error code 2
Script composer run-script post-install-cmd -d ./vendor/siu-toba/framework/ handling the post-install-cmd event returned with error code 2

Datos complementarios:
Debian 9
PHP 7.1
Postgresql  9.6.19
Composer version 1.2.2 2016-11-03 17:43:15
NodeJS v4.8.2
yarn  0.27

Muchas gracias por la asistencia!

Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: mariela en septiembre 28, 2020, 11:37:44 am
Hola Edgardo puede ser la versión del composer, lo actualizaría a la versión 1.4.x, que para esa versión de php y toba funcionaba correctamente.

Saludos,
Mariela





2
Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: ebombara en septiembre 28, 2020, 12:19:29 pm
Hola Mariela gracias por la pronta respuesta,
Acabo de actualizar composer a la ultima versión estable y persiste el mensaje de error.
Composer version 1.10.13 2020-09-09 11:46:34
Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: mariela en septiembre 28, 2020, 01:08:47 pm
Tenes instalado el yarn? en que versión?

Mariela


2
Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: ebombara en septiembre 28, 2020, 01:57:34 pm
Si, versión yarn  0.27
Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: mariela en septiembre 29, 2020, 10:21:42 am
Hola Edgardo, tendrías que actualizar la versión de yarn, ya que es tambien está muy desactualizada con respecto al composer 1.10.x.

Saludos,
Mariela
Título: Re:Error en actualización Mapuche versión 3.4.4 a 3.11
Publicado por: ebombara en septiembre 29, 2020, 02:12:24 pm
Hola Mariela,
Acabo de actualizar yarn también a la última versión 1.22.5 y concluyó la instalación de dependencias del proyecto sin inconveniente.
Muchas gracias por la asistencia!
Solucionado!