Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - fwhelan

Páginas: [1] 2
1
Migración de Datos / error con migración de datos actividades
« : octubre 29, 2020, 04:49:01 pm »
Estimados buenos días, probé la migración de actividades en un servidor de desarrollo que tenia instalado guarani 3.17 y se migro a guarani 3.18.

Se creo el archivo csv, se guardo en la carpeta Externos\01_schemas\CSV.

Se corrio luego el script_mig_actividades.kjb y me arrojo el siguiente error.

2020/10/29 16:07:16 - upload_mig_actividades - ERROR (version 9.0.0.0-423, build 9.0.0.0-423 from 2020-01-31 04.53.04 by buildguy) : ¡Errores detectados!
2020/10/29 16:07:16 - Salida Tabla.0 - ERROR (version 9.0.0.0-423, build 9.0.0.0-423 from 2020-01-31 04.53.04 by buildguy) : Because of an error, this step can't continue:
2020/10/29 16:07:16 - Salida Tabla.0 - ERROR (version 9.0.0.0-423, build 9.0.0.0-423 from 2020-01-31 04.53.04 by buildguy) : org.pentaho.di.core.exception.KettleValueException:
2020/10/29 16:07:16 - Salida Tabla.0 - Unexpected conversion error while converting value [creditos String] to a Number
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 - creditos String : couldn't convert String to number
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 - creditos String : couldn't convert String to number : non-numeric character found at position 1 for value [-]
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.getNumber(ValueMetaBase.java:2035)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.convertData(ValueMetaBase.java:3858)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.convertBinaryStringToNativeType(ValueMetaBase.java:1621)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.getString(ValueMetaBase.java:1825)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.RowMeta.getString(RowMeta.java:329)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.RowMeta.getString(RowMeta.java:864)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.trans.steps.tableoutput.TableOutput.writeToTable(TableOutput.java:384)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.trans.steps.tableoutput.TableOutput.processRow(TableOutput.java:125)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.trans.step.RunThread.run(RunThread.java:62)
2020/10/29 16:07:16 - Salida Tabla.0 -    at java.lang.Thread.run(Thread.java:748)
2020/10/29 16:07:16 - Salida Tabla.0 - Caused by: org.pentaho.di.core.exception.KettleValueException:
2020/10/29 16:07:16 - Salida Tabla.0 - creditos String : couldn't convert String to number
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 - creditos String : couldn't convert String to number : non-numeric character found at position 1 for value [-]
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.convertStringToNumber(ValueMetaBase.java:1044)
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.getNumber(ValueMetaBase.java:1975)
2020/10/29 16:07:16 - Salida Tabla.0 -    ... 9 more
2020/10/29 16:07:16 - Salida Tabla.0 - Caused by: org.pentaho.di.core.exception.KettleValueException:
2020/10/29 16:07:16 - Salida Tabla.0 - creditos String : couldn't convert String to number : non-numeric character found at position 1 for value [-]
2020/10/29 16:07:16 - Salida Tabla.0 -
2020/10/29 16:07:16 - Salida Tabla.0 -    at org.pentaho.di.core.row.value.ValueMetaBase.convertStringToNumber(ValueMetaBase.java:1037)
2020/10/29 16:07:16 - Salida Tabla.0 -    ... 10 more
2020/10/29 16:07:16 - Salida Tabla.0 - Procesamiento finalizado (EN=0, SA=4420, LE=4421, ES=4000, AC=0, ER=1)
2020/10/29 16:07:16 - upload_mig_actividades - ERROR (version 9.0.0.0-423, build 9.0.0.0-423 from 2020-01-31 04.53.04 by buildguy) : ¡Errores detectados!

Pero seguí con los pasos de la migración, ya que revise y la tabla 'mig_actividades' en el esquema 'ext' estaba creada, y la misma estaba cargada con los datos del csv.

todos los demás scripts se ejecutaron sin problemas, y  los excel de los controles dieron correctos y corroborados.

Pensé que todo había salido bien, y solo había sido un error desconocido en pentaho, pero cuando quiero revisar desde gestión en la opción PROPUESTAS FORMATIVAS\ACTIVIDADES\ADMINISTRAR ACTIVIDADES me aparece el siguiente error.

SQLSTATE[22P05]: Untranslatable character: 7 ERROR: character with byte sequence 0xe2 0x80 0xa6 in encoding "UTF8" has no equivalent in encoding "LATIN1" Más info...

SQLSTATE: db_22P05

CODIGO: 7

MENSAJE: ERROR: character with byte sequence 0xe2 0x80 0xa6 in encoding "UTF8" has no equivalent in encoding "LATIN1"

SQL: SELECT sga_elementos.elemento,\n sga_elementos.codigo,\n sga_elementos.entidad,\n sga_elementos.nombre,\n sga_elementos.nombre_abreviado,\n sga_g3entidades_tipos.entidad_tipo,\n sga_g3entidades_tipos.nombre as tipo_desc,\n sga_g3entidades_subtipos.entidad_subtipo,\n sga_g3entidades_subtipos.nombre as subtipo_desc,\n sga_elementos.estado as estado,\n sga_elementos_estados.descripcion as estado_desc,\n sga_g3entidades.entidad_subtipo,\n sga_g3entidades.entidad\n FROM sga_elementos,\n sga_g3entidades_subtipos,\n sga_g3entidades_tipos,\n sga_elementos_estados,\n sga_g3entidades \n WHERE sga_g3entidades_subtipos.entidad_tipo = "2" AND sga_elementos.entidad_subtipo = sga_g3entidades_subtipos.entidad_subtipo\n AND sga_g3entidades_subtipos.entidad_tipo = sga_g3entidades_tipos.entidad_tipo\n AND sga_elementos.estado = sga_elementos_estados.estado\n AND sga_elementos.entidad = sga_g3entidades.entidad \n ORDER BY sga_elementos.codigo\n ; -- toba_log: 1115011942


lo cual me parece totalmente raro, ya que la base de datos esta en encoding UTF8 , mismo el client_encoding en la base de datos tmb esta en utf8.

Cuando revise en la base de datos el view vw_actividades me aparecen todas las actividades  que migraron.

¿No se cual es el problema, o si yo estoy confundido y estoy buscando mal en gestión la opción para ver las actividades?.

Podrían darme una ayuda.

Gracias!

2
Técnicos / problema con usuario en toba editor 3.0
« : octubre 28, 2020, 10:34:13 am »
Estimados,

En mi servidor de test tenia instalada la versión 3.17 de guaraní y podía ingresar sin problemas al  toba_editor con el usuario toba.  Actualice a la version 3.18 de guarani y en mi toba_editor 3.0 no puedo ingresar con el usuario toba y la clave generica de toba.

Pero sin embargo en el guarani 3.18 si puedo ingresar con usuario toba y su clave generica.

Como puedo reestablecer la clave del usuario toba para el toba_editor?

Muchas Gracias!

3
Técnicos / Consulta sobre certificado de porcentaje de carrera.
« : octubre 26, 2020, 02:16:25 pm »
Estimados

Quería consultar si alguna otra institución realizo alguna vez la personalización de un certificado de porcentaje de carrera.

Estamos necesitando realizar esta personalización  y queríamos saber si por ahí en algún caso alguna otra universidad o el SIU ya la tenia desarrollada y la podían compartir.


Muchas Gracias!

4
Técnicos / Modificar parametro ung_cant_max_folios_libro
« : octubre 22, 2020, 10:23:39 am »
Estimados,

En mi universidad necesitan modificar la cantidad de folios  la cual ahora solamente te deja hasta 10000.

Para realizarlo entre a la tabla en test  3.18 par_parametros_sistema y modifique el valor de esta fila por 1000000 , pero después el cambio no se vio reflejado en test y nuevamente ingrese y sigue estando en 10000.

Debo modificar alguna tabla mas?

Reinicie el apache2 y el postgresql

5
Técnicos / Pedir certificados desde autogestion
« : octubre 21, 2020, 12:47:21 pm »
Estimados, estoy haciendo una prueba en autogestión 3.18 y quiero solicitar un certificado pero cuando voy a la opción, el desplegable no me muestra que certificados puedo seleccionar.

Se que en algún lado, se debía habilitar alguna opción para que se puedan solicitar certificados desde autogestión.

6
Técnicos / Problema con carga de personas Guarani 3.18 produccion
« : octubre 19, 2020, 03:24:44 pm »
Buenos Tardes!

Tengo instalada la versión propia de producción, sin personalizaciones y con la base solo con los datos de inicio. Quise cambiar la clave del usuario toba desde administrar personas, peor cuando accedo a la opción de agregar el mail en datos personales, e ingreso el correo y lo quiero guardar me tira el error email no es valido.

Intente cargar un usuario nuevo, y me da el mismo error.  Los correos ingresados son validos.

Espero su respuesta

Gracias!

7
Técnicos / Consulta sobre versión propia 3.18 para producción
« : octubre 16, 2020, 04:17:34 pm »
Estimados,

Genere una versión propia 3.18.0.1 y la instale en el servidor de producción, todavía no tiene personalizaciones, lo que quería saber es si es la versión correcta la que esta en producción.

Cuando ingreso al sistema me dice Versión 3.18 y en la opción de ayuda me aparece  versión aplicada 3.18.0 base de datos 3.18.0 y revisión  svn: 44318.

Tanto en test como en desarrollo el numero de revisión de svn son iguales pero no es el mismo de producción, obviamente por que se supone que al generar una versión propia, el numero de svn va a cambiar para producción. Pero como puedo saber si esta que aparece en producción es correctamente la versión propia que genere?

Gracias!

8
APP SIU-Guarani / Instalación y Manual API -SIU GUARANI
« : octubre 16, 2020, 12:20:49 pm »
Estimados, buenos dias!


Tengo instalado en un servidor de test gestion y autogestion de guarani 3.18, y estábamos instalando en producción la versión propia, pero no sabíamos  que era la API-REST API-SIU GUARANI, cual es su funcionalidad?  estamos iniciándonos y desconozco cual es su función.

También saber si hay algún manual de instalación para esta API-siu guarani.

Espero su respuesta!

Muchas Gracias!

9
Técnicos / Problema con encoding latin1 en postgres
« : octubre 14, 2020, 03:32:00 pm »
Hola buenas tardes!,

Estoy luchando hace rato con el encoding del postgresql para la instalación de produccion de guarani 3.18, cada vez que quiero crear la BD en LATIN1 me da el siguiente error.

ERROR:  encoding "LATIN1" does not match locale "en_US.UTF-8"
DETALLE:  The chosen LC_CTYPE setting requires encoding "UTF8".

Ya cambie en el servidor el LOCALE y lo puse en es-AR.ISO-8859-1 pero me sigue tirando ese error.

Pasa algo si la base de datos de guarani queda con encoding UTF8 , o saben alguna manera de poder resolver esto?

Otra alternativa era crear la base en utf 8 y después realizar un update de encoding a latin1, pero nose si es la manera correcta.




10
Estimados,

Buenos dias!.

Necesito empezar a instalar la versión 3.18 desde cero en producción. Nosotros contamos con una versión de desarrollo y una versión de test en 3.18, estas ambas tienen habilitado para realizar personalizaciones, pero todavía no comenzamos a realizar las mismas.

Igualmente me están pidiendo que instale en el servidor de producción la versión 3.18.

Como leí en la documentación  https://documentacion.siu.edu.ar/wiki/SIU-Guarani/version3.18.0/instalacion_desde_cero/produccion/gestion/linux  debo generar una versión propia 3.18.x.y, pero obviamente la mía no tendrá personalizaciones.

Mi duda es la siguiente en el servidor de desarrollo donde generare la versión propia de 4 dígitos, tengo habilitada la opción de generar personalizaciones, eso afectaría al servidor de producción?

11
Técnicos / Problema con autogestion 3.18
« : octubre 13, 2020, 02:31:50 pm »
Estimados,

Actualice mi versión de autogestión  en test de 3.17 a 3.18.

Pude ingresar sin problemas pero el problema es que me sale la  barra de opciones de php en el navegador, y quiero que no aparezca.

También utilizo esta consulta, para preguntar como puedo comprobar que mi versión de autogestión desde la web, este correctamente actualizada es decir, que este ingresando a la versión 3.18?






12
Técnicos / Consulta sobre personalizaciones de certificados y actas
« : octubre 09, 2020, 01:53:53 pm »
Estimados,

Estoy ingresando en el mundo de las personalizaciones, y en el videotutorial del siu de personalización de certificados, nos dicen que debemos hacer un svn update para que así tome esta personalización autogestión.

Quisiera saber si solo con el comando svn update funciona, o si debo poner el path, el cual no se cual debería ir, el path donde deje la personalización jasper?, que seria la carpeta de personalizaciones/exportaciones/jasper?

Por otro lado, quería preguntar también, si quisiera hacer el cambio de un label, para que se aplique a todos los certificados, por ejemplo la palabra actividad por materia, y todos los certificados que tengan la palabra actividad, se modifique a materia. Como debería hacerlo? tengo que modificar uno por uno los certificados?

La misma duda tengo para los logos.

Gracias!

13
Técnicos / problema con actualizacion de gurarani 3.17 a 3.18
« : octubre 07, 2020, 07:03:10 pm »
Estimados,

Realice la actualización de versión de 3.17 a 3.18 previamente actualice postgresql a la versión 11 y php a la versión 7.3, también instale el yarn.

la actualización se dio correcta, pero cuando intento ingresar a la url, esta no aparece. A su vez, quiero ingresar a la url vieja y me tira el siguiente error

acceso_web(); } else { die("Es necesario definir la variable 'TOBA_DIR' en el archivo de configuracion de apache (Utilize la directiva 'SetEnv')"); } //-------------------------------------------------------------------------- ?>

este error lo empezó a ejecutar desde el momento que actualice  el php de 7.1 a 7.3 y elimine el 7.1

Lo raro que veo es que  cuando ejecuto svn status me muestra lo siguiente

?       bin/doctrine-dbal
?       bin/php-parse
!       bin/toba.bat
?       sql
M       www/img/logo_grande.png
?       www/img/logo_grande_orig.png

El archivo proyecto.ini me entrega lo siguiente

[proyecto]
id = guarani
nombre = SIU-Guarani
descripcion = "Sistema de Gesti▒n Acad▒mica"
mail_soporte = guarani@siu.edu.ar
url_ayuda = doc/
url_ayuda_agregar_extension = 1
version = "3.18.0"
historico_versiones = [3.1.0,3.2.0,3.3.0,3.4.0,3.4.1,3.5.0,3.6.0,3.7.0,3.8.0,3.8.1,3.8.2,3.9.0,3.10.0,3.10.1,3.10.2,3.10.3,3.11.0,3.11.1,3.11.2,3.12.0,3.13.0,3.13.1,3.13.2,3.14.0,3.15.0,3.15.1,3.16.0,3.16.1,3.16.2,3.17.0,3.17.1,3.18.0]
controlar_versiones_app_bd = 1
css=css/instalador_guarani.css
permite_cambio_perfil_funcional = 1


[controles]
version_postgres = "error|11.6"
version_php = "error|7.3"
magic_quotes = "error|"
upload = "warning|8|"
memory_limit = "warning|512|"
suhosin_patch= "warning|"
pdo_pgsql = "error|"
zip = "error|El sistema utiliza la librer▒a ZIP de php para el intercambio de datos con otras aplicaciones. "
gd = "warning|El sistema utiliza la librer▒a GD de PHP para la manipulaci▒n de im▒genes en algunos servicios. Sin esta librer▒a es posible que algunas operaciones no se presenten correctamente."
mbstring = "warning|"
curl = "warning|El sistema utiliza la librer▒a CURL para el modulo de env▒o de mensajes, sin esta librer▒a, el mismo no funcionar▒ correctamente."

Y el archivo  bases.ini me da como motor postgres7  y yo tengo instalado el 11, migre el cluster y elimine el de la version 9.6
[guarani3]
motor = "postgres7"
profile = "localhost"
usuario = "postgres"
base = "guarani3"
puerto = "5432"
encoding = "LATIN1"
schema = "desarrollo"

Por ultimo el archivo toba.conf me da lo siguiente, me sigue mostrando 3.17 y la versión de apache que tengo instalada es Server versión: Apache/2.4.29 (Ubuntu)

 #Proyecto: guarani
        Alias /guarani/3.17 "/guarani/proyectos/SIU-Guarani/www/"
        <Directory "/guarani/proyectos/SIU-Guarani/www/">
                SetEnv TOBA_DIR                 "/guarani/proyectos/SIU-Guarani/vendor/siu-toba/framework"
                SetEnv TOBA_PROYECTO    "guarani"
                SetEnv TOBA_INSTALACION_DIR "/guarani/proyectos/SIU-Guarani/instalacion"
                SetEnv TOBA_INSTANCIA   "desarrollo"
                DirectoryIndex aplicacion.php

                AllowOverride None
                <IfModule !mod_access_compat.c>
                #Apache 2.2.x
                ##Piense en actualizar la version del web server a Apache 2.4.x al menos
                ##Si desea seguir en esta version, descomente las siguientes lineas
                #       Order allow,deny
                #       Allow from all
                </IfModule>
                <IfModule mod_access_compat.c>
                        #Apache 2.3.x/2.4.x  back-comp (deprecated)
                        Order allow,deny
                        Allow from all
                </IfModule>
                <IfModule mod_authz_core.c>
                        #Apache 2.4.x
                        Require all granted
                </IfModule>

                #API REST
                RewriteEngine On
                RewriteBase /guarani/3.17
                Options FollowSymLinks SymLinksIfOwnerMatch
                RewriteRule ^rest/(.*)$ rest.php/$1 [PT,L,QSA]
                RewriteRule ^rest$      rest.php/   [PT,L,QSA]
                SetEnvIf Authorization "(.*)" HTTP_AUTHORIZATION=$1
        </Directory>

Por ultimo el archivo instancia.ini dentro de i__desarrollo me da el siguiente resultado
[guarani]
path = "/guarani/proyectos/SIU-Guarani"
url = "/guarani/3.17"
url_pers = "/guarani_pers/3.17"

me sigue marcando 3.17 y en enabled sites del apache también tengo 3.17

claramente hay algo que no me actualizo bien, o algún error cometí. Seguí todos los pasos tal cual el manual indicaba.

Me podrán dar una mano?

Saludos!

14
Técnicos / Consulta generación de BD para migracion externa 3.17
« : octubre 02, 2020, 02:30:42 pm »
Buenas tardes, esta pregunta tal vez es mas relacionada con migración, pero la cargue en el foro de migración y no obtuve respuestas hasta el momento y las necesito cuanto antes.

Estoy instalando por primera vez en el servidor de test, el pentaho kettle para la migración de sistemas externos. En la documentación de la wiki,  después de leer e instalar toda la parte del pentaho-kettle, el siguiente paso es EL SISTEMA: SIU-GUARANI3 y en la sección que dice instalación dice seguir los pasos del instructivo de instalación del guaraní, lo cual ya esta hecho cuando instale el proyecto en la versión de test, actualmente se estuvo trabajando en esta BD, y luego dice correr el comando instalar que crea una nueva base vacía con los metadatos de siu guaraní 3.

Mi pregunta es la siguiente, ¿esto borra la base que genere y en la cual estuve trabajando, cuando instale el proyecto guarani3? o ¿me genera una base alternativa donde va a guardar los datos que voy a migrar desde el sistema externo?

Otra duda que tengo, es si necesito algún script que ya venga predeterminado, para correr  el esquema EXT, ya que no lo encuentro o no se bien donde buscarlo.

¿Dónde encuentro el siguiente trabajo Externos/01_Schema/00_Esquema/esquema_ext.kjb?

disculpen pero soy nuevo en este sistema y me estoy interiorizando.

gracias

15
Técnicos / kettle-pentaho.org no se puede descargar
« : octubre 01, 2020, 12:01:19 pm »
Buenos días,

Tengo un problema ingreso al link   http://kettle.pentaho.org que aparece en la documentación del guaraní 3.17 para migrar desde sistemas externos, pero ese link me lleva a una pagina de Hitachi donde me pide un usuario y contraseña.

Encontré el siguiente link https://www.ubuntupit.com/how-to-install-pentaho-data-integration-pdi-tool-on-ubuntu/ desde una documentación de siu diaguita.

Este link me otorga el pentaho 9..me sirve para guaraní este mismo?,

También me pide que instale la versión de java 1.8 y si tengo una superior que la desinstale e instale esta ultima. Mi versión de java es

openjdk version "11.0.4" 2019-07-16
OpenJDK Runtime Environment (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3)
OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Ubuntu-1ubuntu218.04.3, mixed mode, sharing)

Debo desinstalarla e instalar la 1.8?

gracias

Páginas: [1] 2