Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - Sergio F. Vier

Páginas: [1] 2 3 ... 30
1
Araí - Usuarios / Re:[SOLUCIONADO] Instalación Arai-Usuarios
« : junio 13, 2018, 02:18:01 pm »
Buen ojo Sebastián!

Ahora lo corrijo en la documentación, muchas gracias!

2
Claro!

En el arai.json es donde han de indicar que quieren efectivamente registrar uno de aplicación|api rest|servicio en la plataforma.

En todo esto la documentación se va actualizando constantemente, mejorándola para tratar de cubrir lo humanamente posible. Disculpen si no lo llegamos a mejorar a tiempo.

Saludos!

3
Hola Javier,

No no aparecen errores, pero la aplicacion nunca se nos muestra en arai usuarios (Versión 2.0.3).

Tenes idea de por donde puede venir el problema?

Vamos por puntos:
  • Me confirmas que en el ABM de aplicaciones no les figura?
  • podrías pasar el contenido del archivo config/idp.yml ?
  • en la aplicación, en instalacion/i__produccion/instancia.ini la entrada de la aplicación contiene una clave full_url
  • en la aplicación, podrían mostrar el contenido de arai.json

Al momento de hacer sync en Arai-Usuarios  es donde se crea/actualiza la aplicación.  Es por eso que resulta extraño que no vean su aplicación en este mensaje:

Citar
...
Configuring SP: https://usuarios2.unr.edu.ar:443/gestion/default-sp
Actualizado siu/huarpe_1
Actualizado siu/arai-usuarios_1
Se sincronizó correctamente

4
Araí - Usuarios / Re:Instalación Arai-Usuarios
« : junio 05, 2018, 02:23:47 pm »
Un solo detalle, siguiendo el ejemplo de instalación se generan 2 archivos, pero uno .crt y el otro .key
Ahora veo si cambio en la configuración que sea .pem

No afecta en nada la extensión en sí... sí la forma en que se genera.

5
Javier,

Hoy por hoy las aplicaciones registradas a la plataforma, quedan registradas. Si las remueven con Registry (desde el server de Registry) solo desaparecen de allí. Luego tienen que dirigirse a cada aplicación cliente y ejecutar un sync para que (si era cliente de la aplicación eliminada) nos elimine su registro.

Adicionalmente, Araí-Usuarios tiene un comportamiento (extraño, pero feature al fin) que si se elimina una app de Registry, no se elimina del ABM de aplicaciones. Quizá tengamos que reveer esta funcionalidad. Por lo pronto, pueden dirigirse a dicho ABM y eliminar manualmente la aplicación que deseen dejar de proveer.

Saludos!

6
Araí - Usuarios / Re:Instalación Arai-Usuarios
« : junio 04, 2018, 03:39:12 pm »
Hola Sebastián,

Perfecto, solo para aclarar, la versión 2 de la plataforma no es compatible con la 1 y se requiere realizar una nueva instalación.

Por otro lado, algunas dudas me quedan:

1. generaron los certificados del IDP (comando generar-certs-idp)? antes de instalar Arai-Usuarios?

Citar
...Could not find PEM encoded certificate in "/usr/local/siu/usuarios/config/certs_idp/certificado_idp.key" ...

2.  tiene pinta que o no quedó bien generado el par de certificados... o de alguna forma el IDP (mediante el server apache) no está pudiendo leerlos.  Son dos (un .crt y un .pem en gral.) y tienen que ser publico/privado, lo tienen? bien configurado en arai-usuarios.env al momento de instalar?
3.  En la doc del hub que es por versión, hay una guía como generar manualmente los certificados.

En el momento de instalar (en todo momento en realidad pues no afecta en nada es read-only), pueden correr un "proyecto:verificar" para que evalúen los requisitos para la instalación. Pueden usarlo para verificar.

Saludos!

7
SIU - Huarpe / Re:Error en la extensión libsodium
« : junio 04, 2018, 03:19:12 pm »
Juan, vamos por parte como diría Jack

1. tenes instalado nodejs?
2. tenes instalado modulo bower (de npm)?
2. tenes instalado modulo less (de npm)?

Una vez que los tengas bien instalados, ejecutá un "composer install" (se lanzan operaciones de descarga por background). El instalador estába validando que no ubica dichos módulos (revisen el log del instalador).




8
SIU - Huarpe / Re:Error en la extensión libsodium
« : junio 04, 2018, 12:40:36 pm »
Hola Juan

[ ERROR ] PHP: La extensión libsodium no se encuentra instalada en el sistema o no se está en la versión esperada.

Para una guía rápida sobre como configurar Sodium, ver la documentación en la wiki.

y no hay manera de solucionarlo. me comentaron que la versión 7.2 de php es la que tenia compatibilidad, el tema es que a la hora de hacer los chequeos en el proyecto:verificar solo se puede con la versión de php 7.2.0 y la versión que se baja en los repositorios es la 7.2.6 y no me deja avanzar

Estos son los requerimientos de SIU-Araí 2.0.

Espero les sea de utilidad. Ante cualquier duda estamos a disposición.

Saludos!

9
Bien!

La documentación la fuimos actualizando para ayudar a realizar esta integración. Espero que les pueda servir de ayuda también.

Saludos!

10
Hola Oscar,

Es como que Registry no está actualizando bien !!!, no se que puede ser.

Analicemos.
  • ./bin/arai-cli registry:status en cada una de las aplicaciones registradas (te dará la URL de Registry)
  • ./bin/console packages:list en Registry para ver los servicios registrados (tendrán los ID para comparar con las apps)

No entiendo muy bien el tema de que siga haciendo referencia a la dirección de la aplicación:
  • Al momento de hacer login (te lleba al IDP viejo?)
  • en Huarpe, el icono de la app es la url vieja?
  • otro?
  • en el ABM de aplicaciones en ARAI-Usuarios que hay?

Tips alternativos. Recuerden siempre luego de sincronizar una app, hacer el sync en Usuarios. Huarpe requiere que se limpie la caché luego de realizar algun cambio.

Saludos!

11
Araí - Usuarios / Re:instalacion arai-usuarios
« : junio 01, 2018, 08:08:19 am »
Tengan en cuenta revisar los requerimientos de la plataforma. Además, para todo lo que sea Sodium tenemos esta guía para comprender mejor que necesitan tener andando.

Por otro lado, PHP 7.2 no está soportado aún... utilizamos librerías que hoy dependen de mcrypt y como saben dicha extensión fué deprecada en la última versión de PHP.

Saludos!

12
Araí - Usuarios / Re:instalacion arai-usuarios
« : mayo 30, 2018, 07:00:13 am »
Hola Agustin,

Hola, estoy instalando arai usuarios y se me presento un problema con los parámetros de instalación.
Para instalar comento el parámetro opcional
Código: [Seleccionar]
##### CONFIG API REST #####
REST_SERVIDOR_AUTH=basic
#REST_ARAI_SYNC_KEY_FILE="/ruta/arai-sync.key"

Como se detalla en la documentación específica de la versión, este parámetro permite dar una ruta "distinta" donde alojar la key. Por eso es opcional.


me da error por no tener configurado el parámetro opcional

Código: [Seleccionar]
  No se puede leer el certificado '/home/agrup/Proyecto/Portal/arai-usuarios/instalacion/arai-sync.key' para sincronizar con Arai-Registry configu 
  rado en el archivo 'instalacion.ini'   

Esto quiere decir que no existe en esa ruta el archivo que contiene la clave para encriptar la sincronización. Al momento de instalar se verifican los requerimientos, podes revisar en el instalador.log a ver si pasó algo (la clave para encriptarla sincronización se genera al momento de instalar).

Saludos!

13
Araí - Registry / Re:Error con certificado al tratar de registar
« : mayo 29, 2018, 04:37:29 pm »
Hola Oscar,

Pero cuando quiero sincronizar me sale un error
Citar
C:\toba3\weme>arai-cli registry:sync
El valor a encriptar no puede ser vacío

Agradeceré cualquier pista que puedan darme para solucionar este inconveniente.

Eso sucede cuando en el paso sync no se pudo encriptar la clave del cliente rest (de la app que uds desarrollan) para mandarla a Registry.  Pudo pasar varias cosas, pero me decanto que puede ser por la configuración del cliente.ini (esta app es cliente de api rest, entonces uds tuvieron que configurar previamente el cliente.ini).

En la respuesta previa tmb. se trata del cliente.ini. Eso es parte del manejo del framework Toba y este lo suele generar automáticamente e incluso proporciona unos comandos de consola para realizarlo.

Saludos!

14
Araí - Registry / Re:Error con certificado al tratar de registar
« : mayo 29, 2018, 04:07:30 pm »
Hola Javier,

Notice: Undefined index: auth_usuario

Efectivamente, les está faltando configurar el cliente.ini del servicio rest al cual se van a conectar desde esta app que están desarrollando. Araí espera que su aplicación, luego de indicar en el arai.json que consumen una api de otro sistema, indiquen en una ruta similar a /ruta/instalacion/i__produccion/p__id-sistema/rest/id-servicio-consumido/cliente.ini los datos de acceso (auth_usuario, auth_password dentro de una sección [conexion]) (al instalar un proyecto toba, crea ese archivo por lo gral. vacío, si definieron desde toba_editor que consumen un servicio rest).

Vamos a agregar mayores controles al sync para evitar estos traspiés. Saludos!

15
Araí - Registry / Re:Error con certificado al tratar de registar
« : mayo 22, 2018, 02:59:53 pm »
Hola Oscar,

Dos cosas:
Son certificados autofirmados los que usan? En cualquier caso pareciera que hay que agregar la CA o actualizar la lista de CA del S.O. Por algún motivo no lo está ubicando.

Saludos!

Páginas: [1] 2 3 ... 30