Autor Tema: error en instalador de 3.1.0  (Leído 72 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dspagnuolo

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Dario Spagnuolo
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
error en instalador de 3.1.0
« : abril 05, 2017, 04:37:06 pm »
buenas tardes,
estoy probando la versión 3.1.0, pero me esta dando error al abrir el instalador,
directamente me aparece una pantalla en blanco... en el log de Apache encontre el siguiente mensaje:

[Wed Apr 05 16:32:08 2017] [error] [client 181.28.242.135] PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 64 bytes) in /var/www/i_mapuche_3.1.0/lib/configuracion.php on line 16

[Wed Apr 05 16:09:04 2017] [error] [client 192.168.0.3] PHP Fatal error:  Allowed memory size of 4294967296 bytes exhausted (tried to allocate 77 bytes) in /var/www/i_mapuche_3.1.0/lib/configuracion.php on line 16


lo probe en 2 servidores distintos y los dos dan el mismo error. que puede estar pasando?

Gracias!
Dario



mariela

  • Moderador
  • *****
  • Mensajes: 202
    • Ver Perfil
    • Email
  • Institución: Consorcio SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:error en instalador de 3.1.0
« Respuesta #1 : abril 05, 2017, 07:18:58 pm »
Hola Darío, cual es el memory_limit asignado en el php.ini?, probaste con asignarle mas memoria y ver si persiste el error?

Saludos,
Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
Consorcio SIU
http://www.siu.edu.ar

dspagnuolo

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Dario Spagnuolo
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:error en instalador de 3.1.0
« Respuesta #2 : abril 06, 2017, 12:35:15 pm »
Hola Mariela,
en uno de los servidores estaba en 2Gb y en otro en 4Gb.
lo raro es que ambos servidores ya tienen productivo el mapuche en versión 3.0.2 sin inconvenientes, y el problema lo da al querer abrir este nuevo instalador.

dspagnuolo

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Dario Spagnuolo
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:error en instalador de 3.1.0
« Respuesta #3 : abril 10, 2017, 11:36:38 am »
Para agregar información al tema, en los servidores donde no me esta funcionando son:
sistema operavitov Debian 7 (Linux mapuche 3.2.0-4-amd64 #1 SMP Debian 3.2.81-2 x86_64 )
Apache 2.2
PHP Version 5.4.45-0+deb7u5

Lo probe en un windows con Apache 2.2 y PHP Version 5.3 y funciona correctamente

puede ser que sea un tema de la versión de PHP?

mariela

  • Moderador
  • *****
  • Mensajes: 202
    • Ver Perfil
    • Email
  • Institución: Consorcio SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:error en instalador de 3.1.0
« Respuesta #4 : abril 10, 2017, 01:18:04 pm »
Probablemente sea la versión de PHP, podes probar con una versión de php 5.5?
Gracias
Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
Consorcio SIU
http://www.siu.edu.ar

dspagnuolo

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Dario Spagnuolo
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:error en instalador de 3.1.0
« Respuesta #5 : abril 13, 2017, 02:51:08 pm »
Hola,
probe en un servidor de desarrollo la actualización a PHP 5.5 y no funciono.
puede ser algun otro problema con el Apache o bien con el Debian 7 ?
revisando en foros, la mayoría de las soluciones apuntan a modificar el codigo que se esta ejecutando.

sabes si alguien lo probo con estas especificaciones?

Gracias!

Marco Mora

  • General Guarani
  • *
  • Mensajes: 66
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Comahue
  • Nombre y apellido: Marco Andres Mora
  • Sistema: SIU - Mapuche
  • Teléfono laboral: 4490300
Re:error en instalador de 3.1.0
« Respuesta #6 : abril 17, 2017, 12:23:00 pm »
Hola Darío.

Nosotros hicimos pruebas en un servidor virtualizado con 2 GB de RAM
Debian 7
PHP 5.4.45
Apache/2.2.22 (Debian)

la configuración que tengo  de php es:
/etc/php5/apache2/php.ini -> memory_limit 1024MB;
/etc/php5/cli/php.ini  -> memory_limit -1;

No probé hacer un cambio de versión sino una instalación desde cero con datos demo y funcionó bien
Area SiU Mapuche
Universidad Nacional del Comahue

dspagnuolo

  • Newbie
  • *
  • Mensajes: 18
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Dario Spagnuolo
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:error en instalador de 3.1.0
« Respuesta #7 : abril 18, 2017, 02:21:08 pm »
Hola!
el problema resulto ser que al generar el  ZIP para subirlo al servidor, este quedo generado con menos archivos, y ese era el motivo del error.

gracias y disculpen las molestias!
Dario

 

Comunidad SIU