Autor Tema: Instalacion Huarpe  (Leído 273 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 390
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Instalacion Huarpe
« Respuesta #15 : mayo 18, 2017, 12:25:52 pm »
Hola, excelente!!! Ya estamos mas cerca

huarpe.unr.edu.ar:443:0 server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
huarpe.unr.edu.ar:443:0 server certificate does NOT include an ID which matches the server name

¿Será algún problema cuando generé  los certificados para huarpe?

Si, efectivamente eso ya es cuestión de como están generados los certificados SSL para servidor que han configurado en el apache de huarpe.  Hay muchos tutoriales de como generar los de tipo autofirmados o simples. Lo ideal es que para producción sean certificados válidos....

Saludos!
happy coding!!

javierb

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
    • Email
  • Institución: UNR
  • Nombre y apellido: Javier Bonfanti
  • Sistema: Arai
  • Teléfono laboral: +54 341 - 4201200 int. 450
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion Huarpe
« Respuesta #16 : mayo 19, 2017, 10:20:34 am »
Perfecto, ya logré  que  superar eso tambien. Pero sigo con el error 500.

El log de huarpe (prod.log)

[2017-05-19 10:13:51] app.ERROR: No route found for "GET /portal" [] []
[2017-05-19 10:13:51] request.CRITICAL: Uncaught PHP Exception Twig_Error_Runtime: "An exception has been thrown during the rendering of a template ("The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL.")." at /opt/huarpe-core/src/CoreBundle/Resources/views/Layout/_leftmenu.html.twig line 20 {"exception":"[object] (Twig_Error_Runtime(code: 0): An exception has been thrown during the rendering of a template (\"The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL.\"). at /opt/huarpe-core/src/CoreBundle/Resources/views/Layout/_leftmenu.html.twig:20, Symfony\\Component\\Security\\Core\\Exception\\AuthenticationCredentialsNotFoundException(code: 0): The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL. at /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Component/Security/Core/Authorization/AuthorizationChecker.php:57)"} []

¿Tenés idea que puede ser esto?

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 390
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Instalacion Huarpe
« Respuesta #17 : mayo 19, 2017, 12:19:42 pm »
[2017-05-19 10:13:51] app.ERROR: No route found for "GET /portal" [] []

Te consulto, estás instalando Huarpe para accederlo mediante una url directa o con un alias... porque tenés un /portal ahi. En el virtualhost deberías tener el alias /portal definido... si fuera así.

[2017-05-19 10:13:51] request.CRITICAL: Uncaught PHP Exception Twig_Error_Runtime: "An exception has been thrown during the rendering of a template ("The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL.")." at /opt/huarpe-core/src/CoreBundle/Resources/views/Layout/_leftmenu.html.twig line 20 {"exception":"[object] (Twig_Error_Runtime(code: 0): An exception has been thrown during the rendering of a template (\"The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL.\"). at /opt/huarpe-core/src/CoreBundle/Resources/views/Layout/_leftmenu.html.twig:20, Symfony\\Component\\Security\\Core\\Exception\\AuthenticationCredentialsNotFoundException(code: 0): The token storage contains no authentication token. One possible reason may be that there is no firewall configured for this URL. at /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Component/Security/Core/Authorization/AuthorizationChecker.php:57)"} []

¿Tenés idea que puede ser esto?

Es un error de autenticación, extraño. Es porque no está autenticado el usuario.... un par de preguntas:

* ¿Estas utilizando Huarpe descargado desde master, develop, v1.0.1? Debería ser o master (que sigue la última estable) o v1.0.x en caso de una versión específica.
* ¿Probaste limpiar la cache de Huarpe?  Ver 5. Corregir permisos
* También ejecutalo en modo desarrollo, /app_dev.php...

Saludos!
happy coding!!

javierb

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
    • Email
  • Institución: UNR
  • Nombre y apellido: Javier Bonfanti
  • Sistema: Arai
  • Teléfono laboral: +54 341 - 4201200 int. 450
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion Huarpe
« Respuesta #18 : mayo 19, 2017, 12:48:02 pm »
Me fijo, te queria decir respecto de los permisos que:
si ejecuto ${HUARPE_PATH}/bin/console huarpe:update-permisos-archivos apache
sigue intentndo ejecutar el chown on www-data

javierb

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
    • Email
  • Institución: UNR
  • Nombre y apellido: Javier Bonfanti
  • Sistema: Arai
  • Teléfono laboral: +54 341 - 4201200 int. 450
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion Huarpe
« Respuesta #19 : mayo 22, 2017, 09:33:49 am »
Respecto del alias "/portal" esto solo s e encuentra en las variables de entorno definidas en la instalacion de arai-usuarios
"export ARAI_USUARIOS_URL_PORTAL=https://huarpe.unr.edu.ar/portal"
La cual impacta en el archivo idp.yml de arai-usuarios
url_app_defecto: 'https://huarpe.unr.edu.ar/portal'

Es ahi unicamente donde tengo "/portal"

como figura en la instalacion de arai -usuarios

# configuracion del idp
export ARAI_USUARIOS_URL_PORTAL=http://url.huarpe/portal
export ARAI_USUARIOS_USER_URL_PERFIL=http://url.huarpe/perfil


De todas formas, si le saco el /portal, tampoco funciona y obtengo el error:

SimpleSAML_Error_MetadataNotFound: METADATANOTFOUND('%' => '\\'https://huarpe.unr.edu.ar/simplesaml/module.php/saml/sp/metadata.php/default-sp\\'')
Backtrace:
3 /opt/arai-usuarios/idp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:301 (SimpleSAML_Metadata_MetaDataStorageHandler::getMetaData)
2 /opt/arai-usuarios/idp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:318 (SimpleSAML_Metadata_MetaDataStorageHandler::getMetaDataConfig)
1 /opt/arai-usuarios/idp/modules/saml/lib/IdP/SAML2.php:360 (sspmod_saml_IdP_SAML2::receiveAuthnRequest)
0 /opt/arai-usuarios/idp/www/saml2/idp/SSOService.php:18 (N/A)
Error report with id ed93d0ba generated.

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 390
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Instalacion Huarpe
« Respuesta #20 : mayo 23, 2017, 08:34:11 am »
De todas formas, si le saco el /portal, tampoco funciona y obtengo el error:

SimpleSAML_Error_MetadataNotFound: METADATANOTFOUND('%' => '\\'https://huarpe.unr.edu.ar/simplesaml/module.php/saml/sp/metadata.php/default-sp\\'')

Javier, puedo reproducir el error que reportas, dejame que lo vea y vemos de solucionarlo. Por cierto, el /portal es una ruta interna en Huarpe así que está bien.
happy coding!!

 

Comunidad SIU