Autor Tema: Problemas con el Tablero de Instalaciones  (Leído 138 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Gustavo Ernesto Olmedo

  • General Guarani
  • *
  • Mensajes: 128
    • Ver Perfil
    • Dirección General de Servicios Informáticos
    • Email
  • Institución: Universidad Nacional de Formosa
  • Nombre y apellido: Gustavo Ernesto Olmedo
  • Sistema: Guaraní
  • Teléfono laboral: 0370-4454004
  • Utilizo algun sistéma del SIU: Sí
Problemas con el Tablero de Instalaciones
« : mayo 19, 2017, 07:19:22 pm »
Estimados,
siguiendo el instructivo correspondiente al wichi versión 6.1, en el punto 5.2.2 Tablero de Instalaciones, no ocurre nada cuando intento agregar una nueva instalación o bien modificar las dos que vienen por defecto.
Adjunto el log para que puedan orientarme.
Saludos cordiales

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 186
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #1 : mayo 22, 2017, 08:32:22 am »
Hola Gustavo, en el log encontré el siguiente error:

ERROR [JDBCExceptionReporter] ERROR: no existe la columna am.amcanorder

Por lo que estuve leyendo es un error de postgresql 9.6. 
Que versión de postgres tenes instalada? bajaste el driver para esa versión? Paso 2.2.4.1. Instalación del driver PostgreSQL de la guía.
Saludos,
Sabrina.

Gustavo Ernesto Olmedo

  • General Guarani
  • *
  • Mensajes: 128
    • Ver Perfil
    • Dirección General de Servicios Informáticos
    • Email
  • Institución: Universidad Nacional de Formosa
  • Nombre y apellido: Gustavo Ernesto Olmedo
  • Sistema: Guaraní
  • Teléfono laboral: 0370-4454004
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #2 : mayo 22, 2017, 07:23:49 pm »
Estimada Sabrina,
tal como mencionás tengo instalado el postgresql 9.6 y olvidé el driver correspondiente. De acuerdo a la página de drivers de  postgres, para la versión 7 de Java corresponde JDBC versión 4.1, yo descargué el archivo "postgresql-42.0.0.jre7.jar" (que es uno de los que corresponde de acuerdo a la tabla).
Igualmente no puedo  agregar una nueva instalación ni  modificar las dos que vienen por defecto.
Adjunto la salida del log y espero sugerencias.
Saludos cordiales.

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 186
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #3 : mayo 23, 2017, 08:37:44 am »
Hola Gustavo, no tendrás un problema de permisos? proba iniciando pentaho con root.
Si el problema persiste, por favor, enviame los archivos de configuración:

applicationContext-spring-security-hibernate.properties
El archivo se encuentra en el directorio /biserver-ce/pentaho-solutions/system/ .
hibernate-settings.xml
El archivo se encuentra en el directorio /biserver-ce/pentaho-solutions/system/hibernate
postgresql.hibernate.cfg.xml
El archivo se encuentra en el directorio /biserver-ce/pentaho-solutions/system/hibernate/ .
repository.xml
El archivo se encuentra en el directorio /biserver-ce/pentaho-solutions/system/jackrabbit.
server.properties ubicado en biserver-ce/pentaho-solutions/system/
el archivo pentahoObjects.spring.xml ubicado en pentaho-solutions/system/.
el archivo pentaho.xml ubicado en /biserver-ce/pentaho-solutions/system/
el archivo plugin.xml ubicado en biserver-ce/pentaho-solutions/system/default-plugin/,
el archivo importExport.xml ubicado en biserver-ce/pentaho-solutions/system/
el archivo ImportHandlerMimeTypeDefinitions.xml ubicado en biserver-ce/pentaho-solutions/system/
el archivo saiku.min.js ubicado en /biserver-ce/pentaho-solutions/system/saiku/ui/
el archivo SaikuWidgetComponent.js ubicado en la carpeta /biserver-ce/pentaho-solutions/system/saiku/components/saikuWidget/.
el archivo SaikuEmbed.js ubicado en /biserver-ce/pentaho-solutions/system/saiku/ui/js/saiku/embed
context.xml ubicado en el directorio  /biserver-ce/tomcat/webapps/pentaho/META-INF/ .
el archivo web.xml ubicado en /biserver-ce/tomcat/webapps/pentaho/WEB-INF.
el archivo classic-engine.properties ubicado en biserver-ce/tomcat/webapps/pentaho/WEB-INF/classes
el archivo mondrian-schema-mapping.properties dentro de  biserver-ce/tomcat/webapps/pentaho/WEB-INF/classes/
el archivo server.xml ubicado en  /biserver-ce/tomcat/conf/

Saludos,
Sabrina.

Gustavo Ernesto Olmedo

  • General Guarani
  • *
  • Mensajes: 128
    • Ver Perfil
    • Dirección General de Servicios Informáticos
    • Email
  • Institución: Universidad Nacional de Formosa
  • Nombre y apellido: Gustavo Ernesto Olmedo
  • Sistema: Guaraní
  • Teléfono laboral: 0370-4454004
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #4 : mayo 23, 2017, 02:38:12 pm »
Estimada Sabrina,
inicié el pentaho con el usuario root y continúa igual.
Te adjunto lo solicitado.
Saludos cordiales.

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 186
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #5 : mayo 24, 2017, 08:48:01 am »
Hola Gustavo, te paso tres archivos modificados, igualmente el que realmente importa es el repository.xml (los otros dos son configuraciones de seguridad), no lo habías cambiado a la conexión a postgres, no se si fue adrede o se te paso... Si tu intensión es no conectarlo a postgres hay que cambiar algunas configuraciones, nosotros aconsejamos conectarlo con postgres ya que luego hay etl q lo requieren.

Reemplazar el archivo repository.xml  en el directorio /biserver-ce/pentaho-solutions/system/jackrabbit

Gustavo Ernesto Olmedo

  • General Guarani
  • *
  • Mensajes: 128
    • Ver Perfil
    • Dirección General de Servicios Informáticos
    • Email
  • Institución: Universidad Nacional de Formosa
  • Nombre y apellido: Gustavo Ernesto Olmedo
  • Sistema: Guaraní
  • Teléfono laboral: 0370-4454004
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #6 : mayo 26, 2017, 05:08:09 pm »
Estimada Sabrina,
con las modificaciones indicadas, anduvo diez puntos.
¡Muchas Gracias!
Saludos cordiales.

sbaisi

  • Moderador Global
  • *****
  • Mensajes: 186
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sabrina Baisi
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas con el Tablero de Instalaciones
« Respuesta #7 : mayo 29, 2017, 08:20:39 am »
Buenisimo!!!
Saludos!

 

Comunidad SIU