Autor Tema: Instalacion - requisitos  (Leído 284 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Jaco

  • Full Member
  • ***
  • Mensajes: 131
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Rosario
  • Nombre y apellido: Pablo Jacobson
  • Sistema: SIU Guarani 3
Instalacion - requisitos
« : agosto 23, 2017, 11:25:13 am »
Hola, estaba por probar por primera vez instalar la versión 3.x.
Siempre había instalado todo a mano y es la primera vez que voy a probar el docker y quería saber qué requisitos mínimos debo tener instalados, ya que no los veo, en cuanto a versión de Apache, PHP Y postgres. Veo que ya soporta PHP 7.x, y quería saber si es la versión que ya recomiendan instalar.
Saludos.
Pablo

richard

  • Moderador Global
  • *****
  • Mensajes: 2442
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Instalacion - requisitos
« Respuesta #1 : agosto 23, 2017, 05:59:04 pm »
Hola Pablo,
Hola, estaba por probar por primera vez instalar la versión 3.x.
Siempre había instalado todo a mano y es la primera vez que voy a probar el docker y quería saber qué requisitos mínimos debo tener instalados, ya que no los veo, en cuanto a versión de Apache, PHP Y postgres. Veo que ya soporta PHP 7.x, y quería saber si es la versión que ya recomiendan instalar.

estas por hacer una instalación para un proyecto nuevo o para migrar uno que traes de antes?, tené en cuenta que cambio sustancialmente el rol de Toba dentro de los proyectos.
En caso de estar arrancando un proyecto nuevo, te recomiendo que leas aqui, de paso podes ver como se esta planteando la config para docker y su uso.

En cuanto a la version de PHP, siempre es lo mas recomendable estar lo mas al dia posible para no caernos del ciclo de vida  y quedar en una rama sin soporte. Por el momento, 5.6 zafa minimamente.. pero no menos que eso, si dispones de PHP 7.0 mejor.. yo estoy desarrollando en 7.1.x pero depende del repositorio, en algun caso ya perdio la extensión mcrypt lo que trae problemas ya que es requerida por una de la libs que usamos.

Saludos


Twitter es al incontinente verbal,  lo que los dulces al diabetico.

Jaco

  • Full Member
  • ***
  • Mensajes: 131
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Rosario
  • Nombre y apellido: Pablo Jacobson
  • Sistema: SIU Guarani 3
Lista de requisitos
« Respuesta #2 : marzo 27, 2018, 05:42:10 pm »
Hola, voy a instalar por primera vez la versión 3.x de toba.
Hay una lista de prerequisitos completo con sus versiones.
En  las versiones 2.x detallaban bien :
Apacache xx
PHP 5.xx con los módulos ......
Postgres .....

Acá no encuentro esta lista detallada. Me guiarían a donde está publicado esto.
Gracias.
Pablo

richard

  • Moderador Global
  • *****
  • Mensajes: 2442
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Instalacion - requisitos
« Respuesta #3 : abril 05, 2018, 10:06:52 am »
Hola Pablo,
te combine el tema porque es algo que ya habias preguntado el año pasado y por ahi te quedo traspapelado.
Fijate que en el link que te pase en el post se detalla lo que se debe instalar, las versiones especificas no se mencionan ya que se apunta a las ultimas en lo posible (salvo la de PHP que se controla via composer).

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.