Autor Tema: Problemas con el modulo de SQ_PAGOS  (Leído 524 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dbogado

  • Jr. Member
  • **
  • Mensajes: 99
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Oeste
  • Nombre y apellido: Diego Bogado
  • Sistema: SIU-Diaguita, SIU-Pilaga, SIU-Guarani, SIU-Wichi.
  • Teléfono laboral: 02204834192
Problemas con el modulo de SQ_PAGOS
« : septiembre 27, 2017, 03:25:27 pm »
Hola buenas tardes, estoy teniendo el siguiente problema con  SQ_PAGOS, desde 3W en un curso de idiomas que estamos realizando las pruebas.
Al al inscribirme y seleccionar "Pagar" nos envía a la plataforma de pagos.

Solo aparece como la captura que adjunto.
Estuve revisando los logs de la unidad de venta pero no encuentro algún error.


Muchas Gracias,
Saludos.

Esteban Sassone

  • Jr. Member
  • **
  • Mensajes: 59
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Esteban Sassone
  • Sistema: SIU Sanaviron Quilmes
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #1 : septiembre 27, 2017, 04:30:46 pm »
Hola Diego, ingresa nuevamente para pagar una inscripción y luego revisa el log del proyecto G.C.O. para ver si encontras  algún error. Si es así pasalo así lo vemos.

Saludos
Coordinador de desarrollo
Equipo SIU-Sanaviron-Quilmes

dbogado

  • Jr. Member
  • **
  • Mensajes: 99
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Oeste
  • Nombre y apellido: Diego Bogado
  • Sistema: SIU-Diaguita, SIU-Pilaga, SIU-Guarani, SIU-Wichi.
  • Teléfono laboral: 02204834192
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #2 : septiembre 28, 2017, 10:13:21 am »
Hola Esteban Muchas gracias por la respuesta.

La inscripción que realice a curso, volví a hacer clic en "pagar" , me direcciona nuevamente a la plataforma de pagos y se visualiza como la captura que te adjunto mas arriba.

No me genera ningún log en /usr/local/proyectos/sanaviron_quilmes/gco/logs con fecha de hoy.

Después , inscribimos a una nueva persona y realizamos todos los pasos, también nos direcciona a la plataforma sin contenido.

Paso el log que se genera cuando chequeo el estatus de  "http://10.0.2.19/sq_pagos_backend/status"

Código: [Seleccionar]
cat sq_pagos_20170928.log
[2017-09-28 09:53:30] myapp.INFO: Matched route "GET_status". {"route_parameters":{"_controller":"sq_pagos_backend:status","_route":"GET_status"},"request_uri":"http://10.0.2.19/sq_pagos_backend/status"} []
[2017-09-28 09:53:30] myapp.INFO: > GET /sq_pagos_backend/status [] []
[2017-09-28 09:53:30] myapp.INFO: < 200 [] []


Gracias.
Saludos.

dbogado

  • Jr. Member
  • **
  • Mensajes: 99
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Oeste
  • Nombre y apellido: Diego Bogado
  • Sistema: SIU-Diaguita, SIU-Pilaga, SIU-Guarani, SIU-Wichi.
  • Teléfono laboral: 02204834192
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #3 : noviembre 06, 2017, 01:23:49 pm »
Hola buenas tardes realizamos unas pruebas en una nueva instalación con la versión 1.0.12.

Estoy llegando al mismo punto al querer pagar el curso.
Me direcciona a una pagina solo con el encabezado del SQ_PAGOS y sin contenido.

Realice una nueva inscripción aparte de mi usuario y no me genera un log en GCO, solo chequeando el status.
Todas las pruebas nuevas las realice el día de hoy, adjunto logs que se generaron hoy y también de apache.

Veo en apache que los consumos_externos que realiza el Guarani3w, los busca en el directorio por default de apache /var/www/html
Pero todos los módulos del SQ están instalados en /usr/local/proyectos/sanaviron_quilmes/.

Adjunto los logs.


Saludos.


Pego el log de apache acá por el limite de adjuntar archivos.

Código: [Seleccionar]
AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:14:23.968997 2017] [authz_core:error] [pid 27340] [client 10.0.2.63:44908] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:14:27.468270 2017] [authz_core:error] [pid 27336] [client 10.0.2.63:44919] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:14:27.684245 2017] [authz_core:error] [pid 27336] [client 10.0.2.63:44919] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:14:27.743327 2017] [authz_core:error] [pid 27336] [client 10.0.2.63:44919] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:15:20.013336 2017] [authz_core:error] [pid 28949] [client 10.0.2.63:44933] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:15:22.798864 2017] [authz_core:error] [pid 28950] [client 10.0.2.63:44943] AH01630: client denied by server configuration: /var/www/html/servicios-instancias-valorizaciones
[Mon Nov 06 10:15:22.901309 2017] [authz_core:error] [pid 28950] [client 10.0.2.63:44943] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:15:27.804229 2017] [authz_core:error] [pid 28951] [client 10.0.2.63:44946] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:15:27.953914 2017] [authz_core:error] [pid 28951] [client 10.0.2.63:44946] AH01630: client denied by server configuration: /var/www/html/servicios-instancias-valorizaciones
[Mon Nov 06 10:15:28.059661 2017] [authz_core:error] [pid 28951] [client 10.0.2.63:44946] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos
[Mon Nov 06 10:15:28.121533 2017] [authz_core:error] [pid 28951] [client 10.0.2.63:44946] AH01630: client denied by server configuration: /var/www/html/solicitudes-consumos-externos

Esteban Sassone

  • Jr. Member
  • **
  • Mensajes: 59
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Esteban Sassone
  • Sistema: SIU Sanaviron Quilmes
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #4 : noviembre 10, 2017, 10:55:09 am »
Hola Diego, por la pantalla que mostras lo que parece es que no tenes instalado correctamente el proyecto de sq_pagos.

Revisa el instructivo: http://documentacion.siu.edu.ar/wiki/SIU-Sanaviron-Quilmes/version1.0.0/instalar_sq_produccion#SQ_Pagos

Es posible que este tirando algún error al instalar con el comando: npm install ???

Te paso los comando que utilizamos en el entorno de testing:
Código: [Seleccionar]
export NODE_VERSION=4.5.0
export NVM_DIR=/home/node/.nvm
git clone https://github.com/creationix/nvm.git ~/.nvm && cd ~/.nvm && git checkout `git describe --abbrev=0 --tags`
. ~/.nvm/nvm.sh && nvm install $NODE_VERSION
echo ". ~/.nvm/nvm.sh" >> ~/.bashrc
. ~/.nvm/nvm.sh && nvm use 4.5.0
cd ..../sq_pagos
npm install

Probalo y avisame

Saludos!
Coordinador de desarrollo
Equipo SIU-Sanaviron-Quilmes

dbogado

  • Jr. Member
  • **
  • Mensajes: 99
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Oeste
  • Nombre y apellido: Diego Bogado
  • Sistema: SIU-Diaguita, SIU-Pilaga, SIU-Guarani, SIU-Wichi.
  • Teléfono laboral: 02204834192
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #5 : noviembre 10, 2017, 04:04:21 pm »
Hola Esteban Gracias por la respuesta,

Ejecute un nuevamente la instalación de sq_pagos.

De la siguiente manera.

Código: [Seleccionar]
npm install --unsafe-perm
El panorama cambio me muestra lo siguiente que adjunto con captura y también agrego la salida de npm install y logs de apache2.

Pego aca debajo la configuración de angular.

Código: [Seleccionar]
cat angular-config.json
{
"entorno": "desarrollo",
"desarrollo": {
"config": {
"api_backend_url": "http://sanaviron.uno.edu.ar/sq_pagos_backend/",
"titulo": "Universidad Nacional del Oeste :: Plataforma de pagos :: Sanaviron"
}
},
"produccion": {
"config": {
"api_backend_url": "http://sanaviron.uno.edu.ar/sq_pagos_backend/",
"titulo": "Universidad Nacional del Oeste :: Plataforma de pagos :: Sanaviron"
}
}
}

Saludos
« Última Modificación: noviembre 10, 2017, 04:08:51 pm por dbogado »

dbogado

  • Jr. Member
  • **
  • Mensajes: 99
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Oeste
  • Nombre y apellido: Diego Bogado
  • Sistema: SIU-Diaguita, SIU-Pilaga, SIU-Guarani, SIU-Wichi.
  • Teléfono laboral: 02204834192
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #6 : noviembre 13, 2017, 03:40:05 pm »
Hola Esteban buenas tardes.

Borre completamente  sq_pagos y configure la instalación nuevamente.
Instale NodeJS  de la manera que comentaste en el post anterior.

Al ejecutar
Código: [Seleccionar]
npm install
Me dio la siguiente salida que adjunto y no funciono  sq_pago.

Luego ejecute directamente en el mismo directorio.
Código: [Seleccionar]
npm install --unsafe-perm
Quedo funcionando el modulo y realizamos una inscripción con mercado pago.

Adjunto las salidas de cada ejecución del comando npm.


Muchas Gracias.

Saludos.

Esteban Sassone

  • Jr. Member
  • **
  • Mensajes: 59
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Esteban Sassone
  • Sistema: SIU Sanaviron Quilmes
Re:Problemas con el modulo de SQ_PAGOS
« Respuesta #7 : noviembre 14, 2017, 10:13:55 am »
Hola Diego, ayer te estaba por contestar y se corto la luz en la oficina.. 

Bárbaro que quedo instalado el modulo.

Cualquier cosa avisen.

Saludos
Coordinador de desarrollo
Equipo SIU-Sanaviron-Quilmes