Autor Tema: [SOLUCIONADO] problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5  (Leído 1242 veces)

0 Usuarios y 1 Visitante están viendo este tema.

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
al actualizar desde la version 3.1.5 a 3.2.3. entre otros errores me aparece esto y no veo los proveedores

gracias

nahuel

SQLSTATE: db_42883

CODIGO: 7

MENSAJE: ERROR: no existe la función sincronizador.sincronizar(unknown, integer, integer, unknown, unknown, unknown)\nLINE 1: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12...\n ^\nHINT: Ninguna función coincide en el nombre y tipos de argumentos. Puede ser necesario agregar conversión explícita de tipos.

SQL: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12,68,"pilaga2.espaciomemoria.lan/pilaga/aplicacion.php","pilaga","3.2.3"); -- toba_log: 666002657
« Última Modificación: octubre 21, 2019, 04:07:48 pm por lramirez »

lramirez

  • Moderador
  • *****
  • Mensajes: 196
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #1 : diciembre 18, 2018, 03:18:23 pm »
Nahuel,

Hace unas semanas te habíamos pedido no replicar la misma consulta en distintos foros, vemos que volviste a replicar una misma consulta en mas de un foro, esto genera varias complicaciones para todos, te pido nuevamente evitar esto.
Para poder ayudarte necesitaría primero que me indiques los pasos que seguiste al momento de instalar o actualizar Pilagá, y si seguiste la parte de la guía que explica como configurar la conexión a la base Arai Proveedores en el archivo de configuración que usa el instalador.

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #2 : diciembre 18, 2018, 03:24:06 pm »
ok lo replique x q no sabia si era un problema de pilaga o de arai .

para actualizar baje el zip pilaga 3.2.3  y segui los pasos del video  y la guia que estan en http://documentacion.siu.edu.ar/wiki/SIU-Pilaga/version3.0.3/instalacion_actualizacion#Actualizaci.C3.B3n_del_ambiente_de_producci.C3.B3n_con_personalizaciones

el arai proveedores ya esta instalado en la version 3.1.5 y en la actualizacion solo complete los datos de la bd

Saludos

Nahuel

lramirez

  • Moderador
  • *****
  • Mensajes: 196
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #3 : diciembre 18, 2018, 03:29:40 pm »
Seguiste estos pasos? http://documentacion.siu.edu.ar/wiki/SIU-Pilaga/version3.2.1/consideraciones_tecnicas#Conectar_SIU-Pilag.C3.A1_con_SIU-Arai_Proveedores

ok lo replique x q no sabia si era un problema de pilaga o de arai .

para actualizar baje el zip pilaga 3.2.3  y segui los pasos del video  y la guia que estan en http://documentacion.siu.edu.ar/wiki/SIU-Pilaga/version3.0.3/instalacion_actualizacion#Actualizaci.C3.B3n_del_ambiente_de_producci.C3.B3n_con_personalizaciones

el arai proveedores ya esta instalado en la version 3.1.5 y en la actualizacion solo complete los datos de la bd

Saludos

Nahuel

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #4 : diciembre 18, 2018, 03:59:30 pm »
Asi es como lo hice. los datos de arai que van en    instalador.env ###### CONFIG DE BASE DE DATOS ARAI PROVEEDORES ######

los saque de /var/www/arai/instalacion/bases.ini


nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #5 : diciembre 18, 2018, 05:35:34 pm »
quise sincronizar manualmente pilaga y diaguita este es el resultado

root@pilaga:/var/www/SIU-Pilaga_3.2.3/bin# ./pilaga.sh arai sincronizacion
 ------------------------------------------------------------------------------
  Actualizando secuencias
 ------------------------------------------------------------------------------
 Actualizando Pilaga.Catalogos
 Actualizando Arai.Catalogos
 Actualizando Arai.Sincronizador
 Actualizando secuencia sq_anx_personas en base Pilaga
 Actualizando secuencia sq_anx_domicilios en base Pilaga
 ------------------------------------------------------------------------------
  Sincronizaci▒n Arai
 ------------------------------------------------------------------------------
toba_error_db:
ERROR ejecutando SQL:
 [CODIGO]: 7
 [SQLSTATE]: db_42883
 [MENSAJE]: ERROR:  no existe la funci▒n sincronizador.sincronizar(unknown, integer, integer, unknown, unknown, unknown)
LINE 1: SELECT * FROM sincronizador.sincronizar('''PROVEEDORES''',12...
                      ^
HINT:  Ninguna funci▒n coincide en el nombre y tipos de argumentos. Puede ser necesario agregar conversi▒n expl▒cita de tipos.
 [SQL EJECUTADA]: SELECT * FROM sincronizador.sincronizar('''PROVEEDORES''',12,68,'','pilaga','3.2.3'); -- toba_log: 666002716
 in /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/lib/db/toba_db.php:468
Stack trace:
#0 /var/www/SIU-Pilaga_3.2.3/php/p_nucleo/lib/sincronizador.php(604): toba_db->consultar('SELECT * FROM s...')
#1 /var/www/SIU-Pilaga_3.2.3/php/p_nucleo/lib/sincronizador.php(123): sincronizador->get_registros_sincronizar(12, 68)
#2 /var/www/SIU-Pilaga_3.2.3/php/p_nucleo/anexas/con_sincronizacion_arai.php(11): sincronizador->sincronizar('''PROVEEDORES''', Object(display_consola))
#3 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/nucleo/toba_solicitud_consola.php(25): require('/var/www/SIU-Pi...')
#4 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/nucleo/toba_nucleo.php(209): toba_solicitud_consola->procesar()
#5 /var/www/SIU-Pilaga_3.2.3/php/extension_toba/comandos/comando_arai.php(54): toba_nucleo->acceso_consola('produccion', 'pilaga', 21000083)
#6 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/comando.php(102): comando_arai->opcion__sincronizacion(NULL)
#7 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/comando.php(90): comando->ejecutar_opcion('opcion__sincron...', NULL)
#8 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/consola.php(78): comando->procesar()
#9 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/consola.php(55): consola->invocar_comando('arai', Array)
#10 /var/www/SIU-Pilaga_3.2.3/php/extension_toba/pilaga_comando.php(83): consola->run(Array)
#11 /var/www/SIU-Pilaga_3.2.3/php/extension_toba/pilaga_comando.php(147): pilaga_comando->solicitar_consola()
#12 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/comandos/comando_proyecto.php(87): pilaga_comando->opcion__arai(Array)
#13 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/comando.php(90): comando_proyecto->ejecutar_opcion('opcion__arai', Array)
#14 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/consola.php(78): comando->procesar()
#15 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/consola.php(55): consola->invocar_comando('proyecto', Array)
#16 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/php/consola/run.php(32): consola->run(Array)
#17 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/bin/launcher.php(28): require_once('/var/www/SIU-Pi...')
#18 /var/www/SIU-Pilaga_3.2.3/vendor/siu-toba/framework/bin/toba(2): require_once('/var/www/SIU-Pi...')
#19 {main}root@pilaga:/var/www/SIU-Pilaga_3.2.3/bin#
---------------------------------------------
root@pilaga:/var/www/diaguita/bin# ./toba proyecto arai_sincronizacion -i produccion -p diaguita
  ===============================
    Actualizaci▒n de secuencias
  ===============================
  Secuencia sq_anx_personas en base Diaguita esquema Diaguita actualizada correctamente!
  Secuencia sq_anx_domicilios en base Diaguita esquema Diaguita actualizada correctamente!
  Secuencias en base Diaguita esquema catalogos: Actualizadas las secuencias!
  Secuencias en base Arai esquema catalogos: Actualizadas las secuencias!
  Secuencias en base Arai esquema sincronizador: Actualizadas las secuencias!
=============================
Iniciando la sincronizacion
=============================
[# + Registros actualizados de la actividad local pendiente :.......... 6
---------------

lramirez

  • Moderador
  • *****
  • Mensajes: 196
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #6 : diciembre 19, 2018, 11:31:07 am »
Por favor corré este query en la base Arai Proveedores y pasame el resultado

Código: [Seleccionar]
SELECT * FROM phinxlog

Asi es como lo hice. los datos de arai que van en    instalador.env ###### CONFIG DE BASE DE DATOS ARAI PROVEEDORES ######

los saque de /var/www/arai/instalacion/bases.ini

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #7 : diciembre 19, 2018, 11:44:48 am »
Ok este es el resultado

Error de SQL:

ERROR:  no existe la relación «phinxlog»
LINE 1: SELECT COUNT(*) AS total FROM (SELECT * FROM phinxlog) AS su...
                                                     ^
En la declaración:
SELECT COUNT(*) AS total FROM (SELECT * FROM phinxlog) AS sub

lramirez

  • Moderador
  • *****
  • Mensajes: 196
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #8 : diciembre 19, 2018, 11:50:11 am »
Por lo visto no se corrieron las migraciones sobre la base Arai Proveedores, evidentemente hubo una omisión del paso que te mencionaba en el link anterior o algun error en el seteo de los parámetros (por eso no existe la tabla sobre la cual te pedía el query que se encarga de registrar las migraciones aplicadas sobre la base).
Un consejo, trata de usar un cliente de Postgresql que no te encapsule los queries que ejecutas sobre la base como subquery.

Ok este es el resultado

Error de SQL:

ERROR:  no existe la relación «phinxlog»
LINE 1: SELECT COUNT(*) AS total FROM (SELECT * FROM phinxlog) AS su...
                                                     ^
En la declaración:
SELECT COUNT(*) AS total FROM (SELECT * FROM phinxlog) AS sub

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #9 : diciembre 19, 2018, 12:22:27 pm »
ok y como sigo?

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #10 : diciembre 19, 2018, 12:48:54 pm »
bueno  elimine el directorio instalacion de la actualizacion y corri el instalador nuevamente pero sigo con errores

esto me dice el instalador
---------------------------
 === Generando conversión de base de datos ===
-----------------------------------------------

-Generando conversión de base de datos de negocio

1/1 [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓] 100%


 [ OK ] Se generó la entrada en bases.ini de la base de datos 'arai'


 [ OK ] la base de datos 'arai' ya existe


 [ ERROR ] [ Phinx ] Error de conversión de datos para la base de datos 'arai'

  ¿desea continuar?  (yes/no) [yes]:
 > yes
-----------------------
en pilaga al ir a MAESTROS> tablas anexas>  abm personas proveedores

SQLSTATE: db_42501

CODIGO: 7

MENSAJE: ERROR: permiso denegado al esquema sincronizador\nLINE 1: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12...\n ^

SQL: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12,68,"pilaga2.espaciomemoria.lan/pilaga/aplicacion.php","pilaga","3.2.3"); -- toba_log: 666002784


lramirez

  • Moderador
  • *****
  • Mensajes: 196
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #11 : diciembre 19, 2018, 01:25:33 pm »
Por lo que está indicando el error se trata de un problema de permisos en la base:

MENSAJE: ERROR: permiso denegado al esquema sincronizador\nLINE 1: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12...\n ^

bueno  elimine el directorio instalacion de la actualizacion y corri el instalador nuevamente pero sigo con errores

esto me dice el instalador
---------------------------
 === Generando conversión de base de datos ===
-----------------------------------------------

-Generando conversión de base de datos de negocio

1/1 [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓] 100%


 [ OK ] Se generó la entrada en bases.ini de la base de datos 'arai'


 [ OK ] la base de datos 'arai' ya existe


 [ ERROR ] [ Phinx ] Error de conversión de datos para la base de datos 'arai'

  ¿desea continuar?  (yes/no) [yes]:
 > yes
-----------------------
en pilaga al ir a MAESTROS> tablas anexas>  abm personas proveedores

SQLSTATE: db_42501

CODIGO: 7

MENSAJE: ERROR: permiso denegado al esquema sincronizador\nLINE 1: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12...\n ^

SQL: SELECT * FROM sincronizador.sincronizar("""PROVEEDORES""",12,68,"pilaga2.espaciomemoria.lan/pilaga/aplicacion.php","pilaga","3.2.3"); -- toba_log: 666002784

nbaglietto

  • Newbie
  • *
  • Mensajes: 45
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Re:problemas com proveedores al actualizar pilaga de 3.1 a 3.2.5
« Respuesta #12 : diciembre 19, 2018, 01:56:51 pm »
Bueno ahora borre el directorio instalacion y modifique en instalador.env el usuario de la bd arai  x postgres. ejecute el instalador nuevamente y funciono 

Gracias
nahuel
« Última Modificación: diciembre 19, 2018, 02:47:48 pm por nbaglietto »