Autor Tema: Error de conexión a LDAP en el chequeo de instalcion  (Leído 81 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jetchevers

  • Newbie
  • *
  • Mensajes: 12
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Error de conexión a LDAP en el chequeo de instalcion
« : octubre 24, 2019, 07:29:33 pm »
Buenas tardes.

Estoy teniendo un problema de conexión a ldap al momento que el instalador chequea los requerimientos  y no puedo continuar.

En el log del instalador aparece los siguiente.

Código: [Seleccionar]
[2019-10-24 18:03:57] MAIN.INFO: [ OK ] POSTGRES: Versión esperada desde 9.4.0, versión instalada 9.6.15
[2019-10-24 18:03:57] MAIN.INFO: [ OK ] PHP: La extensión ldap se encuentra instalada en el sistema.
[2019-10-24 18:03:57] MAIN.ERROR: [ Ldap ] LDAP CONNECTION ERROR: ERROR conectandose al LDAP [0] - No se pudo conectar al servidor LDAP
[2019-10-24 18:03:57] MAIN.ERROR: No se pudo ejecutar la consulta al servicio
[2019-10-24 18:03:57] MAIN.INFO: [ OK ] POSTGRES: Se pudo validar la aplicación (conexión exitosa)
[2019-10-24 18:03:57] MAIN.INFO: [ PREGUNTA ] ¿desea continuar?
[2019-10-24 18:04:20] MAIN.INFO: [ RESPUESTA ] No

Manualmente realizo la prueba que se sugiere en el instructivo para instalar ldap y funciona correctamente (me solicita la password del administrador de LDAP).

ldapsearch -x -W -D "cn=admin,dc=unm,dc=edu,dc=ar" -b "dc=unm,dc=edu,dc=ar"

Revise los logs y no encuentro nada que me  de una pista que puede estar pasando.

Gracias.
Juan.-

« Última Modificación: octubre 24, 2019, 08:50:56 pm por Sergio F. Vier »

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 520
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Error de conexión a LDAP en el chequeo de instalcion
« Respuesta #1 : octubre 24, 2019, 08:55:42 pm »
Hola  Juan,

mirá el log no es muy detallado, no da mas información al respecto como para evaluar el inconveniente (me lo anoto, para mejorarlo).

Evidentemente si te funciona conectandote manualmente (con host, bindn, user, pass) y accedes de forma correcta, estás teniendo mal configurado en el archivo de variables de entorno arai-usuarios.env.

El error sugiere que el host y puerto de LDAP están bien, lo que está fallandote es el usuario y/o clave. Revisalo y probá conectandote desde otra aplicación como Apache Directory Studio, para descartar.

Saludos!
happy coding!!

jetchevers

  • Newbie
  • *
  • Mensajes: 12
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error de conexión a LDAP en el chequeo de instalcion
« Respuesta #2 : enero 22, 2020, 12:05:01 pm »
Hola Sergio..

Luego de un tiempo volvimos a retomar la instalación de  ARAI.
El tema de la consulta LDAP quedo solucionada pero ahora el instalador (Arai-usuario) me da el siguiente error.

5) Configuraciòn del proyecto
=============================

Configurando Arai Usuarios
--------------------------
-Configurando
21/23 [âââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââ|      ]  91%
In Parser.php line 127:
  The YAML value does not appear to be valid UTF-8.

-------------------------------------------------
A postgres lo tengo configurado con el encoding LATIN1 .
Sobre este mismo postgres ya tengo instalado el esquema de Arai-Registry.


Lo que figura en el log de instalación es lo siguiente..

[2020-01-21 17:27:03] MAIN.NOTICE: === PASO 5) Configuración del proyecto
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/config/security.yml.dist' hacia '/usr/local/siu/arai-usuarios/config/security.yml
'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/config/idp.yml.dist' hacia '/usr/local/siu/arai-usuarios/config/idp.yml'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/config/mailer.yml.dist' hacia '/usr/local/siu/arai-usuarios/config/mailer.yml'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/config/databases.yml.dist' hacia '/usr/local/siu/arai-usuarios/config/databases.y
ml'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/config.php' hacia '/usr/local/siu/arai-usuarios/config/simplesamlphp/config.p
hp'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/siuArai-passRecovery.php' hacia '/usr/local/siu/arai-usuarios/config/simplesa
mlphp/siuArai-passRecovery.php'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/authsources.php' hacia '/usr/local/siu/arai-usuarios/config/simplesamlphp/aut
hsources.php'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/saml20-sp-remote.php' hacia '/usr/local/siu/arai-usuarios/config/simplesamlph
p/saml20-sp-remote.php'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/saml20-idp-hosted.php' hacia '/usr/local/siu/arai-usuarios/config/simplesamlp
hp/saml20-idp-hosted.php'
[2020-01-21 17:27:03] MAIN.INFO: Se copia archivo: '/usr/local/siu/arai-usuarios/templates/idp/idp.conf' hacia '/usr/local/siu/arai-usuarios/instalacion/idp.conf'

richard

  • Moderador Global
  • *****
  • Mensajes: 2670
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Error de conexión a LDAP en el chequeo de instalcion
« Respuesta #3 : febrero 04, 2020, 11:01:13 am »
Hola Juan
5) Configuraciòn del proyecto
=============================

Configurando Arai Usuarios
--------------------------
-Configurando
21/23 [âââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââââ|      ]  91%
In Parser.php line 127:
  The YAML value does not appear to be valid UTF-8.

-------------------------------------------------
A postgres lo tengo configurado con el encoding LATIN1 .
Sobre este mismo postgres ya tengo instalado el esquema de Arai-Registry.

A priori no pareciera ser un tema de Postgres, el mensaje habla del parseo del archivo de configuracion (con algun valor no esperado)... me subirias el archivo de log completo del instalador asi veo bien donde es que queda finalmente el proceso?.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.