Autor Tema: Error al de 4.0.1 a 4.1.0  (Leído 52 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ricardoude

  • Full Member
  • ***
  • Mensajes: 121
    • Ver Perfil
    • Email
  • Institución: UDE
  • Nombre y apellido: Ricardo Marcelo De Lucia
  • Sistema: Siu-Guarani
  • Teléfono laboral: 0221-4232545
  • Utilizo algun sistéma del SIU: Sí
Error al de 4.0.1 a 4.1.0
« : enero 13, 2020, 08:36:08 am »
Hola
estamos intentando actualizar la version 4.0.1a la  4.1.0 para luego pasar a la 4.3.0

en el proceso de migracion da este error:
ERROR: problemas ejecutando el método .

SQLSTATE[23503]: Foreign key violation: 7 ERROR: inserción o actualización en la tabla «apex_usuario_proyecto» viola la llave foránea «apex_usu_proy_fk_grupo_acc» DETAIL: La llave (proyecto, usuario_grupo_acc)=(kolla, consulta) no está presente en la tabla «apex_usuario_grupo_acc».


note dos cosas:
1) las tablas  apex_usuario_proyecto y apex_usuario_grupo_acc tiene n informacion
2) cuando renombro los archivos usuarios.sql que estan en la carpeta del 4.0.1, el error cambia: da error general

No se si necesitan algun log

Muchas Gracias
Saludos

Myriam Céspedes

  • Moderador Global
  • *****
  • Mensajes: 315
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Myriam Céspedes
  • Sistema: SIU-Kolla | SIU-Tehuelche
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #1 : enero 13, 2020, 10:46:23 am »
Buen día Ricardo,
según el detalle que envías, esos mensajes se están dando por cambios que se realizan en la versión 4.1.

El motivo esta detallado en la documentación: http://documentacion.siu.edu.ar/wiki/SIU-Kolla/Version_4.1.0/actualizacion#Migraci.C3.B3n

Te pedimos que continúes con la Configuración Adicional y finalices el proceso de actualización.

Contanos cómo te fue.

Saludos!
Myriam

ricardoude

  • Full Member
  • ***
  • Mensajes: 121
    • Ver Perfil
    • Email
  • Institución: UDE
  • Nombre y apellido: Ricardo Marcelo De Lucia
  • Sistema: Siu-Guarani
  • Teléfono laboral: 0221-4232545
  • Utilizo algun sistéma del SIU: Sí
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #2 : enero 13, 2020, 11:25:25 am »
Hola

si si, estoy siguiendo esa documentacion
en el paso de migracion, donde dice actualizar la aplicacion, empieza el proceso, da el error y queda en esa pantalla
no me da ninguna otra opcion para continuar

Saludos


Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 164
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #3 : enero 13, 2020, 01:37:13 pm »
Hola Ricardo. Mandanos por favor el log de apache para ver si podemos rastrear lo que pasó y porque nos está faltando un grupo de acceso.

Germán

ricardoude

  • Full Member
  • ***
  • Mensajes: 121
    • Ver Perfil
    • Email
  • Institución: UDE
  • Nombre y apellido: Ricardo Marcelo De Lucia
  • Sistema: Siu-Guarani
  • Teléfono laboral: 0221-4232545
  • Utilizo algun sistéma del SIU: Sí
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #4 : enero 14, 2020, 08:39:49 am »
Hola

te adjunto  los logs del apache, postgres y del instalador

Saludos

Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 164
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #5 : enero 14, 2020, 10:46:40 am »
Hola Ricardo.

Te pido que por favor nos generes una solicitud en el GDS para que lo podamos seguir desde allí.

Gracias!

ricardoude

  • Full Member
  • ***
  • Mensajes: 121
    • Ver Perfil
    • Email
  • Institución: UDE
  • Nombre y apellido: Ricardo Marcelo De Lucia
  • Sistema: Siu-Guarani
  • Teléfono laboral: 0221-4232545
  • Utilizo algun sistéma del SIU: Sí
Re:Error al de 4.0.1 a 4.1.0
« Respuesta #6 : enero 14, 2020, 11:05:24 am »
ya la genere

saludos