Autor Tema: Upgrade con fallas  (Leído 97 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Fernando Velarde

  • Full Member
  • ***
  • Mensajes: 102
    • Ver Perfil
  • Institución: Universidad Provincial de Ezeiza
  • Nombre y apellido: Fernando Velarde
  • Sistema: Guaraní 3.17.1
  • Teléfono laboral: 4480-0318
  • Utilizo algun sistéma del SIU: Sí
Upgrade con fallas
« : marzo 21, 2020, 08:05:05 pm »
Hola,

Pasé de la 3.15.1 a la 3.17.1 y algunas operaciones como "Administrar personas" y "Cargar notas a mesa de examen" (38000083)    funcionan perfecto, mientras que otras como "Distribuir alumnos  entre comisiones" (37000106) y "Cargar notas a comisiones" (41000034) solo muestran la barra con los titulos sin llegar al formulario para elegir las opciones. Y otras como "Inscribir a cursada fuera de término" (9000039) funcionan las primeras 2 páginas de selección y muestra solo título al pasar al PASO 2.

En Autogestión también hay problema, por ejemplo en perfil docente "Cursadas"  en las operaciones "Cargar Notas" y "Moodle" dan error "ocurrió un error, chequee su conexión a internet" mientras que "Alumnos" lista sin problema. En "Exámenes" siempre devuelve "No hay mesas de exámenes disponibles " aunque ponga un rango que tuvo mesas para el docente.

Pensé en un tema de permisos www-data:www-data en un momento, lo vi, lo corregí, pero sigue igual.
Siempre agradecido a los que me ayudan en este foro. No lo explicito en nuevos mensajes sólo para no generar más mensajes que no necesitan respuesta.

eluqueunca

  • General Guarani
  • *
  • Mensajes: 2759
    • Ver Perfil
    • Email
  • Institución: Facultad de Ciencias Agrarias - UNCa
  • Nombre y apellido: Emilio Luque
  • Sistema: Siu-Guarani
Re:Upgrade con fallas
« Respuesta #1 : marzo 24, 2020, 12:07:39 pm »
Hola

Esto ocurre en una instalación de desarrollo o en una de producción?

Lo hicistes siguiendo estrictamente los pasos para actualizar versiones?

Compilastes los metadatos nuevamente?

Emilio

Fernando Velarde

  • Full Member
  • ***
  • Mensajes: 102
    • Ver Perfil
  • Institución: Universidad Provincial de Ezeiza
  • Nombre y apellido: Fernando Velarde
  • Sistema: Guaraní 3.17.1
  • Teléfono laboral: 4480-0318
  • Utilizo algun sistéma del SIU: Sí
Re:Upgrade con fallas
« Respuesta #2 : marzo 24, 2020, 08:01:46 pm »
Citar
Esto ocurre en una instalación de desarrollo o en una de producción?
Producción.

Habíamos hecho upgrade en desarrollo y parecía bien pero no lo puedo confirmar, ya que algunas cosas se ven y otras no, y no sé si probé las que no.
Hoy con la cuarentena no tenemos acceso al servidor de Desarrollo pq está caído el enlace y la Universidad está cerrada. Por eso no puedo cruzar info con Desarrollo.


Citar
Lo hicistes siguiendo estrictamente los pasos para actualizar versiones?
Fui al mapita   http://documentacion.siu.edu.ar/wiki/SIU-Guarani/Version3.17.0/instalacion_actualizacion_gestion
Tengo inst. Desarrollo "Si",   izquierda
Hay Personalizaciones "No", derecha
Actualizacion de entorno de Desarrollo sin pers.   (lo hicimos hace unos 20 días)   pero no puedo confirmar si falla lo mismo que ahora. Como ví que un par de cosas andaban bien, dí por sentado que había salido todo bien.
Hay que pers ?  "No" derecha
Creación 4 dígitos OK
Hay ambiente de producción "si",  izquierda.

Pasamos a PHP 7.1  (nos costó un poco más de lo indicado en la doc -el apt-get no andaba-,  pero google ayudó para instalar por afuera (creo que apt en vez apt-get )
https://www.itzgeek.com/how-tos/linux/debian/how-to-install-php-7-3-7-2-7-1-on-debian-10-debian-9-debian-8.html

Citar
Compilastes los metadatos nuevamente?
El paso 10 lo hice y está la carpeta metadatos_compilados llena de php a la hora de instalación.


Se me ocurre que pude haberme equivocado al hacer el upgrade de g3w3 ... pero no sé si eso me influye en Gestión.

Al crear la versión de 4 dígitos en g3w3  usé 3.17.1 y 3.17.1.1    (viendo después la que corresponde con Gestión 3.17.1  debería ser la 3.17.0 de g3w3)

La duda es si me aceptó sin error de "no existe", es que existe la 3.17.1 de g3w3. El tema es qué contenido hay, si una replica de 3.17.0   o  una versión nueva no compatible o no estable que me está haciendo fallar el resto....

Ejemplo de error en Gestión. Operación "Administrar persona" (37000023) . Puedo filtrar personas sin problema. Puedo acceder a "Datos personales" y actualizar sin problema.  Si voy a "Datos adicionales" ya no los puedo ver. Solo el título "Datos adicionales" y ahí me quedo clavado y no puedo volver a la pantalla de "Datos personales" u otra mediante los links (solo con flecha del browser).

Siempre agradecido a los que me ayudan en este foro. No lo explicito en nuevos mensajes sólo para no generar más mensajes que no necesitan respuesta.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1427
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Upgrade con fallas
« Respuesta #3 : marzo 25, 2020, 08:18:27 am »
Hola Fernando,

Revisaste los logs de Apache y los del sistema?

Saludos, Florencia.

eluqueunca

  • General Guarani
  • *
  • Mensajes: 2759
    • Ver Perfil
    • Email
  • Institución: Facultad de Ciencias Agrarias - UNCa
  • Nombre y apellido: Emilio Luque
  • Sistema: Siu-Guarani
Re:Upgrade con fallas
« Respuesta #4 : marzo 25, 2020, 10:49:43 am »
Hola


Citar
Al crear la versión de 4 dígitos en g3w3  usé 3.17.1 y 3.17.1.1    (viendo después la que corresponde con Gestión 3.17.1  debería ser la 3.17.0 de g3w3)

NOOOOOOOOO:
las versiones de guarani son la misma siempre.

Ese comportamiento de Administrar Personas, aparte de errores, suele ocurrir por permisos sobre los directorios.

Tenés una base de datos previa a la conversión?

Para saber si podemos volver atras.
Es mas facil volver a la version anterior y convertir nuevamente que tratar de reparar la instalacion.

Vos tenes que haber generado dos versiones de 4 digitos. Una para gestion y otra para G3w.
Trabajas con tu svn propio o con el del siu?

Una vez me pasó que me faltaban la mitad de los objetos en la version de 4 digitos. Nunca supe por que.

Emilio

Fernando Velarde

  • Full Member
  • ***
  • Mensajes: 102
    • Ver Perfil
  • Institución: Universidad Provincial de Ezeiza
  • Nombre y apellido: Fernando Velarde
  • Sistema: Guaraní 3.17.1
  • Teléfono laboral: 4480-0318
  • Utilizo algun sistéma del SIU: Sí
Re:Upgrade con fallas
« Respuesta #5 : marzo 26, 2020, 02:56:13 pm »
Citar
Revisaste los logs de Apache y los del sistema?

En el log veo "Version-PHP: 5.6.40-0+deb8u2"    mientras que si hago php -v  me da
" PHP 7.1.33-14+0~20200320.35+debian9~1.gbpb15fae (cli) (built: Mar 20 2020 14:28:16) ( NTS )"

No sé si pasa por ahí, pero parece extraño.


Extracto de logs de apache

Gestión

[Thu Mar 26 03:59:07.939749 2020] [:error] [pid 28366] [client 190.19.192.189:54170] PHP Parse error:  syntax error, unexpected '?' in /usr/local/proyectos/guarani/php/nucleo/cursadas/comisiones/co_comisiones.php on line 1292, referer: http://34.232.173.37/guarani/3.15/aplicacion.php?ah=st5e7c52b220b572.41077028&ai=guarani%7C%7C37000023

[Thu Mar 26 04:00:51.806188 2020] [:error] [pid 28686] [client 190.19.192.189:54196] PHP Parse error:  syntax error, unexpected '?' in /usr/local/proyectos/guarani/php/nucleo/cursadas/inscripciones/co_inscripciones_cursadas.php on line 1298, referer: http://34.232.173.37/guarani/3.15/aplicacion.php?tm=1&tcm=central&ai=guarani||41000010

[Thu Mar 26 04:02:45.357210 2020] [:error] [pid 28686] [client 190.19.192.189:54242] PHP Notice:  Array to string conversion in /usr/local/proyectos/g3w3_317/vendor/siu/chulupi-framework/src/SIU/Chulupi/util/modelo/ProcesadorDatos.php on line 167, referer: http://34.232.173.37/upe/notas_mesa_examen/edicion/0cf5c264e3fc3aea2e8f128a63dfeb34f5ab9144e1d4a72935573edb6349a53cbb34a66cfbac54de

Autogestión

[Thu Mar 26 04:03:07.730524 2020] [:error] [pid 28366] [client 190.19.192.189:54249] PHP Notice:  Array to string conversion in /usr/local/proyectos/g3w3_317/vendor/siu/chulupi-framework/src/SIU/Chulupi/util/modelo/ProcesadorDatos.php on line 167, referer: http://34.232.173.37/upe/notas_mesa_examen/edicion/0cf5c264e3fc3aea2e8f128a63dfeb34f5ab9144e1d4a72935573edb6349a53cbb34a66cfbac54de

[Thu Mar 26 04:04:05.260934 2020] [:error] [pid 28686] [client 190.19.192.189:54274] PHP Parse error:  syntax error, unexpected '?' in /usr/local/proyectos/g3w3_317/src/siu/modelo_g3/nucleo/cursadas/comisiones/co_comisiones.php on line 1292, referer: http://34.232.173.37/upe/cursada/edicion/1f17bf9322ec44eb6e3a71076646b7bbc1ec0f996c70271f8d39899b18e0893f5953610ffcb94d58


Extracto de logs de sistema

-o-o-o-o-o-
Fecha: 26-03-2020 04:00:44
Operacion: Reporte de Total de Inscripciones a Cursadas en un Per?odo Lectivo
Usuario: toba
Version-PHP: 5.6.40-0+deb8u2
Servidor: 34.232.173.37
URI: /guarani/3.15/aplicacion.php?tm=1&tcm=central&ai=guarani||41000010
Referrer: http://34.232.173.37/guarani/3.15/aplicacion.php?ah=st5e7c52b68e2b50.53347248&ai=guarani%7C%7C37000023
Host: 190.19.192.189
==========
[INFO][toba] Se detecto acceso desde el menu. Se limpia la memoria de la operacion
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/guarani_sesion.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/guarani/php
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/autentificacion/guarani_pers_usuario.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/per$
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/guarani_fuente_datos.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/guarani/php
[INFO][guarani] PUNTO MONTAJE: se carg? la clase operaciones/cursadas/comisiones/ci_rep_total_inscr_cursadas_periodo.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/gu$
[INFO][toba] componente(41000063): No hay se?ales de un servicio anterior, no se atrapan eventos
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/componentes/guarani_pers_ei_cuadro.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/perso$
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/componentes/guarani_pers_ei_filtro.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/perso$
[INFO][toba] componente(41000063): [ callback ] 'conf__pant_inicial' no fue atrapado


-o-o-o-o-o-
Fecha: 26-03-2020 04:00:49
Operacion: Reporte de Total de Inscripciones a Cursadas en un Per?odo Lectivo
Usuario: toba
Version-PHP: 5.6.40-0+deb8u2
Servidor: 34.232.173.37
URI: /guarani/3.15/aplicacion.php?ah=st5e7c531bcf80d4.16742330&ai=guarani||41000010&tcm=central&ai=guarani||41000010&ts=cascadas_columnas&cascadas-col=periodo&cascadas-maestros=anio_academico-;-20$
Referrer: http://34.232.173.37/guarani/3.15/aplicacion.php?tm=1&tcm=central&ai=guarani||41000010
Host: 190.19.192.189
==========
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/guarani_sesion.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/guarani/php
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/autentificacion/guarani_pers_usuario.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/per$
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/guarani_fuente_datos.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/guarani/php
[INFO][guarani] PUNTO MONTAJE: se carg? la clase operaciones/cursadas/comisiones/ci_rep_total_inscr_cursadas_periodo.php del punto de montaje proyecto. El path del mismo es /usr/local/proyectos/gu$
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/componentes/guarani_pers_ei_filtro.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/perso$
[INFO][guarani] PUNTO MONTAJE: se carg? la clase extension_toba/componentes/guarani_pers_ei_cuadro.php del punto de montaje personalizacion. El path del mismo es /usr/local/proyectos/guarani/perso$
[INFO][toba] componente(41000063): [ callback ] 'conf__pant_inicial' no fue atrapado

Siempre agradecido a los que me ayudan en este foro. No lo explicito en nuevos mensajes sólo para no generar más mensajes que no necesitan respuesta.

eluqueunca

  • General Guarani
  • *
  • Mensajes: 2759
    • Ver Perfil
    • Email
  • Institución: Facultad de Ciencias Agrarias - UNCa
  • Nombre y apellido: Emilio Luque
  • Sistema: Siu-Guarani
Re:Upgrade con fallas
« Respuesta #6 : marzo 26, 2020, 04:27:21 pm »
Hola

Este es el primer problema a resolver

Citar
En el log veo "Version-PHP: 5.6.40-0+deb8u2"    mientras que si hago php -v  me da
" PHP 7.1.33-14+0~20200320.35+debian9~1.gbpb15fae (cli) (built: Mar 20 2020 14:28:16) ( NTS )"

No sé si pasa por ahí, pero parece extraño.

Con el repositorio que pusistes para instalar el php 7.3
tenes que hacer

Código: [Seleccionar]
apt-get install libapache2-mod-php7.1
para que te lo tome el apache.

Despues seguimos.

Emilio

Fernando Velarde

  • Full Member
  • ***
  • Mensajes: 102
    • Ver Perfil
  • Institución: Universidad Provincial de Ezeiza
  • Nombre y apellido: Fernando Velarde
  • Sistema: Guaraní 3.17.1
  • Teléfono laboral: 4480-0318
  • Utilizo algun sistéma del SIU: Sí
Re:Upgrade con fallas
« Respuesta #7 : marzo 27, 2020, 01:49:39 am »
Citar
apt-get install libapache2-mod-php7.1

Lo toma como instalado. Pero en log del sistema  sigue apareciendo 5.6  mientras que en php -v  7.1

Reading package lists... Done
Building dependency tree
Reading state information... Done
libapache2-mod-php7.1 is already the newest version (7.1.33-14+0~20200320.35+debian9~1.gbpb15fae).
0 upgraded, 0 newly installed, 0 to remove and 65 not upgraded.
Siempre agradecido a los que me ayudan en este foro. No lo explicito en nuevos mensajes sólo para no generar más mensajes que no necesitan respuesta.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1427
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Upgrade con fallas
« Respuesta #8 : marzo 27, 2020, 08:10:59 am »
Hola Fernando,

Fijate que la solución está en este post: http://foro.comunidad.siu.edu.ar/index.php?topic=18167.msg80793#msg80793.

Saludos, Florencia.

Fernando Velarde

  • Full Member
  • ***
  • Mensajes: 102
    • Ver Perfil
  • Institución: Universidad Provincial de Ezeiza
  • Nombre y apellido: Fernando Velarde
  • Sistema: Guaraní 3.17.1
  • Teléfono laboral: 4480-0318
  • Utilizo algun sistéma del SIU: Sí
Re:Upgrade con fallas
« Respuesta #9 : marzo 27, 2020, 02:55:24 pm »
Gracias Florencia !!!   Estaba difícil para encontrarlo con el buscador.

cuento la solución por si le pasa a otro,

probé con "sudo a2dismod php5.6"   pero no tenía ese módulo

con " sudo a2dismod "  me tiró la lista de módulos. En mi caso se llamaba php5   

sudo a2dismod php5
sudo a2enmod php7.1
sudo service apache2 restart

Y funcionando !!!!
Gracias.
Siempre agradecido a los que me ayudan en este foro. No lo explicito en nuevos mensajes sólo para no generar más mensajes que no necesitan respuesta.