Autor Tema: Error al actualizar mapuche-3.9.1 a -3.10.1  (Leído 321 veces)

0 Usuarios y 1 Visitante están viendo este tema.

rbombillar

  • Newbie
  • *
  • Mensajes: 15
    • Ver Perfil
  • Institución: UNAB
  • Nombre y apellido: Rodrigo Bombillar
  • Sistema: mapuche
  • Teléfono laboral: 1136421308
  • Utilizo algun sistéma del SIU: Sí
Error al actualizar mapuche-3.9.1 a -3.10.1
« : mayo 12, 2020, 04:02:11 pm »
hola buenas tardes , quisiera saber si me pueden ayudar porque estoy teniendo un inconveniente al actualizar mapuche de la version 3.9.1 a la 3.10.1. Al momento de actualizar  no me dio ningún error en lo que se refiere a bases de datos, pero cuando termino la actualización, al querer ingresar al mapuche me aparece el siguiente error: La versión de la aplicación (páginas de SIU-Mapuche) no coincide con la versión de la base de datos SIU. Por favor actualice la base de datos.(Version Página:3.9 - Versión Base:3.10). Estuve viendo este error en otros foros y parece ser que tiene que ver con que no se actualizo la base. Les paso adjunto el error del mapuche junto a los logs del instalador.

aguardo comentarios,
Gracias!

mariela

  • Sr. Member
  • ****
  • Mensajes: 379
    • Ver Perfil
    • Email
  • Institución: Consorcio SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #1 : mayo 13, 2020, 07:46:12 am »
Hola Rodrigo, veo en el log varias cosas que pueden haberte traido problemas, una es la configuración de los paths recordá que

TOBA_PROYECTO_DIR="<paths_nueva_instalacion>/mapuche"
TOBA_INSTALACION_DIR="<paths_nueva_instalacion>/mapuche/instalacion"
 
Luego cuando corres el comando de actualización es
> ./bin/instalador proyecto:actualizar -d <path_instalacion_anterior>/mapuche

Por otro lado,  cual es la codificación de la base?

Saludos,
Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
Consorcio SIU
http://www.siu.edu.ar

rbombillar

  • Newbie
  • *
  • Mensajes: 15
    • Ver Perfil
  • Institución: UNAB
  • Nombre y apellido: Rodrigo Bombillar
  • Sistema: mapuche
  • Teléfono laboral: 1136421308
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #2 : mayo 13, 2020, 01:29:11 pm »
Hola Mariela buen día, te comento que  lo que es el tema de los paths lo pude arreglar. Para la actualización no usé el parametro -d sino que utilice --instalacion-anterior, igual supongo que es lo mismo y no influye. La codificación de la base es SQL_ASCII. En el archivo de configuración instalador.env el encoding lo tengo configurado asi:

#### CONFIG DE BASE DE DATOS DE NEGOCIO #######

PROYECTO_DB_ENCODING="SQL_ASCII"

####CONFIG DE BASE DE DATOS DE TOBA ######

PROYECTO_DB_ENCODING="LATIN1"

mi pregunta es la siguiente: la base de datos de toba tiene que ser sql_ascii tambien?

aguardo comentarios,
Gracias!

mariela

  • Sr. Member
  • ****
  • Mensajes: 379
    • Ver Perfil
    • Email
  • Institución: Consorcio SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #3 : mayo 13, 2020, 01:59:17 pm »
Está correcto como tenes los datos de la base. Ahora los paths de instalación los corroboraste?

Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
Consorcio SIU
http://www.siu.edu.ar

rbombillar

  • Newbie
  • *
  • Mensajes: 15
    • Ver Perfil
  • Institución: UNAB
  • Nombre y apellido: Rodrigo Bombillar
  • Sistema: mapuche
  • Teléfono laboral: 1136421308
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #4 : mayo 13, 2020, 03:10:50 pm »
si, eso esta bien, ahora voy a volver a realizar la actualización desde cero y voy a ver si arreglo los errores de los logs. Después te aviso.

Muchas gracias!
Saludos,
Rodrigo

rbombillar

  • Newbie
  • *
  • Mensajes: 15
    • Ver Perfil
  • Institución: UNAB
  • Nombre y apellido: Rodrigo Bombillar
  • Sistema: mapuche
  • Teléfono laboral: 1136421308
  • Utilizo algun sistéma del SIU: Sí
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #5 : mayo 15, 2020, 01:10:41 pm »
Hola Mariela buen día, te escribo para avisarte que ya pude resolver el inconveniente. Mas allá de los errores que tenia en lo logs, que ya los pude corregir, el problema central fue que, después de realizar la actualización y al momento de ejecutar el comando ln -s .... nunca reinicié el servidor de apache , entonces al sacar el modo mantenimiento me aparecía ese error de las paginas del siu.

Muchas gracias,
Saludos.
Rodrigo

mariela

  • Sr. Member
  • ****
  • Mensajes: 379
    • Ver Perfil
    • Email
  • Institución: Consorcio SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error al actualizar mapuche-3.9.1 a -3.10.1
« Respuesta #6 : mayo 19, 2020, 07:30:47 am »
Hola Rodrigo, que bueno que solucionaron el problema.

Saludos,
Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
Consorcio SIU
http://www.siu.edu.ar