Autor Tema: Consultas  (Leído 167 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pdassale

  • Newbie
  • *
  • Mensajes: 5
    • Ver Perfil
  • Institución: Universidad Austral
  • Nombre y apellido: Pablo Assale
  • Sistema: Toba, Guarani
  • Teléfono laboral: 1555789044
Consultas
« : mayo 22, 2020, 06:05:09 pm »
Buenas tardes, estoy empezando con toba y surgieron algunas dudas.

Al querer crear un proyecto nuevo “curso” en toba, que ya tenía el proyecto Guaraní y los  propios de toba (editor, referencia y usuarios) se borraron carpetas y no corrió más toba ni guaraní. Se creó con el comando ./toba proyecto crear x línea de comando de Linux siguiendo las instrucciones en instancias de desarrollo.

Entonces las consultas son:
1.   ¿Pueden existir varios proyectos en la misma instalación e instancia de toba? ¿Cómo, que puntos hay que tener en cuenta?
2.   ¿Se pueden instalar más de un toba en misma máquina virtual en distintos path y que cada Toba tenga distintos proyectos? ¿Cómo, que puntos hay que tener en cuenta?
3.   ¿Cuál es la relación entre los usuarios de toba_usuarios y los usuarios de Guaraní, ya que son bases de datos distintas, igual con los perfiles funcionales y de datos que se pueden crear en toba?.

Desde ya muchas gracias.

Saludos

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Consultas
« Respuesta #1 : mayo 26, 2020, 10:24:36 am »
Hola Pablo buen dia,
Al querer crear un proyecto nuevo “curso” en toba, que ya tenía el proyecto Guaraní y los  propios de toba (editor, referencia y usuarios) se borraron carpetas y no corrió más toba ni guaraní. Se creó con el comando ./toba proyecto crear x línea de comando de Linux siguiendo las instrucciones en instancias de desarrollo.
Supongo que te referis a estas instrucciones no?.
Lo que paso probablemente es que el comando te sobreescribio la carpeta de Guarani al crear el proyecto.

Citar
Entonces las consultas son:
1.   ¿Pueden existir varios proyectos en la misma instalación e instancia de toba? ¿Cómo, que puntos hay que tener en cuenta?
Si pero no, es decir... antiguamente la organizacion de Toba favorecia que existieran multiples proyectos por cada instalacion del framework.
Actualmente todo gira en torno a una aplicacion y por eso Toba queda mas como libreria que otra cosa,, ese cambio organizacional hace mas dificil que puedan convivir varios proyectos en una instalacion.

No hay una restriccion fuerte que lo impida, solo es mas dificil llevarlo adelante porque uno de los proyectos seria la aplicacion ppal y el otro deberia quedar relegado a la carpeta vendor, donde se bajaria como una libreria mas... y eso si haces el manejo manualmente, sino practicamente no hay forma.

Citar
2.   ¿Se pueden instalar más de un toba en misma máquina virtual en distintos path y que cada Toba tenga distintos proyectos? ¿Cómo, que puntos hay que tener en cuenta?
Absolutamente, lo unico que tenes que tener en cuenta es que no se te superpongan los alias en el web server y que tengas bases de datos separadas para cada instancia de Toba.

Citar
3.   ¿Cuál es la relación entre los usuarios de toba_usuarios y los usuarios de Guaraní, ya que son bases de datos distintas, igual con los perfiles funcionales y de datos que se pueden crear en toba?.
Esta es una pregunta que deberias canalizar via el foro de G3, yo te puedo decir que toba_usuarios se usa para crear perfiles funcionales y quizas de datos.. el resto creo que se lleva en la bd de G3.. pero mejor consultalo con ellos que son los que crearon el esquema.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

pdassale

  • Newbie
  • *
  • Mensajes: 5
    • Ver Perfil
  • Institución: Universidad Austral
  • Nombre y apellido: Pablo Assale
  • Sistema: Toba, Guarani
  • Teléfono laboral: 1555789044
Re:Consultas
« Respuesta #2 : mayo 26, 2020, 04:42:06 pm »
Muchas Gracias por las respuestas Richard, una consuta mas:

¿Hay instructivo paso x paso de los pre-requisitos a instalar en una maquina virtual para toba 3.3 (a lo mejor lo hay y no lo veo)?.  Los de github, no detalla paso por paso, intente instalar por composer y sumarle los requisitos de Guarani 3.17  sin suerte.
O si existe una imagen para subir con virtualBox mucho mejor...

desde ya muchas gracias.

Saludos!

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Consultas
« Respuesta #3 : mayo 29, 2020, 01:24:52 pm »
Hola Pablo,
¿Hay instructivo paso x paso de los pre-requisitos a instalar en una maquina virtual para toba 3.3 (a lo mejor lo hay y no lo veo)?.  Los de github, no detalla paso por paso, intente instalar por composer y sumarle los requisitos de Guarani 3.17  sin suerte.

Paso a paso no existe mas porque eso es propio de cada software que usamos y mantener todas las opciones se hizo engorroso, si te puedo dar una lista de lo que deberia contener la VM, luego el proceso de instalacion dependera del sistema operativo que elijas.

A esa lista basica hay que sumarle composer y Yarn, que cada uno tiene sus dependencias.

Luego de eso,  composer se va a encargar en gran parte de avisarte si te falta alguna extension de PHP o si la version que necesitas es superior via los requerimientos de plataforma que vamos especificando.

Si mal no recuerdo guarani 3.17 salio con una version de Toba que tenia requerimientos bastante diferentes, de hecho usaba Bower en lugar de Yarn.

Para Toba 3.3, vas a necesitar como minimo PHP 7.3.. eso seguramente entre en conflicto con muchas de las librerias que solicitaba la version que tiene Guarani 3.17. Por el lado de Postgres cualquier version > 9.6 va bien.

Lo que estas haciendo, necesita convivir con G3 en la misma maquina o la misma instalacion?, en el primer caso podes llegar a tener instaladas las dos versiones de PHP quizas y con eso zafar, de nuevo como hacer eso es propio de cada SO, si es que lo permite ademas.

Citar
O si existe una imagen para subir con virtualBox mucho mejor...
Lo que existen son imagenes Docker para correr un proyecto hecho en Toba y/o desarrollar con eso... pero no creo que sea lo que estas buscando.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

pdassale

  • Newbie
  • *
  • Mensajes: 5
    • Ver Perfil
  • Institución: Universidad Austral
  • Nombre y apellido: Pablo Assale
  • Sistema: Toba, Guarani
  • Teléfono laboral: 1555789044
Re:Consultas
« Respuesta #4 : junio 02, 2020, 10:37:11 am »
Hola Richard, buen día.

La idea en principio es instalar la última versión de Toba 3.3, mas guaraní  en mi VM ,ahora está instalada la versión 3.17 (que entiendo es la última) en un servidor de test.
En el corto plazo w3 calculo también. ¿Para esto es mejor instalar otro toba en otra carpeta?. O sea uno para Guarani Gestión y otra para w3?. O directamente en  2 ambientes separados gestión y w3 en disitntas VM?

Tengo una vm (en Windows 10), con virtualbox y Ubuntu 20.4 LTS. Instale lo básico para toba 3.3, seguí las instrucciones del archivo que indicas ( las de Instalación en Máquina Host (Ubuntu))
composer , Yarn y apache 7.4.
Puede haber conflictos con php? Entonces no recomendas usar toba 3.3 con guaraní 3.17.

Desde ya muchas gracias.

Saludos!

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Consultas
« Respuesta #5 : junio 02, 2020, 03:41:48 pm »
Hola Pablo,
La idea en principio es instalar la última versión de Toba 3.3, mas guaraní  en mi VM ,ahora está instalada la versión 3.17 (que entiendo es la última) en un servidor de test.

Entiendo, para eso vas a necesitar tener instaladas al menos dos versiones de PHP al mismo tiempo, 7.1 y 7.3, tambien vas a requerir como te decia antes dos manejadores distintos de assets js, Bower (1.8.4+) y Yarn.

Citar
En el corto plazo w3 calculo también. ¿Para esto es mejor instalar otro toba en otra carpeta?. O sea uno para Guarani Gestión y otra para w3?. O directamente en  2 ambientes separados gestión y w3 en disitntas VM?

No tengo claro cuales sean los requerimientos puntuales de W3, calculo que deben ser bastante similares a los de G3.. y el metodo de instalacion recomendado seguramente figura en la documentación de G3.

Citar
Puede haber conflictos con php? Entonces no recomendas usar toba 3.3 con guaraní 3.17.
Ciertamente el conflicto lo vas a tener por el lado de PHP, la mayoria de las libs de la version de Toba que tiene G3 fueron pensadas para 7.0/7.1, con las extensiones particulares de esas versiones. Muy probablemente te pase lo siguiente:

1.- Composer se va a negar a bajar los paquetes por la version de PHP
2.- Suponiendo que los baje pidiendole que ignore el requerimiento, es bastante probable que algun falle debido a que le falte la extension mcrypt (la cual no es instalable en 7.2+)
3.- Aun teniendo la suerte de esquivar los paquetes dependientes de esas extensiones, nada te garantiza que el resto del codigo siga funcionando adecuadamente ya que PHP metio muchos cambios en el medio, algunos incluso no compatibles... para los cuales las librerias van sacando nuevas versiones normalmente.

En sintesis:

- G3 tiene su propia version de Toba (3.0.x) la cual necesita una version especifica de PHP.
- Toba 3.3 tiene otros requerimientos de PHP mas actuales .
- Podes instalarlos en una misma VM?.. probablemente si, pero no va a ser sencillo ni directo ya que para todo lo que hagas en ambos casos vas a tener que especificar la version de PHP a usar.

Fuera de los requerimientos de PHP que tienen las dos diferentes versiones del framework y el caso de Bower, el resto creo que te serviria.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.