Autor Tema: envio de mail  (Leído 159 veces)

0 Usuarios y 1 Visitante están viendo este tema.

dario fernandez

  • General Guarani
  • *
  • Mensajes: 46
    • Ver Perfil
    • Email
  • Institución: iese
  • Nombre y apellido: Dario Jose Fernandez
  • Sistema: Guarani
  • Teléfono laboral: 47793349
envio de mail
« : junio 02, 2020, 06:31:25 pm »
Estimados, tengo instalado el KOLLA 4.3.0 , finalmente. Pero me tira el siguiente problema al querer realizar el envio de mails

  "Necesita predeterminar una conexión SMTP en Configuración > Configuración de Mail" .

Dentro de Inicio -> Configuración->Configuración de E-mails tengo cargada el servidor smtp

 Configuración    Remitente            Mail                               Host                              Puerto     Usuario           Autenticación    Seguridad    Predeterminada
smtpconfig        FIE -ENCUESTAS   xxxx@iue.edu.ar   smtp.gmail.com   465   xxxxx@iue.edu.ar   SI                       SSL                                   NO

cuando ingreso para cambiar si es predeterminada o no ,  me lo permite hacer pero al salir no me guarda el cambio.
Supongo que es un tema de permisos pero no encontre donde guarda este valor.

Busque en smtp.ini y no esta ese parámetro, tampoco en la tabla de la base.

Gracias por su tiempo.

DARIO FERNANDEZ

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 732
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:envio de mail
« Respuesta #1 : junio 03, 2020, 09:16:37 am »
Buenos días Darío,
habría que revisar los logs de Kolla y los logs de php/apache para ver qué está ocurriendo que no queda guardada la modificación.

No guardamos esta información en tablas de la base, el archivo smtp.ini debería tener cargada la información de la cuenta que ves desde la operación del sistema, ¿esto no es así?

Saludos.
2

Rodrigo García Aponte

  • Full Member
  • ***
  • Mensajes: 128
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Tucumán
  • Nombre y apellido: Rodrigo García Aponte
  • Sistema: SIU-Pilaga, SIU-Wichi, SIU-Diaguita, SIU-Kolla, SIU-Arai.
  • Teléfono laboral: 03814247752 int 7143
  • Utilizo algun sistéma del SIU: Sí
Re:envio de mail
« Respuesta #2 : noviembre 17, 2020, 11:21:38 am »
Buen día.
Estamos teniendo el mismo problema en UNT, no queda guardada la conexión predeterminada como SI.
Versión de Kolla 4.3.2.

Parámetros de smtp.ini

[kollaunt]
nombre_from = "SIU-kolla Universidad Nacional de Tucumán"
from = "kolla@rectorado.unt.edu.ar"
host = "correo.unt.edu.ar"
puerto = "587"
usuario = "kolla@rectorado.unt.edu.ar"
clave = "**********"
seguridad = "tls"
auth = "1"
predeterminada = "1"

Realizo el test y Funciona.

Pero cuando vuelvo a ingresar a la operación Configuración de E-mails vuelve a aparecerme el Predeterminada en NO.
Adjunto Captura.
Rodrigo García Aponte

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 732
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:envio de mail
« Respuesta #3 : noviembre 18, 2020, 08:16:46 am »
Buen día Rodrigo,
¿cómo definieron los datos del smpt.ini?

Parámetros de smtp.ini

[kollaunt]
nombre_from = "SIU-kolla Universidad Nacional de Tucumán"
from = "kolla@rectorado.unt.edu.ar"
host = "correo.unt.edu.ar"
puerto = "587"
usuario = "kolla@rectorado.unt.edu.ar"
clave = "**********"
seguridad = "tls"
auth = "1"
predeterminada = "1"

En particular ese campo "predeterminada" no lo crea Kolla. Deben usar la operación Configuración -> Configuración de E-mails y activar el tilde "Conexión predeterminada" y luego de presionar "Guardar" los cambios deberían persistir. El dato de cuál es la conexión predeterminada no se configura en ese archivo.
Por favor controlá si haciéndolo de esta manera los cambios persisten.
Saludos.
Clara
2

Rodrigo García Aponte

  • Full Member
  • ***
  • Mensajes: 128
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Tucumán
  • Nombre y apellido: Rodrigo García Aponte
  • Sistema: SIU-Pilaga, SIU-Wichi, SIU-Diaguita, SIU-Kolla, SIU-Arai.
  • Teléfono laboral: 03814247752 int 7143
  • Utilizo algun sistéma del SIU: Sí
Re:envio de mail
« Respuesta #4 : noviembre 18, 2020, 11:14:49 am »
Buen día Clara.
Saque el parámetro Predeterminada.
Cuando pongo en Guardar y vuelve a la configuración de E-mails me muestra el SI en conexión predeterminada pero no la persiste, por que vuelvo a Inicio y nuevamente a configuración de E-mails y ya me aparece en NO la conexión predeterminada.
Saludos.

Rodrigo.
Rodrigo García Aponte

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 732
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:envio de mail
« Respuesta #5 : noviembre 18, 2020, 01:21:27 pm »
Rodrigo,
¿al terminar la instalación de 4.3.2 corrieron el comando que acomoda los permisos de la instalación?
Quizas no se está pudiendo guardar cuál es la predeterminada, que se hace en el archivo .../instalacion/instalacion.ini
Saludos.

Rodrigo García Aponte

  • Full Member
  • ***
  • Mensajes: 128
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Tucumán
  • Nombre y apellido: Rodrigo García Aponte
  • Sistema: SIU-Pilaga, SIU-Wichi, SIU-Diaguita, SIU-Kolla, SIU-Arai.
  • Teléfono laboral: 03814247752 int 7143
  • Utilizo algun sistéma del SIU: Sí
Re:envio de mail
« Respuesta #6 : noviembre 18, 2020, 03:56:19 pm »
Muchas gracias Clara.
Pude solucionar el problema, efectivamente estaba en .../instalacion.ini, tenia una por defecto y puse mi conexión kollaunt.
Si corrí el comando que acomoda los permisos cuando terminamos de actualizar a 4.3.2 y no me dio ningún error.
Saludos y gracias nuevamente.
Rodrigo García Aponte

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 732
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:envio de mail
« Respuesta #7 : noviembre 19, 2020, 08:23:14 am »
Rodrigo,
vas a tener que revisar de todas maneras los permisos porque no tendría que ser necesario que lo edites a mano. Al guardar la configuración mediante la operación se tendría que haber actualizado ese campo del archivo. Si eso no ocurrió seguramente la asignación de permisos no es la correcta y eso puede traerte otro tipo de problemas en otro momento.
Saludos.

1

Rodrigo García Aponte

  • Full Member
  • ***
  • Mensajes: 128
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de Tucumán
  • Nombre y apellido: Rodrigo García Aponte
  • Sistema: SIU-Pilaga, SIU-Wichi, SIU-Diaguita, SIU-Kolla, SIU-Arai.
  • Teléfono laboral: 03814247752 int 7143
  • Utilizo algun sistéma del SIU: Sí
Re:envio de mail
« Respuesta #8 : noviembre 19, 2020, 09:47:12 am »
Bueno Clara.
Muchísimas gracias.
Saludos.
Rodrigo García Aponte