Autor Tema: [SOLUCIONADO]error 404  (Leído 104 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sandraz

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: -
  • Nombre y apellido: sandra
  • Sistema: Ninguno
  • Teléfono laboral: --
[SOLUCIONADO]error 404
« : junio 15, 2020, 09:42:17 am »
Hola, buen día

Estoy teniendo este problema al querer acceder al toba_editor/2.4

Not Found

The requested URL was not found on this server.
Apache/2.4.29 (Ubuntu) Server at localhost Port 80

En los log, lo unico que encontre es lo  siguiente:

sudo tail -f /var/log/apache2/access.log
"GET /toba_editor/2.4/ HTTP/1.1" 404 488 "-" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:77.0) Gecko/20100101 Firefox/77.0"


sudo tail -f /var/log/apache2/error.log
[mpm_prefork:notice] [pid 1169] AH00163: Apache/2.4.29 (Ubuntu) configured -- resuming normal operations
[core:notice] [pid 1169] AH00094: Command line: '/usr/sbin/apache2'


« Última Modificación: julio 16, 2020, 12:40:00 pm por richard »

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error 404
« Respuesta #1 : junio 16, 2020, 10:25:24 am »
Hola Sandra,

verificaste que el archivo toba.conf este cargado en Apache y no se haya producido ningun error al reiniciar el web server?.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

sandraz

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: -
  • Nombre y apellido: sandra
  • Sistema: Ninguno
  • Teléfono laboral: --
Re:error 404
« Respuesta #2 : junio 16, 2020, 11:25:13 am »
Hola richard, buen día

Reinicio sin ningún error.
El archivo toba_2_4  esta cargado en /etc/apache2/sites-enabled

Ajunto el toba.conf del instalador y el archivo del apache, pero ambos son iguales.

Puede que me este faltando alguna librería del php.

Quiero aclarar que tengo instalado dos versiones de php,

Los proyectos que tengo en php 7, con toba 2.7 funcionan correctamente

Pero no logro hacer funcionar el 2.4

con estos comandos cambio de versión.


De php7.2 a php5.6:
sudo a2dismod php7.2
sudo a2enmod php5.6
sudo service apache2 restart
sudo update-alternatives –set php /usr/bin/php5.6


De php5.6 a php7.2
sudo a2dismod php5.6
sudo a2enmod php7.2
sudo service apache2 restart
sudo update-alternatives --set php /usr/bin/php7.2
« Última Modificación: junio 16, 2020, 11:44:36 am por sandraz »

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error 404
« Respuesta #3 : junio 19, 2020, 10:54:46 am »
Hola Sandra,

creo que el problema viene justamente por una conjuncion de cosas:

- La configuracion de los alias fue pensada para apache 2.2/2.3
- Vos estas usando Apache 2.4+

Hay dos posibles soluciones, una es activar mod_access_compat si lo tenes disponible, la otra es que actualices los alias manualmente para que Apache los tome como validos.

Fijate que los alias que tenes en proyectos con Toba 2.7 son distintos y tienen una seccion de configuracion diferenciada segun la version de Apache que se use.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

sandraz

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: -
  • Nombre y apellido: sandra
  • Sistema: Ninguno
  • Teléfono laboral: --
Re:error 404
« Respuesta #4 : julio 14, 2020, 11:32:57 am »
Hola Rcihard

Cambie las alias para que el apache tome como válido.

Adjunto el archivo toba.conf

Ya no tengo el mismo error.   Carga la pantalla de inicio para seleccionar proyecto e ingresar usuario.

Pero al querer ingresar al toba referencia se presenta este error.

 Fatal error: Call to undefined function utf8_decode() in /home/sandra/www/toba2.4/php/nucleo/lib/toba_memoria.php on line 98

richard

  • Moderador Global
  • *****
  • Mensajes: 2717
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error 404
« Respuesta #5 : julio 14, 2020, 12:33:30 pm »
Hola Sandra,
Fatal error: Call to undefined function utf8_decode() in /home/sandra/www/toba2.4/php/nucleo/lib/toba_memoria.php on line 98

te estan faltando las extensiones para el manejo de XML en php, por eso no encuentra la funcion.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

sandraz

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: -
  • Nombre y apellido: sandra
  • Sistema: Ninguno
  • Teléfono laboral: --
Re:error 404
« Respuesta #6 : julio 15, 2020, 10:07:12 am »
Solucionado.

Muchísimas gracias.!!!