Autor Tema: Consulta instalación API Arai Proveedores v1.0beta  (Leído 261 veces)

0 Usuarios y 1 Visitante están viendo este tema.

lramirez

  • Moderador
  • *****
  • Mensajes: 222
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Consulta instalación API Arai Proveedores v1.0beta
« : abril 25, 2020, 06:49:34 pm »
Carlos Ruiz (cailovirtual@gmail.com) escribió:
Hola buenas tardes, Leo perdona que te joda, como te comentaba los otros días estaba por probar la versión beta de arai proveedores api pero me encontré con este problema...Si tengo instalado PHP 7.2 me sale el siguiente error en el composer:
==============================================cailo@arai-api:/siu/proovedores-api$  composer install --no-dev --prefer-dist
Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for paragonie/halite v1.6.0 -> satisfiable by paragonie/halite[v1.6.0].
    - paragonie/halite v1.6.0 requires php >=5.6.0 <7.2 -> your PHP version (7.2.30) does not satisfy that requirement.

-- =============================================
Y si instalo la versión de PHP 7.1 me sale..
=============================================cailo@arai-api:/siu/proovedores-api# composer install --no-dev --prefer-dist
Loading composer repositories with package information
Installing dependencies from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for doctrine/dbal v2.10.1 -> satisfiable by doctrine/dbal[v2.10.1].
    - doctrine/dbal v2.10.1 requires php ^7.2 -> your PHP version (7.1.33) does not satisfy that requirement.
  Problem 2
    - Installation request for doctrine/lexer 1.2.0 -> satisfiable by doctrine/lexer[1.2.0].
    - doctrine/lexer 1.2.0 requires php ^7.2 -> your PHP version (7.1.33) does not satisfy that requirement.
  Problem 3
    - Installation request for pimple/pimple v3.3.0 -> satisfiable by pimple/pimple[v3.3.0].
    - pimple/pimple v3.3.0 requires php ^7.2.5 -> your PHP version (7.1.33) does not satisfy that requirement.
  Problem 4
    - doctrine/dbal v2.10.1 requires php ^7.2 -> your PHP version (7.1.33) does not satisfy that requirement.
    - enqueue/dbal 0.9.15 requires doctrine/dbal ^2.6 -> satisfiable by doctrine/dbal[v2.10.1].
    - Installation request for enqueue/dbal 0.9.15 -> satisfiable by enqueue/dbal[0.9.15].
==============================================
Que hago?
Saludos.-
Carlos Ruiz
--- C@ilo ---

lramirez

  • Moderador
  • *****
  • Mensajes: 222
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:Consulta instalación API Arai Proveedores v1.0beta
« Respuesta #1 : abril 25, 2020, 06:51:32 pm »
Hola,

Se me ocurren dos caminos a seguir:

1 - Hacer el composer install agrendando un --ignore-platform-reqs
2 - Tomar el Dockerfile del proyecto, hacer un docker build y correrlo dockerizado

Saludos


Carlos Ruiz

  • General
  • *
  • Mensajes: 12
    • Ver Perfil
  • Institución: UNSL
  • Nombre y apellido: Carlos Ruiz
  • Sistema: Pilaga - Diaguita - Wichi - O3 - Arai
  • Teléfono laboral: 0266-4520300 int. 5121
  • Utilizo algun sistéma del SIU: Sí
Re:Consulta instalación API Arai Proveedores v1.0beta
« Respuesta #2 : abril 30, 2020, 12:44:57 pm »
Hola buenos días,

Leonardo, te quería comentar un par de cosas, en primer lugar te comento que estoy usando para estas pruebas:

PHP 7.2.30
psql (PostgreSQL) 9.6.17
Clone tag v1.0.0-beta
git clone --branch v1.0.0-beta https://hub.siu.edu.ar/siu-arai/proovedores-api.git

1- Probé hacer el composer install agregando --ignore-platform-reqs

cailo@arai-api:/siu/proovedores-api$ composer install --no-dev --prefer-dist --ignore-platform-reqs

Eso funciono, pero a la hora de instalar...

5) Crear base de datos de Araí Proveedores
==========================================

PHP Fatal error:  Uncaught Error: Class 'SIU\AraiProveedores\AraiProveedoresApi' not found in /siu/proovedores-api/src/SIU/ProveedoresApi/Instalador/ConvertirBase.php:124
Stack trace:
#0 /siu/proovedores-api/src/SIU/ProveedoresApi/Instalador/ConvertirBase.php(117): SIU\ProveedoresApi\Instalador\ConvertirBase->ejecutarMigracionesProveedores(Object(Monolog\Logger))
#1 /siu/proovedores-api/src/SIU/ProveedoresApi/Instalador/Paso/CrearBaseProveedores.php(54): SIU\ProveedoresApi\Instalador\ConvertirBase->generarBaseAraiProveedores(Array, Object(Monolog\Logger))
#2 /siu/proovedores-api/src/SIU/ProveedoresApi/Instalador/Paso/CrearBaseProveedores.php(28): SIU\ProveedoresApi\Instalador\Paso\CrearBaseProveedores->generarBaseAraiProveedores()
#3 /siu/proovedores-api/vendor/siu/instalador/src/SIU/Instalador/Paso.php(163): SIU\ProveedoresApi\Instalador\Paso\CrearBaseProveedores->run()
#4 /siu/proovedores-api/vendor/siu/instalador/src/SIU/Instalador/Workflow.php(186): SIU\Instalador\Paso->execute()
#5 /siu/proovedores-api/vendor/siu/instalad in /siu/proovedores-api/src/SIU/ProveedoresApi/Instalador/ConvertirBase.php on line 124

Preguntas:

* Necesitas tener si o si Arai-Registry para poner a funcionar Arai-Proveedores (con el API disponible)? ya que en el log sale:
MAIN.ERROR: [ Registry ] Falta el parámetro 'url' para poder conectarse a la API de Registry
MAIN.WARNING: Faltan parámetros para conectar al servicio, verifique los parámetros de conexión

* En el archivo arai-proveedores.env en ###### CONFIG DE LA BASE DE NEGOCIO ###### apuntas a la base de arai proveedores?.
Me refiero a la base que esta sincronizada con SIU-Pilaga y SIU-Diaguita.

2- Estaba viendo que en la documentación dice -> Ver instalacion de sodium y para instalar sodium usan php7.1 por el soporte con ARAI
http://documentacion.siu.edu.ar/wiki/IT/Sodium

PHP   libsodium en PHP   sodium en S.O.   SIU-Araí
Paragonie/Halite 1.6   5.6 - 7.0 - 7.1   1.0.6 a 1.0.7   1.0.6 o superior   2.0.0
Paragonie/Halite 3.x   7.0 - 7.1 - 7.2   2.0.4 a 2.0.10   1.0.9 o superior   x
Paragonie/Halite 4.x   7.2   -   1.0.13 o superior   x

y como comente anteriormente cuando estaba usando php 7.1 me dio muchos errores el composer install.

3- En la documentación https://hub.siu.edu.ar/siu-arai/proovedores-api/-/blob/master/doc/install/INSTALACION_MANUAL.md
Dice: git clone --branch <VERSION> https://gitlab.siu.edu.ar/siu-arai/proveedores-api.git . tendría que decir para el caso nuestro
https://hub.siu.edu.ar/siu-arai/proovedores-api.git

Saludos.-
« Última Modificación: abril 30, 2020, 03:16:51 pm por Carlos Ruiz »

lramirez

  • Moderador
  • *****
  • Mensajes: 222
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Leonardo Ramirez
  • Sistema: Integración Funcional - SIU Calchaqui - Arai Catálogos
  • Teléfono laboral: +54 (011) 5217-3101 int. 230
Re:Consulta instalación API Arai Proveedores v1.0beta
« Respuesta #3 : mayo 04, 2020, 09:58:53 am »
Buen día,

Acabo de sacar una beta 2 (https://hub.siu.edu.ar/siu-arai/proovedores-api/-/tree/v1.0.0-beta2) que resuelve el problema de instalación y suma nuevos servicios para la integración con el nuevo Portal de proveedores.
Podes instalarlo y realizar pruebas sin tener instalado Arai Registry.
Respecto al tema dependencias, lo ideal es correrlo dockerizado para evitar lidiar con esas cuestiones.
Con respecto a la documentación, gracias por el aviso, ahora lo actualizo.

Saludos