Autor Tema: Error al configurar password de admin de Arai-Usuarios.  (Leído 206 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Error al configurar password de admin de Arai-Usuarios.
« : septiembre 16, 2020, 04:38:54 pm »
Problemas de instalación al desplegar Arai-Usuarios.

Buenas tardes.

Estoy siguiendo la documentación de implementacion de expediente digital y en el paso previo al hacer el despliegue de Arai tengo el siguiente  error.

In UsuariosManager.php line 441:
No se pudo crear el objeto en el servidor LDAP: No such object
In Ldap.php line 930:
No se pudo crear el objeto en el servidor LDAP: No such object

Este error lo tengo cuando quiero configurar la contraseña de admin de Arai-Usuarios.

ADMIN_PASS=CONTRASEÑA  docker stack deploy \
    --with-registry-auth \
    -c util/usuarios_crear_admin.yml \
    boot

El servidor ldap esta instalado en un vm aparte  y fue creado desde cero según la documentacion de Arai.
Verifique poderme conectar con las credenciales suministradas en "usuarios.env" y no tuve inconvenientes.

Saludos

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 694
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #1 : septiembre 16, 2020, 05:37:24 pm »
Hola Juan,

Lo más probable sea la forma en que cargarlos los esquemas en el servicio LDAP. En la documentación, para despliegue manual de LDAP hay una serie de pasos que se usan para corroborar si todo está operativo.

PD: La versión de la doc dice "next" porque es lo que vamos mejorando en desarrollo.... pero para tu caso sirve :)
happy coding!!

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #2 : septiembre 17, 2020, 08:30:35 am »
Hola Sergio.

Estuve revisando la documentación que me comentaste  y el problema estaba en que no personalice el archivo "estructura-arai-usuarios.ldif" ante de ejecutar el comando ldapadd -x -W -D "cn=admin,dc=unx,dc=edu,dc=ar" -f estructura-arai-usuarios.ldif y por eso la estructura no se me generaba correctamente y luego no se podían crea los objetos. Editado este archivo y generada la estructura pude asignarle la clave a admin.

Gracias .
Saludos
Juan.-

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #3 : septiembre 17, 2020, 08:53:35 am »
Hola Sergio.

Te  comento que una ves terminada la instalación con los servicios levantados trato de ingresar a Arai-usuarios y tengo el error

404 page not found

Trate  de ingresar  con las siguientes url.

https://huarpe.unm.edu.ar y https://huarpe.unm.edu.ar/usuarios en ambos casos tuve el mismo inconveniente.

En la instalacion a uunn.local lo remplace por huarpe.unm.edu.ar

Cuando listo los servicios los veo que estan arriba (te copio la salida)

ID                  NAME                        MODE                REPLICAS            IMAGE                                                          PORTS
wpe5g2irnmrr        loki_grafana                replicated          1/1                 grafana/grafana:master                                         *:3000->3000/tcp
nomygml3mw9v        loki_loki                   replicated          1/1                 grafana/loki:1.5.0                                             *:3100->3100/tcp
miig5mmm2en2        traefik_reverse-proxy       global              2/2                 traefik:2.2                                                    *:80->80/tcp, *:443->443/tcp
mjfyt12hn5jr        usuarios_api                replicated          0/1                 hub.siu.edu.ar:5005/siu/expedientes/arai-usuarios/api:v3.0.2
k09bjx8gq48x        usuarios_idm                replicated          0/1                 hub.siu.edu.ar:5005/siu/expedientes/arai-usuarios/idm:v3.0.2
ucbxo5t9frib        usuarios_idp                replicated          0/1                 hub.siu.edu.ar:5005/siu/expedientes/arai-usuarios/idp:v3.0.2
hduoek546m1q        usuarios_memcached-server   replicated          1/1                 bitnami/memcached:1.6.6               

Donde puedo mirar algún log para ver que puede estar pasando..?
saludos
Juan.-



richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #4 : septiembre 17, 2020, 11:28:37 am »
Hola Juan,
Donde puedo mirar algún log para ver que puede estar pasando..?

para mirar los logs de los contenedores podes usar
Código: [Seleccionar]
docker service logs  CONTAINER_NAME

En este caso usuarios_idm seria un buen punto para ver que se haya levantado correctamente Arai-Usuarios.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #5 : septiembre 17, 2020, 11:43:52 am »

Hola Richard.

Me fije en los servicios  usuarios_api, usuarios_idm y usuarios_idp y ninguno arroja nada.
El servicio traefik_reverse-proxy  me arroja continuamente  la linea que copio mas abajo..

traefik_reverse-proxy.0.c7q2odi4pjcs@DS-NODO2    | time="2020-09-16T18:36:54Z" level=info msg="Skipping same configuration" providerName=docker

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 694
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #6 : septiembre 17, 2020, 03:29:43 pm »
Juan!

Vas a tener que, primero, asegurarte que estas logrando llegar a traefik. Este es un proxy reverso, es decir, todo el tráfico entra y sale por ahí. Si no llegas a traefik correctamente, no vas a poder continuar a usuarios/huarpe/etc.

Podrías intentar activar el dashboard de traefik, para revisar como detecta services/routes/middlewares. La documentación de traefik es https://docs.traefik.io/.  En docker swarm, acá está configurandose traefik https://hub.siu.edu.ar/siu/expedientes/-/blob/v1.0.2/prod/servicios/traefik.yml

Saludos!
happy coding!!

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #7 : octubre 07, 2020, 08:36:20 am »
Hola Sergio.

Estoy instalando un nuevo servidor de  arai/sudocu para ambiente de testing y cuando quiero generar la password de admin de Arai-Usuarios  con el comando de docker que figura en la documentación de expediente digital me  tira un error de php. La base de datos de Arai-usuarios es la 3.0.3

No abri un post nuevo porque me paracio que como es el mismo tema esta bueno que quede todo dentro del mismo post, pero si hay que abrir uno nuevo avisame.

Saludos
Juan .-

richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #8 : octubre 07, 2020, 11:47:32 am »
Hola Juan,
Estoy instalando un nuevo servidor de  arai/sudocu para ambiente de testing y cuando quiero generar la password de admin de Arai-Usuarios  con el comando de docker que figura en la documentación de expediente digital me  tira un error de php. La base de datos de Arai-usuarios es la 3.0.3

te hago una consulta, cuando hicieron la inicializacion del LDAP... generaron las entidades con el comando expuesto en el punto 5 de esta guia?, rastreando el error pareciera que no existe ningun grupo cargado en LDAP.. cuando por defecto se crea uno en dicho paso junto con el resto de las entidades.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

jetchevers

  • Newbie
  • *
  • Mensajes: 23
    • Ver Perfil
  • Institución: Universidad Nacional de Moreno
  • Nombre y apellido: Juan Manuel Etchevers
  • Sistema: ComDoc
  • Teléfono laboral: 0111545384841
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #9 : octubre 07, 2020, 12:00:11 pm »
Hola Ricardo

Efectivamente  genere las identidades, para ello modifique el archivo estructura-arai-usuarios.ldif para personalizarlo.
El archivo quedo de la siguiente manera:

# Entry Usuarios: ou=usuarios,dc=unx,dc=edu,dc=ar
dn: ou=usuarios,dc=unm,dc=edu,dc=ar
changetype: add
objectclass: top
objectclass: organizationalUnit
ou: usuarios

# Entry Usuarios Cuentas: ou=usuariosCuentas,dc=unx,dc=edu,dc=ar
dn: ou=usuariosCuentas,dc=unm,dc=edu,dc=ar
changetype: add
objectclass: top
objectclass: organizationalUnit
ou: usuariosCuentas

# Entry Grupos: ou=groups,dc=unm,dc=edu,dc=ar
dn: ou=groups,dc=unx,dc=edu,dc=ar
changetype: add
objectclass: top
objectclass: organizationalUnit
ou: groups

# Subgrupo devs: cn=devs,ou=groups,dc=unx,dc=edu,dc=ar
dn: cn=devs,ou=groups,dc=unm,dc=edu,dc=ar
changetype: add
objectclass: groupofnames
cn: devs
member: cn=admin,dc=unm,dc=edu,dc=ar

También verifique que la estructura estuviera creada como indica el paso 8.
ldapsearch -x -W -D "cn=admin,dc=unm,dc=edu,dc=ar" -b "dc=unm,dc=edu,dc=ar"

La salida del mismo fue..

Enter LDAP Password:
# extended LDIF
#
# LDAPv3
# base <dc=unm,dc=edu,dc=ar> with scope subtree
# filter: (objectclass=*)
# requesting: ALL
#

# unm.edu.ar
dn: dc=unm,dc=edu,dc=ar
objectClass: top
objectClass: dcObject
objectClass: organization
o: unm.edu.ar
dc: unm

# admin, unm.edu.ar
dn: cn=admin,dc=unm,dc=edu,dc=ar
objectClass: simpleSecurityObject
objectClass: organizationalRole
cn: admin
description: LDAP administrator
userPassword:: e1NTSEF9eUFsQW4yVE8zdW9TNzdNN0ZGS1VkM2hsQ1RhWXozK0s=

# usuarios, unm.edu.ar
dn: ou=usuarios,dc=unm,dc=edu,dc=ar
objectClass: top
objectClass: organizationalUnit
ou: usuarios

# usuariosCuentas, unm.edu.ar
dn: ou=usuariosCuentas,dc=unm,dc=edu,dc=ar
objectClass: top
objectClass: organizationalUnit
ou: usuariosCuentas

# 525abb56-c7be-4613-a5e6-715488510f6c, usuarios, unm.edu.ar
dn: uid=525abb56-c7be-4613-a5e6-715488510f6c,ou=usuarios,dc=unm,dc=edu,dc=ar
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: inetOrgPerson
objectClass: eduPerson
objectClass: labeledURIObject
objectClass: inetOrgPersonArai
uid: 525abb56-c7be-4613-a5e6-715488510f6c
cn: Usuario Administrador
sn: Admin
userPassword:: e0NSWVBUfSQyeSQxMCQ1enowMHJaRWFnQmJHc0tpLmRUVnplaGpjTVZsdUZsVzl
 vZUxKdHJrMUkxb3k2UXc3VW9YdQ==
givenName: Usuario Administrador
mail: admin@example.com
bloqueado: 0
login: admin
loginMethod: uniqueIdentifier
uniqueIdentifier: admin

# search result
search: 2
result: 0 Success

# numResponses: 6
# numEntries: 5

Creo que eso esta ok.. pero por ahí hay algún error que no estoy viendo

Saludos
Juan.-
 

richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Error al configurar password de admin de Arai-Usuarios.
« Respuesta #10 : octubre 07, 2020, 03:54:06 pm »
Hola Juan,

te estaria faltando algo como lo siguiente en la respuesta a la consulta:

Código: [Seleccionar]
# groups
dn: ou=groups,dc=unm,dc=edu,dc=ar
objectClass: top
objectClass: organizationalUnit
ou: groups

# devs, groups
dn: cn=devs,ou=groups,dc=unm,dc=edu,dc=ar
objectClass: groupOfNames
cn: devs
member: cn=admin,dc=unm,dc=edu,dc=ar

El problema por lo que veo esta en la siguiente entrada del archivo estructura-arai-usuarios.ldiff

Citar
# Entry Grupos: ou=groups,dc=unm,dc=edu,dc=ar
dn: ou=groups,dc=unx,dc=edu,dc=ar
changetype: add
objectclass: top
objectclass: organizationalUnit
ou: groups

Fijate que el DN para los grupos esta con una X en lugar de unm (Sergio ojos de halcon lo vio al toque :D), con lo cual la parte de grupos  te quedo sin aplicar y por eso el fallo al realizar el comando.
Probablemente mucho de lo que vino despues de ese punto tambien haya quedado raro, asi que lo mejor seria que luego de hecha la correccion en el archivo arranques nuevamente asi nos aseguramos hasta ese punto que fue todo como deberia y si encontras algo mas podemos descartar que sea consecuencia de.

Saludos

Twitter es al incontinente verbal,  lo que los dulces al diabetico.