Autor Tema: error en composer.json  (Leído 125 veces)

0 Usuarios y 1 Visitante están viendo este tema.

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
error en composer.json
« : octubre 29, 2020, 11:21:09 am »
Ingeniero, buen día
Estamos tratando de descarcargar la última versión del framawork 3.3, con los pasos indicados, pero NO hemos podido, nos puedes orientar por favor?
en composer.json   tenemos (en visual studio indica dos errores del archivo, pero revisamos y está bien)

{
        "repositories": [
            {
                "type": "composer",
                "url": "https://satis.siu.edu.ar"
            }
        ],
        "require": {
            "siu-toba/framework": "^3.3",
            "siu/manejador-salida-bootstrap": "^1.2"
        },
       "scripts": {
            "post-install-cmd": [
              "composer run-script post-install-cmd -d ./vendor/siu-toba/framework/",
              "composer run-script post-install-cmd -d ./vendor/siu/manejador-salida-bootstrap/"
            ],
            "post-update-cmd": [
                "composer run-script post-install-cmd -d ./vendor/siu-toba/framework/",
                "composer run-script post-install-cmd -d ./vendor/siu/manejador-salida-bootstrap/"               
            ]
        },
        "minimum-stability": "dev",
        "prefer-stable" : true
}

Pero sale el siguiente error (ver gráfica)

Gracias y cordial saludo


richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error en composer.json
« Respuesta #1 : octubre 29, 2020, 11:41:24 am »
Buen dia Jhon,

actualizaron la version de composer a la rama 2.0, la cual coloca a todos los repositorios privados como canonicos y busca el paquete en dicho repo unicamente.
Es un tema con la version de composer, por el momento te diria que permanezcas en la rama 1.x  para evitar inconvenientes.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

obelgran

  • Full Member
  • ***
  • Mensajes: 123
    • Ver Perfil
  • Institución: Universidad Nacional de Rosario
  • Nombre y apellido: Oscar Rafael Belgrano
  • Sistema: toba
  • Teléfono laboral: (0341) 4201245
Re:error en composer.json
« Respuesta #2 : octubre 30, 2020, 12:14:51 pm »
Buenas tuve un problema similar...
Si el problema es la versión de composer (^2.0), yo pude hacer "update" colocando "canonical = false" en el repositorio:
Así quedó:
Código: [Seleccionar]

 "repositories": [
    {
      "type": "composer",
      "url": "https://satis.siu.edu.ar",
      "canonical": false
    }
  ],
Espero que les sea de utilidad.
Saludos

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
Re:error en composer.json
« Respuesta #3 : octubre 30, 2020, 03:09:36 pm »
Mil gracias, así me funcionó
Tengo un problema inicial y es que al pasar un proyecto de la 2.7
desde el login, estan llenos de warnings

Warning: count(): Parameter must be an array or an object that implements Countable in C:\proyectos\toba_2_7\php\nucleo\lib\toba_editor.php on line 122

Y las interfaces cuando ingreso error
Warning: session_cache_limiter(): Cannot change cache limiter when session is active in C:\proyectos\toba_2_7\php\nucleo\lib\toba_http.php on line 18
Desfazando el tamaño normal de las etiquetas

Hay que modificar el apache.conf o  el php.ini ?
Alguna solución
Cordial Saludo
« Última Modificación: octubre 30, 2020, 03:56:01 pm por jorozco »

richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error en composer.json
« Respuesta #4 : noviembre 02, 2020, 10:27:11 am »
Hola Jhon,
Hay que modificar el apache.conf o  el php.ini ?
Alguna solución

depende la version de PHP que estes utilizando sera la version de Toba a la que debes migrar, por el mensaje diria que estas utilizando 7.2, por lo que la version minima de Toba seria en dicho caso 3.2.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
Re:error en composer.json
« Respuesta #5 : noviembre 03, 2020, 10:33:30 am »
Richard, buen día
La versión mínima es la recomendada en que es la 7.3.1
según entonces me confirmas que es la 7.3.2. ?

Gracias y cordial saludo

obelgran

  • Full Member
  • ***
  • Mensajes: 123
    • Ver Perfil
  • Institución: Universidad Nacional de Rosario
  • Nombre y apellido: Oscar Rafael Belgrano
  • Sistema: toba
  • Teléfono laboral: (0341) 4201245
Re:error en composer.json
« Respuesta #6 : noviembre 04, 2020, 10:20:10 am »
Hola Jhon!

Por lo que veo estás tratando de ejecutar un proyecto hecho en toba 2.7.x con PHP 7.X.X y por eso te está lanzando los "warnings", toba quedó obsoleto para esas versiones de php.

Lo que tendrías que hacer es una migración hacia toba 3.x.x con los comandos de TOBA.
Yo personalemte uso toba proyecto cargar, pero existe una opción específica para migrar proyectos desde una versión a otra.
Código: [Seleccionar]
toba proyecto migrar_toba
No sé si entendí bien, espero te sirva.
Saludos
Oscar

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
Re:error en composer.json
« Respuesta #7 : noviembre 05, 2020, 11:54:24 am »
Oscar, mil gracias por la ayuda,
si efectivamente siempre lo hago con importar,
trataré entonces con la que dices y te cuento.

Cordial Saludo

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
Re:error en composer.json
« Respuesta #8 : noviembre 09, 2020, 09:38:03 pm »
Inge, dos dudas
A raiz de que con importar se me está presentando muchos warnings de PHP, vamos aplicar el que nos sugiere Oscar

1.  cuando ejecutamos  el comando      ./toba proyecto migrar_toba -p webservice -i desarrollo -d "c:/proyectos/toba_2_7"
      SALE EL SIGUIENTE ERROR:   El número de versión c:/proyectos/toba_2_7 es incorrecto. Se requiere al menos  3 partes. El formato debe ser x.y.z (inestable- 
                                                                          build). Donde (inestable-build)  es opcional
     Como aplico lo de x.y.z sabiendo que la versión anterior  es la  2.7.13 

2. Cuando se aplica composer update hay que aplicar algun comando adicional como toba_proyect regenerar ? sobre algún proyecto ?

Gracias, Quedo atento
Cordial saludo
« Última Modificación: noviembre 09, 2020, 10:46:41 pm por jorozco »

richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error en composer.json
« Respuesta #9 : noviembre 10, 2020, 02:07:49 pm »
Hola Jhon,

creo que con cada paso te vas empantanando un poco mas, te diria que retrotraigas los pasos y comiences nuevamente, esto arranco porque no podias bajar la version de la rama 3.3.

Salvado ese punto, lo que te queda es hacer la migracion de versiones con el comando importar tal como hiciste en varias ocasiones.

Una vez actualizada la version de PHP.. no vas a poder usar aquello que se encuentre en version 2.7, ya que hubo cambios a nivel de lenguaje que la hacen incompatible en su funcionamiento.
Este punto no es negociable y los errores que surjan en el mismo son completamente esperables para algo que se hizo 5 años antes que la version del lenguaje.

Finalmente, para poder usar el comando migrar y actualizar sobre el mismo directorio, los pasos a realizar son distintos, como asi tambien los parametros del comando.

Respecto de esto ultimo, recorda que si invocas el comando sin modificadores te brinda la lista de parametros e informacion sobre que valores puede llevar.

Saludos


Twitter es al incontinente verbal,  lo que los dulces al diabetico.

jorozco

  • Hero Member
  • *****
  • Mensajes: 830
    • Ver Perfil
    • Email
  • Institución: Universidad Catòlica de Manizales
  • Nombre y apellido: Jhon Jairo Orozco D.
  • Sistema: Toba
Re:error en composer.json
« Respuesta #10 : noviembre 13, 2020, 09:48:40 am »
Richard, como siempre gracias por tu oportuna orientación
Me resta una respuesta, cuando aplicamos composer update, también hay que aplicar el  toba instancia regenerar?, mi pregunta es porque inicié en la versión 3.3.0 y y van en la 3.3.14.

Cordial Saludo

richard

  • Moderador Global
  • *****
  • Mensajes: 2771
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:error en composer.json
« Respuesta #11 : noviembre 13, 2020, 10:48:35 am »
Jhon,
Me resta una respuesta, cuando aplicamos composer update, también hay que aplicar el  toba instancia regenerar?, mi pregunta es porque inicié en la versión 3.3.0 y y van en la 3.3.14.
para cambios de version de 3er digito no es necesaria la regeneracion, si para los de 2do.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.