Autor Tema: Faltan archivos de requisitos en repositorio digital  (Leído 141 veces)

0 Usuarios y 1 Visitante están viendo este tema.

alotitokehoe

  • Jr. Member
  • **
  • Mensajes: 94
    • Ver Perfil
    • Email
  • Institución: UTN
  • Nombre y apellido: Agustin Lotito Kehoe
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Faltan archivos de requisitos en repositorio digital
« : octubre 08, 2020, 12:08:22 am »
Buenas noches,

Ya tenemos funcionando satisfactoriamente el repositorio digital con miles de cargas de documentos de cientos de alumnos. Pero en algunos alumnos estamos teniendo el problema en Administrar requisitos de una persona, que al hacer ' Doc draft' sale un mensaje de error "Se produjo un error al intentar obtener el archivo del repositorio digital". Revisando nuxeo vemos  lo que esperábamos, el documento no está.  En la preinscripción tenemos obligatorio la carga de los documentos de los requisitos. Y si revisamos la base de datos el alumno posee los requisitos documentales cargados.
¿Pudo haber pasado que se haya producido un error en el momento de la carga del archivo, se haya persistido en la base de datos y no se haya logrado guardar en nuxeo?. Nosotros cuando deployamos la aplicación hacemos un stop de apache, no de nuxeo. ¿Conocen algùn caso que haya ocurrido esto? Gracias

Agustìn

alotitokehoe

  • Jr. Member
  • **
  • Mensajes: 94
    • Ver Perfil
    • Email
  • Institución: UTN
  • Nombre y apellido: Agustin Lotito Kehoe
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #1 : octubre 09, 2020, 08:32:02 pm »
Buenas tardes. Pudieron ver algo de esto? perdón que insista pero nos está frenando inscripciones en produccion. Gracias!

Noté que en la tabla de Gestion sga_requisitos_digitales no contienen registros los casos en los que tenemos problemas. Si tienen registros en la tabla sga_requisitos_digitales_draft.
« Última Modificación: octubre 09, 2020, 08:57:51 pm por alotitokehoe »

Jesica Schnaiderman

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Jesica Schnaiderman
  • Sistema: SIU guarani
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #2 : octubre 13, 2020, 11:15:03 am »
hola
En que versión se encuentran?¿como esta instalado nuxeo, lo tienen en una virtual  podrían comentarnos un poco mas ? por lo que comentan, no son todos los casos. sino que a algunos les funciona y otros no?
el error es muy genérico deberíamos revisar que devuelve nuxeo. Para eso necesitamos revisar los logs
Como es algunos si y algunos no se nos  ocurre que podria llega a  ser extensiones de los archivos.
Dejo el link de las consideraciones  técnicas
como errores comunes
Sugeriría revisar los permisos y el paso Configuración de los tipos SIU para Nuxeo  y si los cambian reiniciar el nuxeo.

Por favor confirmarnos en que versión están trabajando y si pueden replicar el error en un entorno de desarrollo?

Consultaba la forma que esta instalado por que hacer poco tuvimos un caso de  caso de  Nuxeo que estaba montado sobre una infraestructura basada en contenedores."Aparentemente por un error en el sistema de deploy, los contenedores de los diferentes entornos estaban generando conflicto con el balanceador de carga que tienen delante, lo que hacía que los request no siempre lleguen al backend correcto. Se reimplementó el sistema de deploy, asegurando identificadores y redes independientes para cada entorno, lo que solucionó el problema."

muchas gracias
Saludos
2


alotitokehoe

  • Jr. Member
  • **
  • Mensajes: 94
    • Ver Perfil
    • Email
  • Institución: UTN
  • Nombre y apellido: Agustin Lotito Kehoe
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #3 : octubre 20, 2020, 03:28:15 pm »
Hola Jesica, gracias por tu respuesta. Los solucionamos borrando los regitros de la tabla sga_requisitos_digitales_draft y pidiendo al alumno que vuelva a subirlo. Ese caso de nuxeo que comentás fue nuestro también, y pensamos que estos errores son consecuencia del problema que nos surgió esa vez. Una pregunta:
Si un alumno está subiendo un archivo desde la aplicación, se guarda correctamente en la base de datos (por eso si aparece el registro en la base de datos) y bajamos el aplication server, por ejemplo por un deploy ¿No podría pasar que no se logre subir el archivo a nuxeo? sería este caso que estamos atravesando.

Jesica Schnaiderman

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Jesica Schnaiderman
  • Sistema: SIU guarani
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #4 : octubre 20, 2020, 03:51:46 pm »
Hola
La aplicación lo que hace es navegar a 3w desde el celular no debería tener problemas, es como que accedieran al 3w desde el navegador del celular.

 muchas gracias
 saludos
2

alotitokehoe

  • Jr. Member
  • **
  • Mensajes: 94
    • Ver Perfil
    • Email
  • Institución: UTN
  • Nombre y apellido: Agustin Lotito Kehoe
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #5 : octubre 21, 2020, 01:53:15 pm »
Perdón, cuando digo aplicación me refiero al sistema g3w3, no a la app movil.

Sergio Espínola

  • Moderador Global
  • *****
  • Mensajes: 869
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Espínola
  • Sistema: SIU-Guarani
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #6 : octubre 21, 2020, 05:27:10 pm »
Hola

Si el documento se guarda correctamente en el RDI, luego se actualiza el registro en la base de datos de la aplicación! ¿Tienen muchos casos de este problema?

Saludos!

alotitokehoe

  • Jr. Member
  • **
  • Mensajes: 94
    • Ver Perfil
    • Email
  • Institución: UTN
  • Nombre y apellido: Agustin Lotito Kehoe
  • Sistema: Guarani
  • Utilizo algun sistéma del SIU: Sí
Re:Faltan archivos de requisitos en repositorio digital
« Respuesta #7 : octubre 22, 2020, 02:26:45 pm »
Aah perfecto. Preguntaba por si el problema lo estaba ocasionando el stop de apache al hacer deploy, pero si persiste en la tabla luego de guardar en nuxeo  no es por eso.
Fueron varios casos pero los solucionamos uno por uno. Cada tanto aparece otro pero suponemos que fueron casos ocurridos esa misma vez por el problema que tuvimos en el servidor de nuxeo. Salvo que nos vuelva a aparecer otra tanda de casos con el error, cerramos el tema.
 Les agradezco a ambos por la ayuda!

Agustìn