Autor Tema: Instalacion CERO de server DESA siu guarani  (Leído 67 veces)

0 Usuarios y 1 Visitante están viendo este tema.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Instalacion CERO de server DESA siu guarani
« : noviembre 03, 2020, 08:17:52 am »
Buenos dias,

Estoy intentando instalar desde cero SIU GUARANI (En un DEBIAN 9). 

Me estoy basando en dos documentaciones para esto :

1- realice lo que menciona aca :  https://documentacion.siu.edu.ar/wiki/SIU-Guarani/version3.17.0/instalacion_desde_cero/requisitos_previos/linux

2 - Seguí esta documentacion ( https://documentacion.siu.edu.ar/wiki/SIU-Guarani/version3.17.0/instalacion_desde_cero/instalacion/gestion/linux ) hasta el punto de instalar composer , donde me devuelve el siguiente error/conflicto ( Screen adjunto )



¿ Me podrian ayudar ? Si me falto algun paso, por favor hacermelo saber.

Estuve tambien basandome en este tutorial, pero no veo que les aparezca el mismo problema ya que por lo que puedo ver, la carpeta "vendor" ya la tienen bajada en la clase  :  https://www.youtube.com/watch?v=EAodxx5GiMo&feature=emb_title&ab_channel=SIU

Muchas gracias,
Patricio.
« Última Modificación: noviembre 03, 2020, 08:23:47 am por plecolant »

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #1 : noviembre 03, 2020, 08:24:34 am »
Hola Patricio,

Tienen un error en el paso 4 del instructivo? Cuál es el mensaje? En la imagen que adjuntaste no veo errores.

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #2 : noviembre 03, 2020, 09:19:03 am »
Florencia, como andas?

Disculpa, fue mi error. Cargué mal la imagen. Adjunto la correcta.

"
Installing dependencies from lock file (including require-dev)
Verifying lock file contents can be installed on current platform.
Your lock file does not contain a compatible set of packages. Please run composer update.

  Problem 1
    - wikimedia/composer-merge-plugin is locked to version v1.3.1 and an update of this package was not requested.
    - wikimedia/composer-merge-plugin v1.3.1 requires composer-plugin-api ^1.0 -> found composer-plugin-api[2.0.0] but it does not match the constraint.

You are using Composer 2, which some of your plugins seem to be incompatible with. Make sure you update your plugins or report a plugin-issue to ask them to support Composer 2.
"


Gracias.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #3 : noviembre 03, 2020, 10:00:58 am »
Patricio,

Fijate en este post: http://foro.comunidad.siu.edu.ar/index.php?topic=20845.

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #4 : noviembre 03, 2020, 03:52:35 pm »
Gracias Florencia.

Volví a la version de Composer "1.10.15" ( como bien menciona en link que me pasaste ) y ahora me arroja los siguientes probelmas :

"
$ php composer.phar install
PHP Warning:  Module 'PDO' already loaded in Unknown on line 0
PHP Warning:  Module 'pdo_pgsql' already loaded in Unknown on line 0
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - siu-toba/framework v3.3.9 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.8 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.7 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.6 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.5 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.4 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.3 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.2 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.13 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.12 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.11 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.10 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.1 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.3.0 requires php >=7.3 -> your PHP version (7.1.33) does not satisfy that requirement.
    - siu-toba/framework v3.1.9 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.8 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.7 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.6 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.5 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.4 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.3 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.2 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.15 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.14 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.12 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.11 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.10 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.1 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.0 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.9 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.8 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.7 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.6 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.5 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.4 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.32 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.31 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.30 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.3 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.29 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.28 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.27 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.26 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.25 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.24 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.23 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.22 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.21 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.20 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.2 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.19 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.18 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.17 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.16 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.15 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.14 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.13 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.12 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.11 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.10 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.0.0 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework 3.1.13 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu/security-multitool v1.0 requires ircmaxell/random-lib dev-master@dev -> no matching package found.
    - siu-toba/framework 3.0.1 requires ircmaxell/random-lib dev-master -> no matching package found.
    - siu-toba/framework v3.1.16 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.1.17 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.12 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.13 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.14 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.15 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.16 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.17 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.18 conflicts with siu/arai-cli[v2.4.0].
    - siu-toba/framework v3.2.0 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.1 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.10 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.11 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.2 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.3 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.4 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.5 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.6 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.7 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.8 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - siu-toba/framework v3.2.9 requires siu/security-multitool 1.0 -> satisfiable by siu/security-multitool[v1.0].
    - Installation request for siu/arai-cli 2.4.0 -> satisfiable by siu/arai-cli[v2.4.0].
    - Installation request for siu-toba/framework ^3.0 -> satisfiable by siu-toba/framework[3.0.1, 3.1.13, v3.0.0, v3.0.10, v3.0.11, v3.0.12, v3.0.13, v3.0.14, v3.0.15, v3.0.16, v3.0.17, v3.0.18, v3.0.19, v3.0.2, v3.0.20, v3.0.21, v3.0.22, v3.0.23, v3.0.24, v3.0.25, v3.0.26, v3.0.27, v3.0.28, v3.0.29, v3.0.3, v3.0.30, v3.0.31, v3.0.32, v3.0.4, v3.0.5, v3.0.6, v3.0.7, v3.0.8, v3.0.9, v3.1.0, v3.1.1, v3.1.10, v3.1.11, v3.1.12, v3.1.14, v3.1.15, v3.1.16, v3.1.17, v3.1.2, v3.1.3, v3.1.4, v3.1.5, v3.1.6, v3.1.7, v3.1.8, v3.1.9, v3.2.0, v3.2.1, v3.2.10, v3.2.11, v3.2.12, v3.2.13, v3.2.14, v3.2.15, v3.2.16, v3.2.17, v3.2.18, v3.2.2, v3.2.3, v3.2.4, v3.2.5, v3.2.6, v3.2.7, v3.2.8, v3.2.9, v3.3.0, v3.3.1, v3.3.10, v3.3.11, v3.3.12, v3.3.13, v3.3.2, v3.3.3, v3.3.4, v3.3.5, v3.3.6, v3.3.7, v3.3.8, v3.3.9].

Potential causes:
 - A typo in the package name
 - The package is not available in a stable-enough version according to your minimum-stability setting
   see <https://getcomposer.org/doc/04-schema.md#minimum-stability> for more details.
 - It's a private package and you forgot to add a custom repository to find it

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
$
"



¿Tengo que instalar PHP 7.3 ? Según la documentación, con 7.1 era suficiente.

Aguardo respuesta.

Muchas gracias,
Patricio.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #5 : noviembre 04, 2020, 08:21:55 am »
Patricio,

Estás instalando la versión 3.17 de Guaraní?  Esa versión funciona con PHP 7.1.
La versión 3.18 requiere PHP 7.3.
Verificá cuál es la versión que descargaste ejecutando el comando "svn info" sobre la carpeta de la nueva instalación.

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #6 : noviembre 04, 2020, 09:16:41 am »
Florencia,

Si estoy instalando la versión de guarani 3.17.0 . En un Debian 9, no se si eso pueda provocar algún inconveniente.

Adjunto screen del resultado del comando "svn info"

Gracias,
Patricio.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #7 : noviembre 04, 2020, 10:06:17 am »
Patricio,

Adjuntá también el resultado del comando "svn status".

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #8 : noviembre 04, 2020, 10:38:39 am »
Adjunto lo que me solicitas,

Gracias.

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #9 : noviembre 04, 2020, 10:41:19 am »
Patricio,

Adjuntaste nuevamente el resultado de "svn info", faltaría "svn status".

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #10 : noviembre 04, 2020, 10:49:49 am »
Disculpa, cargue la misma imagen! Ahi fue adjunta.

Te habia hecho una consulta sobre el sistema operativo : ¿ Puede generar algun tipo de conflico instalar guarani 3.17.0 en un Debian 9 ? ¿ Aconsejan instarlo con otra version ? Me basé en la documentacion que no especifica exactamente que version sino que menciona : "Requisitos previos para la instalación en Linux – Distribuciones Debian o derivados"

Gracias!

fjarque

  • Moderador Global
  • *****
  • Mensajes: 1603
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Florencia Jarque
  • Sistema: SIU-Guaraní
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #11 : noviembre 04, 2020, 11:18:48 am »
Patricio,

Vos estás ejecutando el comando "composer install" como indica el paso 4 de la documentación? En la imagen vemos "php composer.phar install".
Descargué su rama 3.17.0 localmente y veo que tienen versionadas carpetas que no deberían: 'instalacion', 'metadatos_compilados', ' vendor'.
Sigamos por Gestor de Solicitudes porque es un caso particular de ustedes.

Saludos, Florencia.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #12 : noviembre 04, 2020, 11:30:25 am »
Te cuento como fue la implementacion , lo mas resumido posible.

Se realizaron modificaciones en el ambiente de PRODUCCION, mas que nada en archivos de PERSONALIZACION, pero se retocaron archivos en el ambiente PRODUCTIVO.
El motivo por el cual estoy instalando desde cero el ambiente de DESA es  porque quedó olvidado y se eliminó. O sea, no se siguio la linea que recomiendan de  generar los cambios en un ambiente de DESA, probar en PRE y luego pasarlo a PROD. TODO se hizo en PROD en este ultimo tiempo.

Volviendo al tema COMPOSER. Como estuve siguiendo la documentacion, instalé la version 2.0 de COMPOSER y fue en ese momento donde te comenté el problema que me generaba y me recomendaste bajar la version de composer.
La version de composer, la baje manualmente ( Descargue el archivo "composer.phar"  para poder usar X version , segun entiendo )

Me podrias indicar bajo que nombre o tema les genero el GDS ? Gracias.

plecolant

  • Newbie
  • *
  • Mensajes: 27
    • Ver Perfil
  • Institución: Universidad Favaloro
  • Nombre y apellido: Patricio Eugenio Lecolant
  • Sistema: sui guarani 3
  • Utilizo algun sistéma del SIU: Sí
Re:Instalacion CERO de server DESA siu guarani
« Respuesta #13 : noviembre 04, 2020, 11:50:47 am »
Florencia,

¿ Hay una forma mas sencilla de solucionar todo esto ? Me refiero a : es posible instalar la version  nueva de guarani 3.18.0 en DESA y traer de alguna forma las personalizaciones que estan actualmente en PRODUCCION ? Asi de esta forma tener la ultima version de Guarani junto con las modificaciones que se hicieron hasta la fecha en el ambiente de PROD.

Tal vez es una forma mas sencilla para ambos empezar desde cero. Esa version 3.17.0 paso por varias personas y no estoy seguro de su estado actual como para partir de cero con algo asi.

Gracias nuevamente.