Autor Tema: Problema Actualizar huarpe 2.1 a 2.2  (Leído 23 veces)

0 Usuarios y 1 Visitante están viendo este tema.

javierb

  • Jr. Member
  • **
  • Mensajes: 97
    • Ver Perfil
    • Email
  • Institución: UNR
  • Nombre y apellido: Javier Bonfanti
  • Sistema: Arai
  • Teléfono laboral: +54 341 - 4201200 int. 450
  • Utilizo algun sistéma del SIU: Sí
Problema Actualizar huarpe 2.1 a 2.2
« : noviembre 13, 2020, 11:09:01 am »
Hola! buen dia!
Queriendo actualziar huarpe de rama 2.1 a 2.2 nos encontramos con el siguiente problema:

PHP Fatal error:  Uncaught Error: Class 'SIU\MapucheBundle\SIUMapucheBundle' not found in /opt/huarpe-core/app/AppKernel.php:44
Stack trace:
#0 /opt/huarpe-core/app/AppKernel.php(28): AppKernel->addBundlesFromConf(Array)
#1 /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php(488): AppKernel->registerBundles()
#2 /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Component/HttpKernel/Kernel.php(132): Symfony\Component\HttpKernel\Kernel->initializeBundles()
#3 /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Bundle/FrameworkBundle/Console/Application.php(64): Symfony\Component\HttpKernel\Kernel->boot()
#4 /opt/huarpe-core/vendor/symfony/symfony/src/Symfony/Component/Console/Application.php(148): Symfony\Bundle\FrameworkBundle\Console\Application->doRun(Object(Symfony\Component\Console\Input\ArrayInput), Object(Symfony\Component\Console\Output\BufferedOutput))
#5 /opt/huarpe-core/src/CoreBundle/Instalador/Paso/Configurar.php(233): Symfony\Component\Console\Application->run(Object(Symfony\Compon in /opt/huarpe-core/app/AppKernel.php on line 44


Saben a que se debe?

Muchas gracias, saludos!
« Última Modificación: noviembre 13, 2020, 11:25:45 am por javierb »

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 694
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Problema Actualizar huarpe 2.1 a 2.2
« Respuesta #1 : noviembre 13, 2020, 12:01:55 pm »
Hola Javier,

El error es porque a partir de Huarpe 2.2 el bundle Mapuche esta separado de Huarpe en sí. Podes editar el archivo app/config/bundles.yml y eliminar la entrada ahi, para poder continuar con la actualización.

Luego de actualizar, podes realizar los pasos para agregar Huarpe (en la doc/bundles está los pasos).

En futura versión de Huarpe, vamos a mejorar esto nuevamente. Saludos!
happy coding!!

javierb

  • Jr. Member
  • **
  • Mensajes: 97
    • Ver Perfil
    • Email
  • Institución: UNR
  • Nombre y apellido: Javier Bonfanti
  • Sistema: Arai
  • Teléfono laboral: +54 341 - 4201200 int. 450
  • Utilizo algun sistéma del SIU: Sí
Re:Problema Actualizar huarpe 2.1 a 2.2
« Respuesta #2 : noviembre 13, 2020, 12:42:44 pm »
Gracias sergio!
Te consulto, desde que versión huarpe esta con php 7.3?

saludos!

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 694
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Problema Actualizar huarpe 2.1 a 2.2
« Respuesta #3 : noviembre 13, 2020, 12:54:58 pm »
Javier,

Huarpe 2.2 requiere PHP 7.1... y la próxima versión (futura 3.0) será compatible con PHP 7.3.
happy coding!!