Autor Tema: Dudas sobre las versiones requeridas de PHP y Postgres para Kolla 4.3.2 !!!  (Leído 38 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Mati.Barboza

  • Jr. Member
  • **
  • Mensajes: 63
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Alto Utuguay
  • Nombre y apellido: Matias Barboza
  • Sistema: Guaraní - Kolla
Buenos días, Feliz año nuevo a toda la comunidad !!!

Estamos  por migrar Kolla desde la versión 4.3.0 hacia 4.3.2 que es la última versión compatible con Guaraní  3.18.1.

Actualmente tenemos funcionando en producción  Kolla 4.3.0 corriendo en un mismo servidor junto a Guaraní 3.17.1 con las versiones PHP/Postgres que ésta última requiere:

Código: [Seleccionar]
PHP
versión 7.1.x
postgreSQL 9.6.x

El problema surge al momento de intentar migrar a la última versión de Kolla ya qué ésta pide una versión de  PHP:  7.1.x a 7.2.13 y para postgres: 10.x a 11

Mientras que para guaraní 3.18.1 necesitamos las versiones  de PHP : 7.3.x  y para postgres:  11.6.x .

Estos requerimientos de diferentes versiones para ambos sistemas nos traen un problema para hacer que ambos sistemas corran en la misma máquina. Se optó por instalar kolla utilizando las mismas versiones de PHP y postgres de Guaraní 3.18 pero nos marca un Error de versiones justamente para PHP y postgres:

Código: [Seleccionar]
errores de versiones
[ WARNING ] PHP: Versión esperada desde 7.1 hasta 7.2.13, versión instalada 7.2.34
[ WARNING ] POSTGRES: Versión esperada desde 10 hasta 11.3, versión instalada 11.9

Quisiera saber si hay alguna manera de Forzar  aque Kolla utilice las mismas  versiones php/postgres que usa guaraní o alguna otra solución que le podríamos dar al asunto. La idea es que ambos sistemas estén instalados en el mismo servidor.

Saludos !



Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 191
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla
Buenas tardes Matias.

Es correcto lo que decís y reconocemos desde nuestro lado esta limitación, pero la realidad es que no podemos asegurar el uso de dicha versión de Kolla con versiones distintas a las recomendadas, en especial PHP.

De manera que, no queda otra opción que corran en servidores separados cada uno con sus versiones correspondientes de PHP y Postgres, y a la brevedad vamos a estar liberando una nueva versión de Kolla que no tenga esta traba.

Saludos! Germán