Foro de la Comunidad SIU

ComDoc => Técnicos ComDoc => Mensaje iniciado por: Nicolas en Noviembre 11, 2009, 10:22:51 am

Título: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 11, 2009, 10:22:51 am
Hola, buenos dias:

Realizamos la instalación de ComDocIII, siguiendo las indicaciones del manual de instalación, pero al momento de ejecutarlo en el navegador muestra el error que se adjunta en la captura.

Espero puedan darnos una mano.

Muchas gracias

Nicolas Dovico
Admin ComDoc
Universidad Nacional de Luján
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Noviembre 11, 2009, 01:41:13 pm
Hola Nicolás,

Verificá el archivo jboss_init.sh: tenes que configurar el comdoc_dir de acuerdo con tu instalación

comdoc.dir=/usr/local/jboss/server/comdoc/

Cambialo en todos los lugares donde aparece en ese archivo. Revisá que ese y el JBOSS_HOME sean los correctos.
Reiniciá y fijate como se comporta.

Si te sigue dando error adjuntá el server.log y vemos que puede estar pasando.

Saludos,
Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 12, 2009, 09:49:40 am
Hola Eugenia, muchas gracias por responder!!!

Hice los cambios que me señalaste, pero me surgió una duda: el JBOSS_HOME donde debe apuntar??
a la carpeta donde esta el jboss, en mi caso /usr/local/jboss-4.2.2.GA o a alguna mas interna por ejemplo esta /usr/local/jboss-4.2.2.GA/server/comdoc??

Igualmente te adjunto el archivo de log, para ver si se puede saber algo mas.

Nuevamente muchas gracias

Nicolas
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Noviembre 12, 2009, 11:34:13 am
Hola Nicolás,

El JBOSS_HOME debe apuntar a: /usr/local/jboss-4.2.2.GA
En el log que me envias entre otras cosas dice que no encuentra el archivo:
/usr/local/jboss-4.2.2.GA/server/comdoc/conf/comdoc.properties

Verificá esto y lo de los path del jboss_init.sh y vemos que pasa. Volvé a adjuntar el server.log.

Saludos,
Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 12, 2009, 12:40:17 pm
Eugenia:

El JBOSS_HOME está apuntando hacia donde vos indicas.

Ahora, el archivo comdoc.properties no existía en ese directorio. Lo busque y estaba en otro. Lo copié desde este y lo pegué en el que vos indicas

Reinicié, probé nuevamente y mostro el mismo error.

Alguna otra idea?

Te adjunto el nuevo server.log

Gracias

Nicolas
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Noviembre 12, 2009, 01:08:34 pm
Nicolas,

Este es el error: org.postgresql.util.PSQLException: FATAL: no existe la base de datos.

Controlá la conexión con la base en el archivo comdoc-ds.xml y vemos.

Saludos,
Euge

Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 20, 2009, 10:02:34 am
Hola Eugenia:

Efectivamente había un error en la conexión a la BD. Ahora el error es otro, que es el que adjunto.

Adjunto tambien, por si es necesario el archivo server.xml (lo renombre a server.txt para poder adjuntarlo) que tengo en la ruta /usr/local/jboss-4.2.2.GA/server/comdoc/deploy/jboss-web.deployer (creo que puede ayudar).

Bueno, espero puedas darme una pista por donde seguir. Gracias
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Noviembre 23, 2009, 01:05:39 pm
Hola Nicolás,

Mandame el server.log para ver que dice, con esto que me mandas no alcanza para ver que puede estar pasando.

Saludos,
Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 23, 2009, 02:06:23 pm
ok Eugenia, disculpá, en este envio te lo adjunto. (está renombrado a serverlog.txt)

Nuevamente, muchas gracias

Nicolas
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Noviembre 24, 2009, 11:34:36 am
Hola Nicolás,

El error lo tira en : /usr/local/jboss/server/comdoc/deploy/jmx-console/WEB-INF/web.xml
Cambiaste algo ahí?
Reemplaza al carpeta completa jmx_console por la del server/default/
No entiendo cual es el problema, probemos con eso.
Saludos,
Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Noviembre 25, 2009, 02:35:56 pm
Hola Eugenia, probé con lo que me indicaste y avanzamos otro paso. Ahora muestra la pantalla que adjunto. También te mando el server.log (renombrado a serverlog.txt) para ver como podemos seguir.

Nuevamente muchas gracias!!!

Nicolas
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Diciembre 02, 2009, 01:28:04 pm
Hola Nico,

Te faltan copiar algunos archivos, estan en la carpeta custom. Creá esta carpeta en ../server/comdoc/ y probá de ingresar nuevamente.
Saludos,

Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Nicolas en Diciembre 03, 2009, 10:02:17 am
Listo Eugenia!!!!!

Recién pude ingresar y aparentemente está todo bien.

Te agradezco un monton la ayuda brindada

Un beso

Nicolás
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Diciembre 03, 2009, 10:50:21 am
Buenisimo Nico!
Saludos,
Eugenia
Título: Re: Error HTTP Status 500
Publicado por: Carolina Belmonte en Febrero 05, 2010, 07:42:10 am
Estimados, estaba viendo la guia que se corresponde con este error ya que tengo el mismo problema. Pero queria saber que datos tengo que editar en el archivos comdoc-ds.xml, asi pruebo si sigue dando el error. El usuario y la pass tiene que ser los del comdoc o los de postgres??????

Saludos
Carolina
Título: Re: Error HTTP Status 500
Publicado por: Eugenia Calvo en Febrero 05, 2010, 11:57:40 am
Caro,

en el archivo comdoc-ds.xml tenes que configurar la conexión con la base postgres. Usuario y clave de la base  y el servidor donde está la base.

Saludos,
Eugenia