Foro de la Comunidad SIU

SIU-Arai => Araí - Instalación => Mensaje iniciado por: estebanv en Octubre 29, 2020, 01:31:56 pm

Título: Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: estebanv en Octubre 29, 2020, 01:31:56 pm
Buenas!

Estamos integrando las 2 aplicaciones a nuestra instalación de Arai. Seguimos los pasos del instructivo en https://expedientes.siu.edu.ar/docs/pilaga/ (https://expedientes.siu.edu.ar/docs/pilaga/), verificamos que los archivos de instancia y el de saml:onelogin esten bien, pero nos aparece la pantalla: Ocurrio un error.
En los logs del IPD tengo la siguiente leyenda:
Código: [Seleccionar]
[Thu Oct 29 13:10:45.117433 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] SimpleSAML\\Error\\MetadataNotFound: METADATANOTFOUND('%' => '\\'http://localhost/pilaga_portal/default-sp\\'')
[Thu Oct 29 13:10:45.117495 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] Backtrace:
[Thu Oct 29 13:10:45.117515 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 3 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:340 (SimpleSAML\\Metadata\\MetaDataStorageHandler::getMetaData)
[Thu Oct 29 13:10:45.117532 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 2 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:360 (SimpleSAML\\Metadata\\MetaDataStorageHandler::getMetaDataConfig)
[Thu Oct 29 13:10:45.117548 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 1 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/modules/saml/lib/IdP/SAML2.php:380 (SimpleSAML\\Module\\saml\\IdP\\SAML2::receiveAuthnRequest)
[Thu Oct 29 13:10:45.117565 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 0 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/www/saml2/idp/SSOService.php:21 (N/A)
[Thu Oct 29 13:10:45.117614 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] Error report with id 3a90b9c3 generated.
10.0.3.23 - - [29/Oct/2020:13:10:45 -0300] "GET /idp/saml2/idp/SSOService.php?SAMLRequest=hVNdb9owFH3nV6C8Qz4GlFqQKYN9IDGISLqHvVS3zqVEcmzPHyv993PidGVVxfzi6Pqe43OObxYaGiZJZs2JH%2FCXRW0GQ7fODeOadIfLwCpOBOhaEw4NamIoKbLvW5KMIyKVMIIKFryBXUeB1qhMLbiHbdbLYL%2F7vN1%2F3ezuj0kC83kyo5MJhWmMH25uZtVDNKmSGG6PFY3oFLEC6qE%2FUGnHswwcbTDwbFpb3HBtgBtXj5JoFEej5LaMZySek2ny00PXzmzNwXTwkzFSkzCUQhlgY8uZHWNlx6DCupJhaynpvopiX6D6XVMcy5P0THkfwqeaVzV%2FvO79wTdp8q0s81G%2BL0pPkr1kshJc2wZVf83dYevlOXVMUGAnoU0oawaPcO%2Flhh%2BB6iDtaBatVNJloNL%2FwCo8gmVmpOUivIS9EkmycwY261ywmj539XZ9EaoBF25PcOeUZ5QKy03wtydjTDytFILBZWCUxWAY%2FsPczxtW3fQ51wbPZrgSjQRV6%2FZR8AzU9L5evV22r5gbpQMe06vTRglt%2B1w5d9uTUFX7Ykjd3aUCrts4%2BgTeJfeqwyuy08HL8eWvlP4B&RelayState=https%3A%2F%2Fpruebaspilaga.unlu.edu.ar%2Fpilaga_portal%2F HTTP/1.1" 302 772
 

Me imagino que el problema es;  ERR [27bbda7e1e] SimpleSAML\\Error\\MetadataNotFound: METADATANOTFOUND('%' => '\\'http://localhost/pilaga_portal/default-sp\\'')
El tema es que no tengo esa URL así en ningún lado. Hay alguna forma de debuggear mejor?
Gracias.
Título: Re:Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: Sergio F. Vier en Octubre 29, 2020, 05:52:39 pm
Hola Esteban,

Tenemos documentado en forma básica casos habituales de inconvenientes acá (https://documentacion.siu.edu.ar/usuarios/docs/cache/guia-solucion-de-problemas/#errores-simplesamlphp).

En tu caso, http://localhost/pilaga_portal/default-sp no se corresponde con ningún valor que esté asignado al campo "entityID" de un "conector SAML"  de alguna aplicación. Es lo que en expedientes, los chicos de Pilagá lo documentaron en el paso 5 (https://expedientes.siu.edu.ar/docs/pilaga/#registrar-siu-pilag%C3%A1-como-service-provider-en-ara%C3%AD-usuarios) (Entity Id).

Saludos!
Título: Re:Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: estebanv en Octubre 29, 2020, 07:53:05 pm
Hola Sergio,
Como te comentaba en el primer post, seguí la guía al pie de la letra, la pestaña de configuración de SAML de la aplicación dada de alta muestra lo siguiente:

Código: [Seleccionar]
{
   "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/default-sp": {
      "AssertionConsumerService": "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/?acs",
      "SingleLogoutService": "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/?sls"
   }
}

Esa aplicación la cree y borre varias veces de hecho, con el mismo resultado. Otra prueba que hice fue la de borrarla y no cargarla y el error sigue siendo el mismo, puede ser que sea algo mal configurado en el SP? Cuando se instalo por primera vez estaba mal configurado el parametro full_url y encontre el mismo string (http://localhost/pilaga_portal/) en algunos logs locales de pilaga que no estaban relacionados directamente, pero fueron los únicos que encontré. Cambie el parametro full_url que esta en el instancia.ini, pero sigue siendo lo mismo.
Avisame si necesitas que te suba algo.
Gracias.
Título: Re:Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: estebanv en Octubre 30, 2020, 04:30:08 pm
El problema era el atributo full_url al final.  Claramente los sp's toba están armando los endpoints para saml usando esa url. Cambiando eso junto con limpieza de caches y demás, salio todo andando. Quizás estaría bueno aclararlo en la [url]documentación de integración con pilaga[https://expedientes.siu.edu.ar/docs/pilaga/]. Otra cosa que vi es que se indica que el nombre de la aplicación, a la hora de registrarla como SP sea 'pilaga' y el comando exportación de cuentas de usuario de una instalación standart de pilaga esta usando 'SIU-Pilagá'. Si se quiere importar cuentas así, nunca matchean.
Saludos.
Título: Re:Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: richard en Noviembre 02, 2020, 10:41:39 am
Hola Esteban,
El problema era el atributo full_url al final.  Claramente los sp's toba están armando los endpoints para saml usando esa url.

consulta.. la instalacion de Pilaga que mencionas estaba en docker o era manual?. Y si, efectivamente Toba utiliza el parametro full_url como prioritario para enviar al IDP... sobre todo porque la aplicacion puede estar corriendo detras de un proxy y no siempre se puede determinar correctamente la url via Apache.

Gracias por el feedback, ya le avise a la gente de Pilaga para que vea lo que nos comentas

Saludos
Título: Re:Integración con Pilaga y Mapuche - Ocurrio un error
Publicado por: estebanv en Noviembre 02, 2020, 01:14:09 pm
Hola Esteban,
El problema era el atributo full_url al final.  Claramente los sp's toba están armando los endpoints para saml usando esa url.

consulta.. la instalacion de Pilaga que mencionas estaba en docker o era manual?.





Instalación  manual Richard.
Abrazo