Foro de la Comunidad SIU

SIU-Tehuelche => SIU-Tehuelche - Técnicos => Mensaje iniciado por: amoron en Mayo 03, 2022, 01:45:48 pm

Título: Error en composer Tehuelche 4.3.0
Publicado por: amoron en Mayo 03, 2022, 01:45:48 pm
Hola

Estoy instalando por primera vez Tehuelche 4.3.0 en una Maq. Virt. con Windows 10. Todo recién instalado fresco.

Y cuando escribo el comando 'composer install', me da luego de instalar muchas dependencias, el siguiente error casi al finalizar: 

Package container-interop/container-interop is abandoned, you should avoid using it. Use psr/container instead.
Package dapphp/securimage is abandoned, you should avoid using it. No replacement was suggested.
Package siu-toba/jasper is abandoned, you should avoid using it. No replacement was suggested.

Tengo estas versiones:

* Windwos 10 - 64 bit
* Apache 2.4.48 (Win 64)
* PHP 7.4.23
* PostgreSQL 13.6
* Git 2.36.0 64 bit 
* Composer 2.3.5   
* Yarn 1.22.4
* Node 18.1.0

Adjunto archivo con imagen con más info en el contexto que se genera el error.
Otra inquietud. Abro el pgAdmin y solo veo la DB 'postgres', no veo la DB Toba. Pregunto: Esta no se crea también al ejecutar 'composer install' ?

Gracias !
Título: Re:Error en composer Tehuelche 4.3.0
Publicado por: Rodrigo Miranda [SIU] en Mayo 03, 2022, 01:57:46 pm
Hola Alejandro, el mensaje de composer es un simple warning que te avisa que hay librerías que no las está manteniendo nadie. Es solo un aviso.

El comando composer install solamente te va a descargar y actualizar las librerías que necesita toba para funcionar, pero no te instala el framework. Para instalarlo tenés que seguir la guía de instalación https://github.com/SIU-Toba/framework
Título: Re:Error en composer Tehuelche 4.3.0
Publicado por: Rodrigo Miranda [SIU] en Mayo 04, 2022, 10:30:37 am
Alejandro, te mandé a la docu de instalación de Toba por error. La documentación correcta para saber como instalar Tehuelche es la siguiente https://documentacion.siu.edu.ar/wiki/SIU-Tehuelche/version_4.3/instalacion