Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - agus

Páginas: [1] 2 3 4
1
Buen día!
Se me presenta la siguiente situación:
En una operación, luego de ejecutar un evento, necesito mostrarle un mensaje al usuario con el resultado del proceso, e inmediatamente después desloguear al usuario y redirigirlo a la página de inicio del proyecto.
En el evento, luego de realizar el proceso hago lo siguiente:

toba::notificacion()->agregar("Mensaje con resultado del proceso.",'info');
toba::vinculador()->navegar_a('nombre_proyecto','2');
toba::manejador_sesiones()->logout();   


Donde 2 es el número de operación de la página de inicio del proyecto.
El mensaje se muestra pero no se llega a leer porque inmediatamente se produce el deslogueo.
¿Hay alguna forma en que pueda solucionarlo?
Estoy usando toba 3.3
Muchas gracias!
Agustina



2
Técnicos Mapuche / Re:ERROR el usuario ya tiene un proceso en ejecución
« on: Diciembre 17, 2020, 01:43:11 pm »
Perfecto!
Ahora sí. Con el
Código: [Seleccionar]
TRUNCATE mapuche.par_solicitud cascade; se limpiaron las tablas y el servicio de liquidación volvió a funcionar.
Esto nos pasó en una prueba. Si llegara a sucedernos algo similar en producción podemos hacer el truncate sin perder información relevante?
Gracias!
Agustina

3
Técnicos Mapuche / Re:ERROR el usuario ya tiene un proceso en ejecución
« on: Diciembre 16, 2020, 11:28:30 am »
Hola Mariela!
Si, acá va el error:
Código: [Seleccionar]
[Wed Dec 16 10:26:52.574091 2020] [php7:notice] [pid 652] [client 10.0.2.99:53736] excepcion_par_proceso: ERROR el usuario ya tiene un proceso en ejecuci\xf3n\n[TRAZA]\n\t\n\tpar_planificador->control_concurrencia \nArchivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_planificador.php, lInea 285 \nParametros: \nagustina\t\t\n\t\n\tpar_planificador->nuevo_proceso \nArchivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_planificador.php, lInea 21 \nParametros: \n242\t\t\n\t\t\n\t\t\n\t\n\tpar_planificador::crear_proceso \nArchivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_solicitud.php, lInea 101 \nParametros: \n242\t\t\n\t\n\tpar_solicitud->lanzar_proceso \nArchivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/servicios/proceso_liquidacion/ci_proceso_liquidacion.php, lInea 437 \n\t\n\tci_proceso_liquidacion->evt__liquidar \nArchivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/componentes/interface/toba_ci.php, lInea 282 \nParametros: \nundefined\t\t\n\t\n\ttoba_ci->disparar_evento_prop...SIGUE..., referer: https://xxxxxx/siu5/mapuche/aplicacion.php?ah=st5fda0ad632d198.59800082&ai=mapuche%7C%7C70000002

4
Técnicos Mapuche / Re:ERROR el usuario ya tiene un proceso en ejecución
« on: Diciembre 16, 2020, 10:34:46 am »
Hola!
Puse los permisos correctamente y el error persiste.
En la carpeta instalacion/logs_comandos/  solamente se encuentra el archivo comandos.log y  no está logueando nada  ahi por este error.
Solo se registra en instalacion/i__produccion/p__mapuche/logs/sistema.log

Código: [Seleccionar]
-o-o-o-o-o-
Fecha: 16-12-2020 10:26:52
Operacion: Liquidaci▒n
Usuario: agustina
Version-PHP: 7.3.19-1~deb10u1
Servidor: XXXXX
URI: /siu5/mapuche/aplicacion.php?ah=st5fda0ad97275c1.42884085&ai=mapuche%7C%7C70000002
Referrer: https://mapuche-pruebas/siu5/mapuche/aplicacion.php?ah=st5fda0ad632d198.59800082&ai=mapuche%7C%7C70000002
Host: xxxxxxx
==========
[DEBUG][mapuche] PUNTO DE MONTAJE: se carg▒ exitosamente el autoload del punto de montaje proyecto
[INFO][mapuche] PUNTO MONTAJE: se carg▒ la clase extension_toba/mapuche_sesion.php del punto de montaje proyec                               to. El path del mismo es /home/usumapuche/www/mapuche5/mapuche_3121/php
[DEBUG][mapuche] Inicializando perfil de datos para el proyecto mapuche
[INFO][mapuche] PUNTO MONTAJE: se carg▒ la clase comunes/mapuche_fuente_datos.php del punto de montaje proyect                               o. El path del mismo es /home/usumapuche/www/mapuche5/mapuche_3121/php
[DEBUG][toba] [SECCION] Iniciando componentes...
[INFO][mapuche] PUNTO MONTAJE: se carg▒ la clase servicios/proceso_liquidacion/ci_proceso_liquidacion.php del                                punto de montaje proyecto. El path del mismo es /home/usumapuche/www/mapuche5/mapuche_3121/php
[DEBUG][toba] componente(70000001): Pantalla de eventos: 'pant_seleccion'
[DEBUG][toba] [SECCION] Procesando eventos...
[DEBUG][toba] componente(70000001): [ inicializar_dependencias ]
array (
  0 => 'filtro_seleccion',
  1 => 'cuadro_seleccion',
)
[INFO][mapuche] PUNTO MONTAJE: se carg▒ la clase comunes/mapuche_ei_filtro.php del punto de montaje proyecto.                                El path del mismo es /home/usumapuche/www/mapuche5/mapuche_3121/php
[INFO][mapuche] PUNTO MONTAJE: se carg▒ la clase servicios/proceso_liquidacion/cuadro_proceso_liquidacion.php                                del punto de montaje proyecto. El path del mismo es /home/usumapuche/www/mapuche5/mapuche_3121/php
[DEBUG][toba] componente(70000001): [ evento ] 'liquidar' -> [ evt__liquidar ]
[DEBUG][toba] ************ ABRIR transaccion (prueba_mapuche5@127.0.0.1) ****************
[DEBUG][toba] ************ CERRAR transaccion (prueba_mapuche5@127.0.0.1) ****************
[CRITICAL][toba] excepcion_par_proceso: ERROR el usuario ya tiene un proceso en ejecuci▒n
[TRAZA]

        par_planificador->control_concurrencia
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_planificador.php, l                               Inea 285
Parametros:
agustina

        par_planificador->nuevo_proceso
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_planificador.php, l                               Inea 21
Parametros:
242



        par_planificador::crear_proceso
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/modelos/procesos/paralelizador/par_solicitud.php, lIne                               a 101
Parametros:
242

        par_solicitud->lanzar_proceso
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/php/servicios/proceso_liquidacion/ci_proceso_liquidacion.p                               hp, lInea 437

        ci_proceso_liquidacion->evt__liquidar
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/componentes/interface                               /toba_ci.php, lInea 282
Parametros:
undefined

        toba_ci->disparar_evento_propio
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/componentes/interface                               /toba_ci.php, lInea 204

        toba_ci->disparar_eventos
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/toba_solicitud_web.ph                               p, lInea 135

        toba_solicitud_web->procesar_eventos
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/toba_solicitud_web.ph                               p, lInea 55

        toba_solicitud_web->procesar
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/vendor/siu-toba/framework/php/nucleo/toba_nucleo.php, lIne                               a 96

        toba_nucleo->acceso_web
Archivo: /home/usumapuche/www/mapuche5/mapuche_3121/www/aplicacion.php, lInea 24

5
Técnicos Mapuche / Re:ERROR el usuario ya tiene un proceso en ejecución
« on: Diciembre 10, 2020, 11:54:01 am »
Buenas!
Tuvimos el mismo problema con el liquidador web  de la versión 3.12.1 de Mapuche.
Borramos los registros de la tabla par_proceso del usuario en cuestión.
Al intentar volver a liquidar, el proceso nunca termina.
Los nuevos registros que se crean en esa tabla no tienen número pid, y su estado queda en 0.
¿Cómo podemos solucionarlo?
Gracias!
 

6
SIU - Huarpe / Re:Bundles SIU - Acceso al código y manuales de instalación
« on: Noviembre 09, 2020, 03:53:56 pm »
Ok!
Terminó funcionando poniendo de los dos lados (en Mapuche como servidor y en Huarpe como cliente) el tipo de autenticación basic .
Gracias!

7
SIU - Huarpe / Re:Bundles SIU - Acceso al código y manuales de instalación
« on: Noviembre 06, 2020, 12:30:35 pm »
Hola!
Estoy trabajando con Esteban en la UNLu .
Ya logramos ver en el menú de Huarpe las opciones del  bundle de Recursos Humanos, pero para poder navegarlas nos falta poder decirle a Huarpe  cuáles son los parámetros para consumir la API REST de Mapuche (URL, usuario y contraseña).
En Mapuche ya creamos el usuario para Huarpe, en el archivo instalacion/i__mapuche/rest/ servidor_usuarios.ini
¿Cómo/dónde cargamos esta información del lado de Huarpe?
Les recordamos que tenemos  la versión 2.2.6 de Huarpe desplegada con docker.
En este momento al navegar las opciones de recursos humanos de huarpe obtenemos el error  "cURL error 6: Could not resolve host: url." Claramente nos falta decirle a Huarpe la URL de la API de Mapuche. Además del usuario y contraseña.
Preguntamos al equipo Mapuche via GDS pero no tienen información al respecto.
Saludos,
Agustina

 

8
Técnicos Mapuche / Re:Nueva Versión SIU-Mapuche 3.12.0
« on: Octubre 20, 2020, 10:37:09 am »
Hola Nico!
No habíamos hecho lo que decís. Ahora  que lo hicimos se actualizó  correctamente, migrando los usuarios y perfiles.
Muchas gracias!
Agustina

9
Técnicos Mapuche / Re:Nueva Versión SIU-Mapuche 3.12.0
« on: Octubre 16, 2020, 11:04:52 am »
Buenas!
Luego de actualizar Mapuche desde la versión 3.10.1 a  la  3.12.0  siguiendo los pasos recomendados, la tabla usuarios quedó vacía.
En el archivo  'SIU-Mapuche/instalacion/i__produccion/instancia.ini' tenemos configurado el parámetro 'usar_perfiles_propios = "1"' .
Qué puede estar pasando?
Gracias!
Agustina

10
Técnicos Mapuche / Re:Nueva Versión SIU-Mapuche 3.12.0
« on: Septiembre 23, 2020, 11:10:19 am »
Buenas!
Nosotros tenemos Mapuche 3.10.1 y queremos migrar a esta versión.
Tenemos un nuevo servidor con las versiones de  php y postgres requeridas.
Intentamos  crear una instalación 3.10 con un backup de producción para luego migrar a  la 3.12
Pero no logramos realizar la instalación de la 3.10 por incompatibilidad de las versiones .
Cuáles serian los pasos correctos que deberíamos seguir?
Gracias!

11
Araí - Instalación / Re:Problemas para navegar Arai-Usuarios
« on: Septiembre 04, 2020, 03:46:21 pm »
Para poder navegar arai-usuarios además tuvimos que modificar los certificados que configuramos como secretos.
Nosotros estamos usando certificados autofirmados.
Nos da error el navegador cuando el archivo .key contiene clave.
Tuvimos que sacarla con el siguiente comando  (le pasamos el nombre del archivo_con_clave.key  y  el nombre que le queremos poner al nuevo archivo, sin clave)
openssl rsa -in archivo_con_clave.key -out archivo_sin_clave.key

-Bajamos el stack de usuarios
-Eliminamos los secretos que teniamos cargados y cargamos los nuevos.
-Volvimos a desplegar el stack.

Con eso llegamos a la página de logueo de arai usuarios.

12
Araí - Instalación / Re:Problemas para navegar Arai-Usuarios
« on: Septiembre 04, 2020, 03:31:29 pm »
Logramos encontrar cuál era el problema.
Para hacer el mapeo de puertos, 8080->80  y  8443->443 , en el archivo  traefik.yml    habíamos modificado  no solo las líneas en ports, sino también las siguientes líneas dentro de profiling:
       - --entrypoints.web.address=:8080
       - --entrypoints.web-secured.address=:8443

Esto falla.
Para que funcione, solo hay que modificar
     ports:
       - "8080:80"
       - "8443:443"

y dejar
       - --entrypoints.web.address=:80
       - --entrypoints.web-secured.address=:443



Con esto ya pudimos navegar el dashboard de traefik


13
Araí - Instalación / Re:Problemas para navegar Arai-Usuarios
« on: Agosto 31, 2020, 02:49:08 pm »
Hola!
El log de traefik no registra nada sobre mi intento de acceso. A nivel info y debug  me muestra lo siguiente:

time="2020-08-31T17:38:59Z" level=debug msg="Filtering disabled container" providerName=docker container=usuarios-api-nk0jcnlz3otjr7qekec9ic40w
time="2020-08-31T17:38:59Z" level=debug msg="Filtering disabled container" container=usuarios-memcached-server-04n6fy7nzb6ogtkgdwmignehp providerName=docker
time="2020-08-31T17:38:59Z" level=debug msg="Configuration received from provider docker: {\"http\":{\"routers\":{\"api\":{\"middlewares\":[\"auth\"],\"service\":\"api@internal\",\"rule\":\"Host(`traefik.portal-p.unlu.edu.ar`)\"},\"http-catchall\":{\"entryPoints\":[\"web\"],\"middlewares\":[\"redirect-to-https@docker\"],\"service\":\"dummy-svc\",\"rule\":\"host(`portal-p.unlu.edu.ar`)\"},\"idp\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"idp\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/idp`)\",\"tls\":{}},\"idp-resources\":{\"entryPoints\":[\"web-secured\"],\"service\":\"idp-resources\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/resources`)\",\"tls\":{}},\"usuarios\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"usuarios\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/usuarios`)\",\"tls\":{}},\"usuarios_toba\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"usuarios_toba\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/toba_gestion`)\",\"tls\":{}}},\"services\":{\"dummy-svc\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.28:9999\"}],\"passHostHeader\":true}},\"idp\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.7:80\"}],\"passHostHeader\":true}},\"idp-resources\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.7:80\"}],\"passHostHeader\":true}},\"usuarios\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.5:80\"}],\"passHostHeader\":true}},\"usuarios_toba\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.5:80\"}],\"passHostHeader\":true}}},\"middlewares\":{\"auth\":{\"basicAuth\":{\"users\":[\"traefik:$apr1$lHenvbg3$tctoF8Q6Iq0HtVmRLqc3S.\"]}},\"redirect-to-https\":{\"redirectScheme\":{\"scheme\":\"https\"}}}},\"tcp\":{},\"udp\":{}}" providerName=docker
time="2020-08-31T17:38:59Z" level=info msg="Skipping same configuration" providerName=docker
time="2020-08-31T17:39:14Z" level=debug msg="Filtering disabled container" providerName=docker container=usuarios-api-nk0jcnlz3otjr7qekec9ic40w
time="2020-08-31T17:39:14Z" level=debug msg="Filtering disabled container" providerName=docker container=usuarios-memcached-server-04n6fy7nzb6ogtkgdwmignehp
time="2020-08-31T17:39:14Z" level=debug msg="Configuration received from provider docker: {\"http\":{\"routers\":{\"api\":{\"middlewares\":[\"auth\"],\"service\":\"api@internal\",\"rule\":\"Host(`traefik.portal-p.unlu.edu.ar`)\"},\"http-catchall\":{\"entryPoints\":[\"web\"],\"middlewares\":[\"redirect-to-https@docker\"],\"service\":\"dummy-svc\",\"rule\":\"host(`portal-p.unlu.edu.ar`)\"},\"idp\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"idp\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/idp`)\",\"tls\":{}},\"idp-resources\":{\"entryPoints\":[\"web-secured\"],\"service\":\"idp-resources\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/resources`)\",\"tls\":{}},\"usuarios\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"usuarios\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/usuarios`)\",\"tls\":{}},\"usuarios_toba\":{\"entryPoints\":[\"web-secured\"],\"middlewares\":[\"security-headers@file\"],\"service\":\"usuarios_toba\",\"rule\":\"Host(`portal-p.unlu.edu.ar`) \\u0026\\u0026 PathPrefix(`/toba_gestion`)\",\"tls\":{}}},\"services\":{\"dummy-svc\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.28:9999\"}],\"passHostHeader\":true}},\"idp\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.7:80\"}],\"passHostHeader\":true}},\"idp-resources\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.7:80\"}],\"passHostHeader\":true}},\"usuarios\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.5:80\"}],\"passHostHeader\":true}},\"usuarios_toba\":{\"loadBalancer\":{\"servers\":[{\"url\":\"http://10.0.1.5:80\"}],\"passHostHeader\":true}}},\"middlewares\":{\"auth\":{\"basicAuth\":{\"users\":[\"traefik:$apr1$lHenvbg3$tctoF8Q6Iq0HtVmRLqc3S.\"]}},\"redirect-to-https\":{\"redirectScheme\":{\"scheme\":\"https\"}}}},\"tcp\":{},\"udp\":{}}" providerName=docker
time="2020-08-31T17:39:14Z" level=info msg="Skipping same configuration" providerName=docker

14
Araí - Instalación / Re:Problemas para navegar Arai-Usuarios
« on: Agosto 24, 2020, 02:07:49 pm »
Tenemos habilitado el dashboard de traefik, pero no puedo navegarlo tampoco. 
Usamos certificados que generamos y firmamos con easy-rsa (https://github.com/OpenVPN/easy-rsa).

Van los logs de los contenedores de usuarios

Código: [Seleccionar]
IDP
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.23. Set the 'ServerName' directive globally to suppress this message
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.23. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 20 14:14:28.605070 2020] [mpm_prefork:notice] [pid 8] AH00163: Apache/2.4.43 (Unix) PHP/7.3.14 configured -- resuming normal operations
[Thu Aug 20 14:14:28.605392 2020] [core:notice] [pid 8] AH00094: Command line: 'httpd -D FOREGROUND'


API
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.25. Set the 'ServerName' directive globally to suppress this message
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.25. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 20 14:14:08.226512 2020] [mpm_prefork:notice] [pid 8] AH00163: Apache/2.4.43 (Unix) PHP/7.3.14 configured -- resuming normal operations
[Thu Aug 20 14:14:08.226563 2020] [core:notice] [pid 8] AH00094: Command line: 'httpd -D FOREGROUND'

IDM
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.20. Set the 'ServerName' directive globally to suppress this message
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using 10.0.2.20. Set the 'ServerName' directive globally to suppress this message
[Thu Aug 20 14:13:50.915291 2020] [mpm_prefork:notice] [pid 7] AH00163: Apache/2.4.43 (Unix) PHP/7.3.14 configured -- resuming normal operations
[Thu Aug 20 14:13:50.917163 2020] [core:notice] [pid 7] AH00094: Command line: 'httpd -D FOREGROUND'


15
Buenas!
Tenemos levantado el stack de traefik y de arai usuarios.
No podemos navegar el proyecto.
Descartamos que sea un problema de firewall.
No encontramos ningún error en los logs de los contenedores.
¿Qué podemos mirar para saber qué está fallando?
Gracias!
Agustina

Páginas: [1] 2 3 4