Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - mmunoz

Páginas: [1] 2 3 ... 11
1
Buenos días Emiliano:
                                     Muchas gracias por el link. Te comento que mirando la documentación de araí usuarios desde expediente electrónico integrado llegué a esa documentación de las apis de las aplicaciones del Siu. Está muy buena ya que guía bastante de como consultar los métodos que tiene codificada cada aplicación.
                                     Pudimos consultar el método usuarios y luego para cada uno consultar el atributo extra de número de legajo.

Saludos,
Marcelo.

2
Buenos días Sergio:
                                 Muchas gracias por la respuesta. Pude sacar los datos que necesitaba con Apache Directory Studio. Después se me fueron agregando unos campos que me servirían para filtrar mejor como el Bloqueado, para acortar la búsqueda y el uniqueidentifyer. Asique por ese lado estaría solucionado.
       
Cita
Si fuera por automatizar, también tienen disponible la API de arai-usuarios con muchos de los campos accesibles.

                                 Intenté consultar la api de araí usuarios desde una aplicación que tenemos conectada al ecosistema, pero sin tener éxito. Miré las operaciones existentes en el código de toba-usuarios y lo traté de adaptar para que se conecte a la api pero no encontró el método...Tampoco pude entrar a la documentación de la api...por ahí es algo que nos faltó configurar.

                                 Estaría buenísimo si se pudiera avanzar con esto ó que araí usuarios incluya algunos campos en el listado... :-)

Saludos,
Marcelo.

3

Buenas tardes:
Nuestra consulta tiene que ver con el tema planteado en el foro https://foro.comunidad.siu.edu.ar/index.php?topic=23238.0. Por ahí no puntualmente con que no nos haya exportado Guaraní alguna cuenta.
Lo que si pasó en una prueba que hicimos de importación en instancia de prueba es que los mails que tenía registrado en guaraní no coincidían en su totalidad con los que estaban cargados en araí usuarios. Al importarlos generó cuentas nuevas de aquellos cuyos mails no encontró en el proceso de importación.
Suponemos que depurando el archivo .json que se obtiene de Guaraní e igualando las cuentas para cada usuario debería no duplicar usuarios y generar la cuenta del guaraní gestión o autogestión según corresponda.
La cuestión es que tenemos que filtrar los legajos y los mails que tiene registrado araí usuarios. Como en base de datos no tiene esa información. Supusimos que se podía obtener desde el backup que se le puede hacer a ldap y de allí con por ejemplo comando egrep que nos obtenga el número de empleado y el mail. Hasta nuestra prueba en testing anduvo bien ese razonamiento porque en la estructura del .ldiff aparecía primero el número de empleado y en una entrada posterior el mail.
En producción lo anterior se repite hasta un cierto digamos número de registro, donde comienza a tener primero el mail y luego el número de empleado.

Ahora viene la pregunta, como podemos hacer para obtener el número de legajo y el mail (si se pudiera el dni también) actual que tenemos registrado en araí usuarios?

Desde ya muchas gracias por la atención.

Saludos,

Marcelo.

4
SUDOCU - Técnicos / Recomendaciones de backup - Nuxeo
« on: Octubre 29, 2021, 03:58:30 pm »
Buenas tardes:
                         Les comento que estaríamos necesitando recomendaciones para realizar backups del repositorio Nuxeo.
                         Basta con hacer backup de la base de datos del sistema o hay que hacer alguna copia adicional, por ejemplo archivos?
Desde ya muchas gracias por su atención.

Saludos,

Marcelo.

5
Técnicos Mapuche / Re:Problemas con saml al Instalar en Produccion 3.14
« on: Octubre 29, 2021, 03:45:01 pm »
Buenas tardes:
                        Por lo que se entiende ustedes tenían trabajando a Mapuche versión 11 con SAML. Si esto es así contra que idp se está logueando? los archivos de crt y key los tienen que obtener desde la instalación del idp si el idp es la versión de expediente digital integrado versión dockerizada (es la que usamos nosotros).
                        Si el idp está en la otra versión versión si mal no recuerdo había que métodos en araí que se tenían que ejecutar para que se actualice la sincronización de aplicaciones.

Saludos,
Marcelo.

6
SUDOCU - Técnicos / Re:Conexion SSL con NUXEO
« on: Julio 01, 2021, 01:39:50 pm »
Hola Diego:

                          Teníamos algo parecido a lo de ustedes en nuestra institución UNPSJB. El certificado que tienen es de sectigo. En nuestro caso dos archivos el .crt (wild  card) uno intermedio y nos tuvieron que pasar uno más porque el de la CA raiz si estaba vencido.

                           Juntamos (concatenamos) los tres archivos en uno solo y eso nos sirvió para que por ejemplo el firmador no diera error para firmar un documento.  Quizás sea este su caso, nuxeo no estaría enviando toda la cadena de certificados.

                           Por el tema del vencimiento del CA raiz tuvimos también que agregarlo al ca-certificates (hacer que el servidor confíe en ese certificado) del servidor que tiene que hacer la comprobación. Eso nos posibilitó hacer que funcionen los bundles de mapuche, descargar recibos de sueldo etc. por ejemplo.

Saludos,
Marcelo.

7
SUDOCU - Técnicos / Re:Firma con FIRMAR
« on: Junio 25, 2021, 02:11:34 pm »
Hola Diego:

                         Rectifico un poco lo que te había contestado por mail.

                         En la UNPSJB teníamos funcionando lo de autorizaciones tanto en testing como en producción en la versión 1.1.0 de EEI.

                         Con la actualización a la versión 1.1.1 de EEI nos está apareciendo el mismo error que mencionás en la autorización. Si se ha podido firmar desde sudocu con la aplicación Siu-Firmador.

                         
Cita
En definitiva, dos preguntas: ¿Cómo configurar en sudocu para que utilice FirmAR? y ¿Alguna idea que puede ser el error que tengo al firmar desde SIU-Huarpe?

                          Hasta donde nosotros pudimos probar tanto en producción como en testing Sudocu firma a través del Siu-Firmador no a través de FirmAr.

                          A través de la bandeja de documentos de  Huarpe si se podía acceder a FirmAR con la imagen 2.2.8 de huarpe.

                          En testing lo que probamos como parche provisorio es modificar el archivo huarpe.yml en la linea de la imagen a 2.2.8  (re-deploy) y volvió a andar lo de autorizaciones.

                          En config-api-server.json tenemos

                                      "api": "https://la-url-de-la-solucion/docs/rest/backend",
                                      "api_front": "https://la-url-de-la-solucion/docs/rest/frontend"

Saludos,
Marcelo.



Saludos,
Marcelo.

8
Buenos días:
                            Ya quedó solucionado el problema en producción. En su momento en testing habíamos realizado una modificación en el certificado ssl que no la habíamos hecho en el servidor de producción. Para el resto de las cosas andaba bien pero para esto no.

Saludos,

Marcelo.

9
Buenos días:

                            Les comento que estamos poniendo en producción SUDOCU y estamos teniendo problemas de que no encuentra la url de araí documentos el firmador standalone.

                            Revisando las configuraciones de docs.env y docs.yml de testing y producción están similares.

                            Ambas aplicaciones generan url parecidas, difieren en la primera parte solamente.

                            La aplicación Siu-Firmador no encuentra la url de producción pero si la de testing.

                            En ambas aplicaciones es posible firmar con la plataforma Firmar (en testing con tstfirmar.gob.ar, en producción con firmar.gob.ar)

                            Se les ocurre algo que nos puede haber faltado revisar?

Desde ya muchas gracias por su atención.

Saludos,
Marcelo.

10
Araí - Usuarios / Re:Migrar araí-usuarios 3.0 a 3.1
« on: Mayo 26, 2021, 07:32:45 pm »
Hola Sergio:
                           Disculpas. Me fuí directamente a ver el changelog y llegué a la documentación de araí-usuarios (nos sirvió para actualizar ldap). No me percaté de la documentación de EEI 1.0 a 1.1.
                           Quedó migrado sin problema.

Muchas gracias.
Saludos,
Marcelo.

11
Araí - Usuarios / Re:Migrar araí-usuarios 3.0 a 3.1
« on: Mayo 25, 2021, 09:31:38 am »
Buenos días:
                           Intentamos correr el comando sin las acciones de modificar instancia.ini y exportar la instalación ejectuando:

Cita
docker run --rm -it  --env-file=migrar.env --volume /tmp/instalacion_3_0:/tmp/mapeo_interno hub.siu.edu.ar:5005/siu-arai/arai-usuarios/idm:v3.0.5
sirviendo . . .
[Tue May 25 09:26:55.360932 2021] [core:warn] [pid 6] AH00111: Config variable ${TOBA_ALIAS_NUCLEO} is not defined
[Tue May 25 09:26:55.361402 2021] [core:warn] [pid 6] AH00111: Config variable ${IDM_URL_ALIAS} is not defined
[Tue May 25 09:26:55.361496 2021] [core:warn] [pid 6] AH00111: Config variable ${IDM_URL_ALIAS} is not defined
AH00526: Syntax error on line 30 of /usr/local/app/idm/instalacion/toba.conf:
RewriteBase: argument is not a valid URL

                           Tendrá que ver con el archivo migrar.env? en url de idm probamos con la url del sistema, la que está en la documentación y otras...pero siempre el mismo resultado.

Saludos,
Marcelo.

12
Araí - Usuarios / Migrar araí-usuarios 3.0 a 3.1
« on: Mayo 24, 2021, 08:36:39 am »
Buenos días:
                           Estamos tratando de implementar EEI versión 1.1.0. Mirando los changelog de la versión se ve que hay que pasar Araí-usuarios de la versión 3.0 a 3.1.
                           Siguiendo la documentación de la actualización, pudimos actualizar la estructura de ldap, pero no pudimos actualizar la base de datos. Ejecutar el comando que se muestra en https://documentacion.siu.edu.ar/usuarios/docs/cache/3.0-to-3.1/#actualizar-postgresql nos dió un error que no conoce idm/bin/instalador.

                           
Cita
docker run --rm -it     --env-file=migrar.env    --volume /tmp/instalacion_3_0:/tmp/mapeo_interno    hub.siu.edu.ar:5005/siu-arai/arai-usuarios/idm:v3.0.5 --    sed -i 's/\[arai_usuarios\]/\[arai_usuarios\]\nusar_perfiles_propios="1"/g' /usr/local/app/idm/instalacion/i__produccion/instancia.ini    && idm/bin/instalador instalacion:exportar -d /tmp/mapeo_interno --no-interaction --no-progress

-bash: idm/bin/instalador: No existe el fichero o el directorio

                           Que nos estará faltando?
Desde ya muchas gracias por su atención.

Saludos,

Marcelo.


13
Hola:

           Hemos integrado una aplicación de desarrollo propio (desarrollada con toba 3.2) al login centralizado. Se generó un usuario genérico (empleado) dentro de la misma que accede a unas operaciones específicas.

           Lo que necesitamos hacer es correr algún proceso que genere una cuenta en cada usuario de Araí usuarios que cuente con número de legajo (osea empleado de la universidad).

           Se tendría que generar algún archivo .json como generan las aplicaciones siu (Guaraní, diaguita) para realizar esta operación? o existe alguna otra forma?

Desde ya muchas gracias por su atención.

Saludos,
Marcelo.

14
Araí - Usuarios / Re:EEI - Problemas con la recuperar contraseña
« on: Mayo 17, 2021, 10:51:03 am »
Hola de nuevo:
                                Revisando los parámetros por consola en usuarios_idm y comparándolos con una aplicación toba de desarrollo propio que si podía enviar mails, encontré que era un problema en uno de los parámetros.

Saludos,
Marcelo.

15
Araí - Usuarios / Re:EEI - Problemas con la recuperar contraseña
« on: Mayo 17, 2021, 10:29:31 am »
Buen día Richard:
                                      Te comento que en los logs de idp no aparece el error específico del envío de mail.
                                      Adjunto archivo copiado del log con la secuencia de ir a la patalla de login y luego ejecutar recuperar contraseña.
                                      Estuve mirando los logs de huarpe_webapp y de usuarios_api pero no loggean nada con esta secuencia.

                                     Ingresando por consola al contenedor de idm el archivo smtp.ini muestra lo siguiente:
                                     
Cita
bash-5.0# cat smtp.ini

[arai-usuarios]
host = "$env(MAILER_HOST)$"
puerto = "$env(MAILER_PORT)$"
auth = "$env(MAILER_AUTH)$"
usuario = "$env(MAILER_USUARIO)$"
clave = "$env(MAILER_CLAVE)$"
seguridad = "$env(MAILER_SEGURIDAD)$"
nombre_from = "$env(MAILER_FROM)$"
helo = "$env(MAILER_HELO)$"
from = "$env(MAILER_FROM)$"
auto_tls = "1"
                                       
                   Al ejecutar por ejemplo echo $MAILER_HOST me da la ip que se configuró en usuarios.env

Saludos,
Marcelo.

Páginas: [1] 2 3 ... 11