Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - rbombillar

Páginas: [1] 2 3 ... 7
1
Técnicos / Re:Agregar logo institución al analítico
« on: Septiembre 08, 2022, 04:56:38 pm »
Solucionado. El problema era que estaba intentando agregar la imagen por path y no por parámetro. El certificado analítico o cualquier otro certificado reconoce el logo a partir de la expresión $P{logo}. Lo que noté es que al momento de descargar el analítico, el logo se ve de forma transparente en el documento, es decir, con poca opacidad.  Intente setear la propiedad "opaque" a la imagen pero no funcionó. Si llego a dar con la solución, luego lo reporto por acá.

Saludos.
Rodrigo

2
Técnicos / Agregar logo institución al analítico
« on: Septiembre 05, 2022, 09:42:37 am »
Hola buen día, les comento.. estoy teniendo inconvenientes para descargar el analítico de materias con el logo de la institución. Al momento de modificar el certificado existente, cuando quiero descargarlo se queda en blanco la página. Lo que hice fue seguir la documentación, agregue la imagen con el ireport designer 5.6. Modifique el path de forma relativa y absoluta y no lo tomó. También intente poner la imagen en el directorio donde esta el certificado y ajustar el path en el jrxml y en el jasper. Tampoco funcionó la descarga. Chequee el tema de los permisos de las carpetas y de la imagen y al parecer están bien. Probé insertar varias imágenes png o jpg y tampoco. alguna alternativa que pueda probar?

Desde ya muchas gracias.
Saludos.
Rodrigo

3
Técnicos Mapuche / Re:Quitar detalle ganancias en recibo
« on: Junio 10, 2022, 11:48:25 am »
Solucionado.

Gracias.
Saludos.
Rodrigo

4
Técnicos Mapuche / Quitar detalle ganancias en recibo
« on: Junio 09, 2022, 10:07:23 am »
Hola Buen día, les escribo porque tenemos un inconveniente con los recibos. Al momento de imprimirlos,  En el concepto 204 correspondiente al impuesto a las ganancias aparece un detalle que dice RetGcias que tapa el importe(dejo adjunto). Estuve revisando el archivo xsl que muestra la estructura del recibo ubicado en : "PATH_MAPUCHE/personalizacion/plantillas/recibos/"  pero no encuentro ese texto como para quitarlo. De donde podría modificar esto?

Desde ya muchas gracias.
Saludos.
Rodrigo

5
Técnicos / Re:Falló la creacion del documento en SIU - Arai
« on: Junio 07, 2022, 12:51:06 pm »
Hola Leonel, te quería avisar que en autogestión nos pasa el mismo error y no entendemos bien por que pasa esto. En gestión se cierra correctamente y se envía el documento a Arai, en cambio en Autogestión sigue tirando ese error y el documento no llega a enviarse. Habrá posibilidad de continuar esto por GDS y ver la posibilidad de coordinar un meet para que podamos mostrarles? me parece que seria mas fácil para diagnosticar el error.

Gracias.
Saludos.
Rodrigo

6
Técnicos / Re:Falló la creacion del documento en SIU - Arai
« on: Mayo 26, 2022, 10:58:26 am »
Hola Leonel, tenia supervisor instalado pero lo había configurado mal y no me iniciaba automáticamente. ya lo arregle y pudimos ver los documentos en arai.

Muchas gracias.
Saludos.
Rodrigo

7
Técnicos / Re:Falló la creacion del documento en SIU - Arai
« on: Mayo 24, 2022, 12:40:49 pm »
Hola Leonel, te comento.. probamos hacer una acta regular en gestión y la pudimos cerrar correctamente. Lo hicimos con el usuario toba. Verificamos el portal de huarpe de toba y no aparece el documento. Te dejo adjunto los logs de la api de documentos en modo debug.

Voy a seguir revisando,
Gracias.
Saludos.
Rodrigo

8
Técnicos / Re:Falló la creacion del documento en SIU - Arai
« on: Mayo 06, 2022, 10:33:02 am »
Hola Leonel,  dale gracias. Si tengo creada la tabla y esta corriendo el worker.

Voy a seguir investigando.
Saludos.
Rodrigo

9
Técnicos / Re:Falló la creacion del documento en SIU - Arai
« on: Mayo 06, 2022, 09:25:28 am »
Hola Leonel, te paso el contenido del archivo docs-cli.log :

[2022-05-05 12:10:35] docs-cli.ERROR: Si especifica generacion de archivo por callback debe ingresar parametros [] []
[2022-05-05 12:10:35] docs-cli.ERROR: Error postDocumento, codigo 0. Mensaje: Si especifica generacion de archivo por callback debe ingresar parametros. request:  [] []

Por otro lado revise los logs de la api de documentos y me devolvió status 200 :

 "GET /docs/rest/backend/autorizacion/proceso-autorizacion?skip_sudocu=1&id_usuario_sso='DNI_DOCENTE' HTTP/1.1" 200 21

El archivo del jasper me lo genero bien, pude ver el acta tanto en el path que me pasaste como en la url que aparece en los logs, donde te deja acceder tambien.

Gracias.
Saludos.
Rodrigo

10
Técnicos / Falló la creacion del documento en SIU - Arai
« on: Mayo 05, 2022, 01:22:44 pm »
Hola buenas tardes, estamos teniendo inconvenientes para mandar el acta de promocion y/o regular al portal huarpe del docente. Al momento de querer cerrar el acta aparece el error que figura en el asunto (dejo adjunto). A pesar del error el acta se cierra pero no aparece en el portal de Huarpe. Les comento los pasos que hicimos:

Guarani 3.19.0:
1) Se configuro la url de huarpe en el archivo config.php en autogestion
2) se configuraron los parametros de las actas digitales vinculadas con arai para permitir el uso del acta digital.
2) se configuro arai_documentos.ini tanto en gestion como autogestion, apuntando al "https://midominio"/docs con el usuario/clave correspondiente.
3) Guarani esta apuntando al repositorio digital(nuxeo) de arai.
4) Se vinculo el usuario arai del docente en gestion.

Arai:
1) se configuro la url de nuxeo de arai en el archivo docs.env con el usuario/clave correspondiente.

Ambos servidores se comunican entre si internamente por ping y resuelven correctamente los DNS. Arai esta configurado con traefik pero entiendo que el proxy reverso no deberia ser un problema, ya que solamente hace el ruteo interno de los contenedores. Guarani no está por proxy reverso. Dejo adjunto los logs del error.
Que me puede estar faltando?

Desde ya muchas gracias.
saludos.
Rodrigo

11
Técnicos / Re:Error Autenticacion SAML Autogestion
« on: Abril 21, 2022, 02:00:03 pm »
Hola Leonel, te queria avisar que ya lo pude solucionar. Habia que dejar el atributo_usuario = "defaultUserAccount" en el archivo saml_onelogin.ini y cuando revise el log me di cuenta que al momento de autenticar estaba tomando el fingerprint del certificado publico del idp x509 y no el que habia generado.. asi que comente la linea esa en el archivo settings.php y ya pude autenticar.

Muchas gracias.
Saludos.
Rodrigo

12
Técnicos / Re:Error Autenticacion SAML Autogestion
« on: Abril 21, 2022, 09:23:11 am »
Hola Leonel, si estoy intentando integrar SAML con Arai. acabo de modificar el saml_uid en el login.php y en el archivo saml_onelogin en el campo atributo_usuario pero el error sigue persistiendo. Te paso como me quedo configurado ambos archivos:

saml_onelogin.ini :

[basicos]
permite_login_toba= "0"
atributo_usuario = "userAccounts"


[sp]
auth_source = "default-sp"
session.phpsession.cookiename = "TOBA_SESSID"
idp = "https://arai.unab.edu.ar/idp/saml2/idp/metadata.php"

;Necesita si o si definirle un proyecto por default para loguearse, esto va a determinar las urls de retorno y el entityID del SP
proyecto_login = "guarani"


[idp:https://arai.unab.edu.ar/idp/saml2/idp/metadata.php]
name = "SIU-Guaraní"
SingleSignOnService = "https://arai.unab.edu.ar/idp/saml2/idp/SSOService.php"
SingleLogoutService = "https://arai.unab.edu.ar/idp/saml2/idp/SingleLogoutService.php"
certFile = "/usr/local/proyectos/guarani/instalacion/certificado_idp.crt"

login.php:

 'saml'   => array(
                'activo'     => true,
                'clase'      => 'modelo\\autenticacion\\auth_saml',
                'parametros' => array(
                        'settings_file' => \siu\bootstrap::get_dir_instalacion() . '/saml/settings.php',
                        'saml_uid' => 'userAccounts',// 'urn:oid:0.9.2342.19200300.100.1.1', //se matchea con local_uid
                        'local_uid' => 'usuario', //puede ser 'persona'

Voy a seguir revisando.
Gracias!
Saludos.
Rodrigo

13
Técnicos / Error Autenticacion SAML Autogestion
« on: Abril 20, 2022, 09:17:33 am »
Hola buen dia, abro este hilo porque tenemos inconvenientes en Guarani para loguear via SAML en Autogestion. al momento de querer autenticar aparece el error que dejo adjunto. dejo tambien el txt con los logs. les hago una consulta, solamente segui los pasos para integrar saml con guarani desde la pagina de expedientes.. estuve viendo que hay otro link para configurar saml en Guarani: https://documentacion.siu.edu.ar/wiki/SIU-Guarani/version3.17.0/interfaces/saml
es necesario hacer estos pasos? o alcanza con la documentacion de expedientes para que funcione correctamente saml en Guarani?

desde ya muchas gracias.
Saludos.
Rodrigo

14
Técnicos / Re:Problema para inscribir a Estudiante a propuesta
« on: Abril 19, 2022, 10:40:05 am »
Hola buen dia, queria avisarles que ya pudimos solucionar el inconveniente. Paso en limpio.. la 2da query que propuso Ale:

SELECT r.requisito, r.nombre as requisito_nombre, p.propuesta, p.propuesta_nombre, p.plan, p.plan_version
  FROM vw_planes as p
  JOIN sga_requisitos_ingreso_aplanado as ria ON ria.plan_version = p.plan_version
  JOIN sga_requisitos_ingreso as ri ON ri.requisito_propuesta = ria.requisito_propuesta
  JOIN sga_requisitos as r ON r.requisito = ri.requisito
GROUP BY r.requisito, r.nombre, p.propuesta, p.propuesta_nombre, p.plan, p.plan_version
HAVING COUNT(distinct ri.restrictivo) > 1
ORDER BY r.requisito, p.propuesta

no me devolvio nada. Con respecto a la ultima query, me muestra los requisitos y los mismos no estan duplicados (dejo el resultado adjunto).

Desde el area funcional probaron realizar las operaciones planteadas por Leonel y no vieron los requisitos duplicados, por lo cual esos registros duplicados se ven solo desde la base. Por alguna razon que desconocemos se realizo mal la operacion con este alumno ya que con los demas estudiantes no tuvimos problemas al momento de inscribirlos a la propuesta.

SOLUCION:  Probe la solucion planteada por Leonel. Elimine los requisitos que estaban duplicados (req 1019 y 1020), me quede con los ultimos inserts. Para el requisito 1001 lo borre completamente de la tabla sga_requisitos_digitales pero tuve que sacarlo primero de la tabla sga_requisitos_presentados ya que estaban vinculadas. A partir de eso ya se pudo agregar el estudiante en la propuesta.

Muchas gracias a ambos.
Saludos.
Rodrigo

15
Técnicos / Re:Problema para inscribir a Estudiante a propuesta
« on: Abril 12, 2022, 01:42:49 pm »
Hola, gracias por la ayuda.. les comento, ejecute  la primer query que paso Alejandro y me devuelve el listado que dejo adjunto. Se ve claramente la repeticion de los requisitos 1001, 1019 y 1020. la 2da query no me devolvio nada. Estamos usando la version 3.19.1 de Guarani. Voy a probar eso que me decis Leonardo, para ver si soluciona el inconveniente y les aviso.

Gracias.
Saludos.
Rodrigo

Páginas: [1] 2 3 ... 7