Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - rfarias

Páginas: [1] 2
1
SUDOCU - Usuarios / [RESPONDIDO] Acumulación de Expedientes
« on: Mayo 02, 2022, 12:01:05 pm »
Hola que tal? Soy de la Universidad Nacional de la Patagonia Austral.
Quería consultar sí Sudocu, dispone de alguna operación para acumular/unir expedientes. De ser así, tienen alguna documentación de cómo sería dicho proceso?
Saludos y desde ya muchas gracias.

2
Toba - Desarrollo / Extender bootstrap_tp_normal
« on: Septiembre 30, 2020, 10:17:46 am »
Hola a todos,
Les comento que hemos empezado a desarrollar nuevos proyectos con toba 3.3.9, y como manejado de salida usamos bootstrap. La consulta es si es posible extender la clase bootstrap_tp_normal, desde el proyecto, para sobreescribir algunos métodos y luego hacer que toba levante esas personalizaciones. También quisieramos personalizar el bootstrap_tp_logon.php.
Hemos intentado hacerlo creando un tipo de página en toba editor, como se hacia usando el manejador de salida por defecto de toba, pero no lo hemos logrado. Métodos propios de bootstrap_tp_normal, los sigue levantando del archivo que se encuentra en SIU/ManejadorSalidaBootstrap/Componentes/TiposPagina
Saludos a todos


3
Toba - Desarrollo / Proyectos en TOBA 3.1 son compatible en 3.0?
« on: Octubre 02, 2018, 02:30:53 pm »
Hola que tal? quería consultar si los proyectos que se desarrollan en la versión 3.1 se van a poder seguir trabajando en 3.0
La pregunta es porque en nuestro equipo de desarrollo se dió la situación de que en uno de los puestos de trabajo se actualizó a la 3.1 y los cambios realizados allí no pudimos levantarlos en las instancias de toba 3.0. Al parecer cambia la estructura de la base de datos de toba y no se pueden importar los metadatos.

4
SIU-Kolla - Técnicos / Kolla_en toba desarrollo
« on: Noviembre 28, 2017, 04:01:43 pm »
Hola cómo están?
Mi nombre es Roberto y trabajo en el área de sistemas de la UNPA.
Recientemente, he descargado el proyecto kolla y lo he levantado en una instancia de desarrollo de toba 2.7.12 , para ello, actualicé algunas dependencias vía composer.
El problema que estoy teniendo, es que en aquellas clases que referencian a otras clases a través de namespaces las tengo que importar previamente a través de la sentencia require_once .
Creo que el autoload de toba no las está buscando correctamente ya que todas las clases están cargadas en la instancias e indexadas en el archivo kolla_autoload.php.
Me estará faltando alguna configuración?
Estoy usando php 5.6

Saludos a todos.

5
Toba - Desarrollo / conteo de accesos a una operacion
« on: Mayo 29, 2017, 06:01:51 pm »
Muy buenas tardes a tod@s,
Quería consultar si existe en la api de toba algún método que devuelva la siguiente información:
  • cantidad de accesos de un usuario a una operación
  • listado de las últimas operaciones a las cuales ha accedido un usuario
La finalidad es mostrar, al usuario, un menú de las últimas operaciones que ha ejecutado, y tener un acceso directo a aquellas a las cuales accede con frecuencia.

desde ya muchas gracias.
Saludos

6
Toba - Desarrollo / TOBA con DOCKER
« on: Octubre 24, 2016, 03:02:47 pm »
Hola a todos cómo están?
quería consultarles si existe alguna manera de setear el archivo docker-compose.yml para que el instalador de toba reconozca una clave para postgres diferente a la que viene por defecto (postgres). He intentado cambiando la variable POSTGRES_PASSWORD  del archivo, pero el instalador al parecer continúan intentando autenticarse con la clave por defecto.
Otra consulta, es si es posible setear el docker-compose.yml, o el docker.env, para que la instalación de toba se como instancia de producción.
La última consulta que quisiera hacer es donde alojar la sql que crea la base del proyecto. He configurado las siguientes variables en el docker-compose.yml pero la base del proyecto no se crea:
Código: [Seleccionar]
TOBA_DIR: /var/local/toba
TOBA_INSTALACION_DIR: /var/local/toba/docker-data/instalacion
TOBA_PROYECTO                     : tuinformation
TOBA_BASE_NOMBRE                  : tuinformation
TOBA_PROYECTO_DIR                 : /var/local/toba/proyectos/tuinformation
TOBA_PROYECTO_ALIAS               : /tutarjeta
TOBA_PROYECTO_INSTALAR            : "true"
TOBA_PROYECTO_INSTALAR_PARAMETROS : --base-nombre tuinformation

Saludos a todos

7
Toba - Desarrollo / REST con ssl
« on: Agosto 24, 2016, 02:11:23 pm »
Hola todos,
Estamos intentando configurar los datos de conexión de rest para que use certificados ssl.
Hemos seguido la documentación de la wiki (http://toba.siu.edu.ar/trac/toba/wiki/Referencia/Rest), pero no nos funciona.
Hemos habilitado el módulo ssl en apache, y agregado las siguientes líneas en el virtalhost
Código: [Seleccionar]
SSLVerifyClient require
SSLOptions +StdEnvVars +ExportCertData
Los certificados estamos casi seguros que  funcionan puesto que hemos verificado que son válidos empleando este comando:
Código: [Seleccionar]

openssl verify -purpose sslserver -CAfile ca.crt  cliente.crt
Les paso cómo hemos configurado el cliente.ini:
Código: [Seleccionar]
[conexion]
to = "http://tarjetau.unpa.edu.ar/hub_servicios/1.0/rest/"
auth_tipo = "ssl"
cert_file = "/home/roberto/certificados/CA/certificados/cliente.crt"
key_file = "/home/roberto/certificados/CA/privado/cliente.key"
ca_cert= "/home/roberto/certificados/CA/certificados/ca.crt"
El archivo servidor.ini
Código: [Seleccionar]
autenticacion = ssl
El archivo servidor_usuarios.ini
Código: [Seleccionar]
[admin]
fingerprint = 5bdb46940f1a50e5db7b259ac536f4fb8864e803
La fingerprint la calculamos ejecutando este código:
Código: [Seleccionar]
$certUtils = new SSLCertUtils();
$certUtils->loadCertFromFile("/home/roberto/certificados/CA/certificados/cliente.crt");
echo $certUtils->getFingerprint();

En el archivo sistema.log del servidor de ws nos muestra el siguiente error:
Código: [Seleccionar]
[DEBUG][hub_servicios] SIUToba\rest\http\respuesta_rest::__set_state(array(
   'status' => 401,
   'headers' =>
  array (
    'Content-Type' => 'application/json',
    'API-Version' => '1.0.0',
  ),
   'data' =>
  array (
    'mensaje' => 'autenticación cancelada, falta información',
  ),
   'encoding' => 'latin1',
   'api_version' => '1.0.0',
))

En apache
Código: [Seleccionar]
PHP Fatal error:  Uncaught exception 'GuzzleHttp\Exception\ClientException' with message 'Client error response [url] http://tarjetau.unpa.edu.ar/hub_servicios/1.0/rest/mapuche/agentes/29058990 [status code] 401 [reason phrase] Unauthorized' in /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php:89
Stack trace:
#0 /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/Subscriber/HttpError.php(33): GuzzleHttp\Exception\RequestException::create(Object(GuzzleHttp\Message\Request), Object(GuzzleHttp\Message\Response))
#1 /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/Event/Emitter.php(109): GuzzleHttp\Subscriber\HttpError->onComplete(Object(GuzzleHttp\Event\CompleteEvent), 'complete')
#2 /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/RequestFsm.php(203): GuzzleHttp\Event\Emitter->emit('complete', Object(GuzzleHttp\Event\CompleteEvent))
#3 /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/RequestFsm.php(92): GuzzleHttp\RequestFsm->complete(Object(GuzzleHttp\Transaction))
#4 /home/ro in /home/roberto/toba_2.7.2/vendor/guzzlehttp/guzzle/src/Exception/RequestException.php on line 89
Les adjunto los certificados por si quieren probarlos.

Saludos

8
Toba - Desarrollo / Planificador de tareas de toba
« on: Julio 11, 2016, 01:40:55 pm »
Hola cómo están?
Estamos trabajando en un sistema en toba donde necesitamos enviar periódicamente alertas vía correo electrónico.
Implementamos un comando en toba y lo agregamos al crontab del S.O.
Vimos que toba ofrece otra alternativa: Planificador de Tareas, alguien nos podría pasar un ejemplo para ver como se implementa? En la wiki no pude encontrar algo sobre esta funcionalidad.
Desde ya muchas gracias por la ayuda que puedan brindarnos.
Saludos a todos

9
Toba - Desarrollo / Problema al subir un archivo - Verificación post
« on: Abril 25, 2016, 02:21:10 pm »
Hola a todos:
Tenemos el siguiente problema en la subida de archivos:
Contamos con un formulario con un campo ef_popup, hemos limitado la subida de archivos a 25M en php.ini.
La subida de archivos inferiores a 25M funciona perfecto. El problema viene a la hora de gestionar la excepción lanzada cuando un usuario sube un archivo superior a 25M, aquí desearíamos poder capturarla y mostrar un mensaje más amigable al usuario. En estos casos, la aplicación desarrollada no carga y queda todo en blanco con un mensaje que dice ERROR INTERNO.
Analizando un poco más a fondo, vemos que no pasa la validación del método verificar_pedido_post(), y es allí donde se produce la excepción que es de tipo toba_error_seguridad. Según entendemos aquí se hace una validación por CSRF para evitar ataques por inyección de código.
¿Cómo podemos hacer para que la validación no tome en cuenta el tamaño del contenido enviado por post cuando se suben archivos? ¿Nos faltará alguna configuración de seguridad en nuestro servidor?
Como siempre, agradecemos su ayuda.

Saludos a todos.

10
Toba - Desarrollo / encoding de archivos en toba 2.7
« on: Marzo 15, 2016, 10:42:16 am »
Hola tod@s:
Estamos teniendo un inconveniente con la versión toba 2.7.2 en debian 8 (hicimos la instalación con composer).
El problema es que durante la ejecución de algunas de las funciones del framework, las aplicaciones se pinchan y queda la pantalla en blanco.
Al principio pensamos que era problema del código de nuestras aplicaciones, pero debugeando la aplicación nos encontramos que se interrumpen en funciones propias del framework toba.
Suponemos que en la línea de código donde se interrumpe la ejecución había alguna especie de caracter extraño propio de la codificación iso 8859-1, ya que al guardarlo con codificación utf8 el problema se solucionó.
La pregunta es si es aconsejable cambiar la la codificación de todos los archivos del núcleo de toba, sin perder funcionalidad y que no falle?. Hemos visto que todos los archivos del núcleo están en su mayoría en iso 8859-1. Ahora mismo estamos teniendo problemas con otra funcionalidad y tendremos que rastrear la función que está fallando para probar si se soluciona cambiando el encoding nuevamente.

11
Toba - Desarrollo / Servicios REST
« on: Octubre 14, 2015, 11:51:53 am »
Hola a todos,
Tengo instalado la versión 2.6.0 de toba.
Previamente tenía toba 2.5 y allí desarrollamos un proyecto con servicios en rest. Ahora cargamos el proyecto en toba 2.6 y funciona perfecto salvo los servicios web. El problema es que cuando ingresamos a http://localhost/extension/1.0/rest nos aparece el siguiente mensaje

Cita
The requested URL /extension/1.0/rest was not found on this server

Interpreto que el servidor no puede resolver la url, pero no entiendo cuál puede ser la razón. Mi SO es un ubuntu 14.04, tengo instalado el mod_rewrite de apache, y las librerías necesarias para rest (php5_curl y php5_json).

si ingreso a http://localhost/extension/1.0/rest.php

me aparece este error:
Cita
{
    "error": "500",
    "mensaje": "500 Internal Server Error",
    "descripcion": "Error Interno en el servidor: No se encuentra el recurso para .php en el directorio \/home\/roberto\/toba_2.6.0\/proyectos\/extension\/php\/rest. \u00bfRuta mal formada?"
}

En mi proyecto he creado la carpeta  rest en el directorio php, y allí tengo una clase recurso_postulantes.php

Lo curioso es que tampoco funciona en toba_referencia, que es uno de los proyectos que viene por defecto.

Espero que puedan ayudarme.

Saludos a todos

12
Toba - Desarrollo / El objeto no fue instanciado
« on: Junio 03, 2015, 02:49:12 pm »
Hola a tod@s:
Tenemos el siguiente problema. Tenemos una aplicación desarrollada en toba 2.6.1.
Nuestro entorno de desarrollo es un ubuntu 14.04.
Nuestro problema aparece al instarlo en el entorno de producción (lo hacemos con el empaquetador)
El servidor es un debian 7. La instalación no presenta ningún problema, sin embargo al probarlo, las funciones ajax no funcionan. Por ejemplo los combos cuyas opciones dependen de la selección de otro combo previo. El error nos dice El objeto "100000000247" no fue instanciado en toba_constructor.php:152
También tenemos unos formularios cuyos campos, algunos se autocompletan con ajax y tampoco funcionan, en el error javascript aparece el mismo error al final.
Suponemos que estamos invocando métodos de clases que no se cargaron.
Hemos probado el mismo instalador en ubuntu y la aplicación funciona.
Nos está faltando realizar alguna configuración que en ubuntu es por defecto y en debian no?

13
Toba - Desarrollo / Capturar excepciones de datos_tabla
« on: Marzo 13, 2015, 03:30:13 pm »
Hola que tal comunidad?
Quisiera consultarles si saben si es posible capturar las excepciones que lanza un datos_tabla.
Intenté ponerlo dentro de un try{}catch{} pero supongo que dentro ya gestiona las excepciones, es decir que no las vuelve a lanzar para ser gestionadas más arriba.
Otra consulta asociada a lo mismo, es si es posible modificar el mensaje de la notificación que informa de la excepción.

Saludos

14
Toba - Desarrollo / [SOLUCIONADO]Ordenar datos_tabla
« on: Noviembre 13, 2014, 06:57:50 pm »
Hola cómo andan todos?
Quisiera consultar si existe una manera de ordenar los registros de un datos_tabla por una columna en particular.
Sé que puede realizar una consulta sql, pero estoy usando una datos_relacion con varias tablas cuyos datos se cargan en cuadros y formularios multilínea.
Desearía poder controlar el orden en que estos registros se cargan en estos componentes.
¿Existe algún método para ordernar los registros por ejemplo cuando se hace un get_filas()?
Saludos

15
Toba - Instalación / Toba con php5.4 y apache 2.4.x
« on: Agosto 31, 2014, 01:17:54 pm »
Hola quisiera consultar si la versión 2.6 de toba ya funciona bien con php5.4 y apache 2.4.x
Quizás la 2.5 ya funciona, pero no lo hemos probado.
Pregunto porque hemos tenido problemas con la versión 2.3.6 y hemos tenido que hacer un downgrade a la versión 5.3 en el servidor y aún así no funcionaba correctamente (la versión de apache era 2.4)
Los problemas era de codificación (que se solucionaron con el downgrade) y en el envío de algunos formularios donde algunos campos no se enviaban en el post.
Finalmente nos quedamos con las versiones php5.3 y apache 2.2.
Pregunto esto porque las nuevas versiones de debian ya vienen con php 5.4 o superior.
En la wiki de referencia dice que se puede instalar con php5.2 en adelante, y luego más abajo se recomienda php 5.3.
Más que nada para estar más seguro de las versiones en las cuales funciona el framework, sería bueno saber hasta que versión de php y apache funciona correctamente o fue probado sin inconvenientes.

Saludos.

Páginas: [1] 2