Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Temas - aimlauer

Páginas: [1]
1
SUDOCU - Técnicos / [SOLUCIONADO] connection refused - LOKI
« on: Septiembre 12, 2022, 09:32:59 am »
Buenos dias! como estan?

Espero puedan darme una mano con este error que estoy teniendo con LOKI, la versiòn que esta desplegada es la version: "3.8" y la imagen es "image: grafana/loki:2.3.0". Se creò el archivo corrrespondiente daemon.json en la carpeta /etc/docker:

{
    "debug" : true,
    "log-driver": "loki",
    "log-opts": {
        "loki-url": "https://usuario:contraseña@127.0.0.1:3100/loki/loki/api/v1/push",
        "loki-batch-size": "400",
        "loki-timeout": "3s",
        "loki-retries": "3"
    }
}

El plugin fue instalado y esta habilitado:
ID             NAME          DESCRIPTION           ENABLED
56b644ef1ef7   loki:latest   Loki Logging Driver   true

En definitiva se siguiieron todos los pasos que estan en el enlace https://expedientes.siu.edu.ar/docs/logs/

El problema que tengo es que al intentar agregar el datasource de loki en grafana tengo el siguiente error:
Loki: Cannot connect to Loki. 502. [object Object]

Y en el log del servicio loki_grafana aparece el error:

loki_grafana.1.spl1idiei9iw@vm08unlc    | t=2022-09-12T12:20:50+0000 lvl=eror msg="Data proxy error" logger=data-proxy-log userId=1 orgId=1 uname=admin path=/api/datasources/proxy/6/loki/api/v1/label remote_addr=10.0.0.2 referer=https://vm08unlc.riu.edu.ar/metricas/datasources/edit/daviXaMVz error="http: proxy error: dial tcp 127.0.0.1:3100: connect: connection refused"

Entonces las preguntas son varias, deberia ver los puertos 3100 y 3000 levantados en el listao de puertos abiertos en el sistema operativo? Deberia ver en el listado de servicios levantados en docker los puertos y su redirecciòn?

Desde ya muchas gracias,
Saludos cordiales.

NOTA: Se establecieron reglas en UFW para permitir el trafico a los puertos 3100 y 3000 desde cualquier origen

2
SIU - Huarpe / No such image: hub.siu.edu.ar
« on: Julio 12, 2022, 08:46:06 pm »
Buenas! como estan?
Estoy teniendo un problema con el servicio de huarpe, he probado conectividad hacia hub.siu.edu.ar y entiendo que con el puerto 443 y el 5005 deberian estar abiertos. Mudamos nuestros servidores a otro datacenter y vamos solicitando aperturas de puertos de ser necesario.
Que otro puerto podria ser necesario? o que podria mirar para solucionar este problema?

Paso el log:

TATE            ERROR                              PORTS
ngpu79tyf7ho   huarpe_webapp.1       hub.siu.edu.ar:5005/siu/expedientes/huarpe-core:v3.0.2   sudocu-worker02-prod   Shutdown        Rejected 6 minutes ago   "No such image: hub.siu.edu.ar…"   
ody0uhkdwxcz    \_ huarpe_webapp.1   hub.siu.edu.ar:5005/siu/expedientes/huarpe-core:v3.0.2   sudocu-worker02-prod   Shutdown        Rejected 6 minutes ago   "No such image: hub.siu.edu.ar…"   
rmo8b4ydc1hp    \_ huarpe_webapp.1   hub.siu.edu.ar:5005/siu/expedientes/huarpe-core:v3.0.2   sudocu-worker02-prod   Shutdown        Rejected 6 minutes ago   "No such image: hub.siu.edu.ar…"   
voc2kcagvesj    \_ huarpe_webapp.1   hub.siu.edu.ar:5005/siu/expedientes/huarpe-core:v3.0.2   sudocu-worker01-prod   Shutdown        Rejected 6 minutes ago   "No such image: hub.siu.edu.ar…"   
yeyrtiqayn1v    \_ huarpe_webapp.1   hub.siu.edu.ar:5005/siu/expedientes/huarpe-core:v3.0.2   sudocu-worker01-prod   Shutdown        Rejected 7 minutes ago   "No such image: hub.siu.edu.ar…"   
root@sudocu-manager01-prod:/usr/local/proyectos/expedientes/prod/arai#

Aclaracion: otros servicios que estan en la misma VM no tienen problema y veo que levantan bien despues de varios intentos en la busqueda de la imagen.
Desde ya muchas gracias! saludos

3
SUDOCU - Técnicos / error_Invalid signature - Sudocu
« on: Junio 24, 2022, 02:38:49 pm »
Buenas, como estan?

Tengo un problema con la implementacion de sudocu 1.3.4, esta levantando bien el stack completo, se llega al login correctamente pero al intentar ingresar cualquier usuario (inclusive adminsudocu) tengo un error en sudocu_api-server:

| [2022-06-24T13:52:02] error_Invalid signature  {
   msg: 'error_Invalid signature',
   type: 'error',
   clientmessage: 'error_Invalid signature',
  id_err: 'jq3ok',
   trace: 'Error\n' +
     '    at _do_log (/app/src/common/alertas.js:417:27)\n' +
     '    at Function.app.alertas (/app/src/common/alertas.js:556:11)\n' +
     '    at /app/src/modules/auth/auth.js:336:13\n' +
     '    at Strategy.strategy.error (/app/node_modules/passport/lib/middleware/authenticate.js:352:18)\n' +
    '    at /app/node_modules/passport-saml/lib/passport-saml/strategy.js:82:38',
   file: '/app/src/modules/auth/auth.js:336:13',

El mismo error se ve desde la web, que dice
"{"msg":"error_Invalid signature","type":"error","clientmessage":"error_Invalid signature","id_err":"bklld"}"

Este mismo problema ya lo habia tenido anteriormente y era porque desde la version 1.3.0 es obligatorio configurar un certificado para el IDP en la integración con Araí - Usuarios por lo cual segui las instrucciones que se encuentran aqui https://sudocu.dev/docs/documentacion-tecnica/faq-tecnico#configuraci%C3%B3n-del-certificado-para-el-idp-en-la-integraci%C3%B3n-ara%C3%AD---usuarios, por lo cual luego de aplicar esto funcionaba todo correctamente.

He realizado los mismo pasos pero tengo el error de mas arriba de "error_Invalid signature".
He verificado que dentro del contenedor de sudocu_api-server en /etc/ssl/certs/ exista el archivo cerificado_idp.pem.

Espero me puedan ayudar o guiar en que otra prueba podria hacer para detectar el problema,
Desde ya muchas gracias!

Saludos!

4
Técnicos / SMTP Gmail y cambio de politicas
« on: Mayo 23, 2022, 09:41:48 am »
Buenas, como estan?
Una consulta, con respecto al cambio de politicas por parte de gmail, el cual desde el 30 de este mes ya no permitirà el uso de sus servicios para aplicaciones de terceros los cuales SOLAMENTE utilicen "usuario y contraseña" para la validaciòn del mismo.

Para el caso de las aplicaciones que solamente utilizan usuario y contraseña para el envio de notificaciones como son guarani, pilaga, etc etc, tenemos alguna alternativa ? En SUDOCU se utiliza el "resfresh_token" y el "client_id" por  lo cual SUDOCU no se veria afectado.

De no existir una alternativa o parche para salvar esto, nos queda como alternativa la creacìon de un server dedicado, ejemplo POSTFIX, y posteror uso de ese SMTP para el reenvio de notificaciones?

Aguardo su respuesta, mientras nosotros ya estamos avanzando con la instalaciòn y configuracion de POSTFIX para su uso, por ahora sin resultados positivos.

Saludos

5
Buenas tardes! como estan???

Estamos actualizando nuestro ambiente de testing de sudocu, pasando de la version 1.2.x a la version 1.3.x.  Vamos siguiendo el instructivo que esta en https://expedientes.siu.edu.ar/docs/1.2-to-1.3/.

Luego de hacer la comparacion de los archivos del proyecto anterior con el nuevo, y de hacer las modificaciones y personalizaciones del caso, tenemos un error al hacer el deploy de sudocu, puntualmente con el servicio api-server de sudocu.
 
El error es el siguiente:
TypeError: cert is required
  at assertRequired (/app/node_modules/passport-saml/lib/node-saml/utility.js:7:15)
  at SAML.initialize (/app/node_modules/passport-saml/lib/node-saml/saml.js:110:48)
  at new SAML (/app/node_modules/passport-saml/lib/node-saml/saml.js:79:29)
  at new AbstractStrategy (/app/node_modules/passport-saml/lib/passport-saml/strategy.js:26:26)
  at new Strategy (/app/node_modules/passport-saml/lib/passport-saml/strategy.js:154:1)
  at module.exports (/app/src/modules/auth/auth.js:169:19)
  at module.exports (/app/src/modules/auth/index.js:3:25)
  at /app/src/main.js:422:74
  at Array.forEach (<anonymous>)
  at _iniciar_modulos (/app/src/main.js:421:8)

Nos dieron una ayuda con respecto a que existe un paso mas a realizarse,  ya que desde la version 1.3.0 es obligatorio configurar un certificado para el IDP en la integración con Araí - Usuarios. Es por ello que nos fuimos al siguiente enlace https://sudocu.dev/docs/documentacion-tecnica/faq-tecnico/#configuraci%C3%B3n-del-certificado-para-el-idp-en-la-integraci%C3%B3n-ara%C3%AD---usuarios,  en donde se explican los pasos a realizarse en el item "Configuración del certificado para el IDP en la integración Araí - Usuarios".

Aqui es donde viene la duda, ya que en el paso 3 dice:

Verificar en el archivo sudocu.yml que contenga las siguientes líneas. En caso contrario agregarlas en la sección de secrets.   
   - source: sudocu_idp_cert_pem         
    target: /etc/ssl/crt/certificado_idp.pem

Asi que no entendemos en que seccion de secrets,  ya que existen 2 referencias en el mismo archivo:

Uno es:
 # BACKEND
  api-server:
    image: ungs/sudocu-api-server:1.3.2
    #env_file:
    #  - sudocu.env
    environment:
      TZ: "America/Buenos_Aires"
    # REEMPLAZAR POR VARIABLES DE ENTORNO
    configs:
      - source: api-server_config
        target: /app/config.json
      - source: usuarios_idp_saml_cert
        target: /app/certificado_idp.crt
    secrets:
      - sudocu-api-server

Y la otra referencia es:
secrets:
  sudocu-api-server:
      external: true

En cual iria? Se define el path en donde se encuentra el .pem? Estarìa faltando algun otro paràmetro a definir que no este en la documentacion de sudocu.dev?

Desde ya muchas gracias!
Saludos.

NOTA: Se aclara que se hicieron todos los pasos definidos en sudoco.dev, pero aun persiste el error que se pasa mas arriba.

6
SIU - Huarpe / Personalizacion portal Huarpe
« on: Marzo 03, 2022, 07:14:24 pm »
Buenas tardes! como estàn?

Estamos en la version 1.2.3 del ecosistema, y haciendo personalizaciones al portal de Huarpe para prontamente salir a producciòn.
La pregunta es, como se realiza el cambio del fondo del portal de Huarpe? la idea es poner una imagen institucional, ya hemos podido dejar solo nuestro logo, y quitando textos adicionales.
Entiendo que la personalizacion vendria a ser modificada en el archivo usuarios_idp, tocando un archivo dentro del docker.
Se adjunta una imagen para que quede claro cual es el fonde al que hago referencia.

Desde ya muchas gracias! Saludos!

7
Buenos dias! Buen año para todos!!
Tengo un error al actualizar la base de datos de sudocu, el error dice lo siguiente

root@vm06unlcTESTING:/home/# docker run --rm \
  --env SUDOCU_DB_HOST=170.210.xxx.xxx \
  --env SUDOCU_DB_NAME=sudocu \
  --env SUDOCU_DB_PORT=xxxx \
  --env SUDOCU_DB_USER=postgres \
  --env SUDOCU_DB_PASSWORD=passwordd \
  ungs/sudocu-db-instalador:1.2.9
[ERROR] AssertionError [ERR_ASSERTION]: ifError got unwanted exception: could not create unique index "idp_id_usuario_idp_usuarios_cuentas_un"
    at /usr/local/lib/node_modules/db-migrate/lib/commands/on-complete.js:15:14
    at tryCatcher (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/util.js:16:23)
    at Promise.successAdapter (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/nodeify.js:22:30)
    at Promise._settlePromise (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/promise.js:601:21)
    at Promise._settlePromiseCtx (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/promise.js:641:10)
    at _drainQueueStep (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/async.js:97:12)
    at _drainQueue (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/async.js:86:9)
    at Async._drainQueues (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/async.js:102:5)
    at Immediate.Async.drainQueues [as _onImmediate] (/usr/local/lib/node_modules/db-migrate-pg/node_modules/bluebird/js/release/async.js:15:14)
    at processImmediate (internal/timers.js:464:21)
    at Parser.parseErrorMessage (/usr/local/lib/node_modules/db-migrate-pg/node_modules/pg-protocol/dist/parser.js:287:98)
    at Parser.handlePacket (/usr/local/lib/node_modules/db-migrate-pg/node_modules/pg-protocol/dist/parser.js:126:29)
    at Parser.parse (/usr/local/lib/node_modules/db-migrate-pg/node_modules/pg-protocol/dist/parser.js:39:38)
    at Socket.<anonymous> (/usr/local/lib/node_modules/db-migrate-pg/node_modules/pg-protocol/dist/index.js:11:42)
    at Socket.emit (events.js:375:28)
    at addChunk (internal/streams/readable.js:290:12)
    at readableAddChunk (internal/streams/readable.js:265:9)
    at Socket.Readable.push (internal/streams/readable.js:204:10)
    at TCP.onStreamRead (internal/stream_base_commons.js:188:23)

Vi que existía un error bastante similar con una versión anterior de sudocu en este mismo foro, por usuarios duplicados, pero intente hacer la misma verificación y obtengo errores en la consulta, calculo que la consulta debe ser modificada para esta nueva versión.

Aguardo sus comentarios/ayuda!
Desde ya muchas gracias!! saludos

8
Técnicos / Preinscripciòn de version 3.9.0 a 3.11.0 - entorno de desarrollo
« on: Septiembre 25, 2020, 06:20:38 pm »
Buenas tardes,

Tenemos un ambiente de desarrollo el cual estamos migrando a 3.18.0, ya quedaron operativos tanto 3w como gestiòn. Estando ahora con la idea de actualizar tambien preinscripciòn veo que tenemos la version 3.9.0,  se puede realizar el "salto" de 3.9.0 a 3.11? en https://documentacion.siu.edu.ar/wiki/SIU-Guarani/preinscripcion3.11.0/documentacion_tecnica veo de como actualizar  desde 3.10 a 3.11, pero no encuentro de 3.9 a 3.11.

Espero me puedan ayudar,
Desde ya muchas gracias! saludos!

9
Buenas tardes! Como va?
Quisiera saber si no hay problema de pasar directo de 3.16.2 a 3.18.0. Es para la actualizaciòn de un ambiente
de desarrollo sin personalizaciones.

Versión Gestión         Versión Preinscripción     Versión 3w
         3.18.0                         3.10.0  o 3.11.0                 3.18.0
         3.17.1                                   3.10.0                                 3.17.0
         3.17.0                                   3.10.0                                 3.17.0
         3.16.2                                   3.9.0                                 3.16.2

Si habria que tener en cuenta algo en especial,
Desde ya muchas gracias!saludos!
 
         


10
Personalizaciones de Autogestión / Personalizacion 3W
« on: Agosto 10, 2020, 09:14:14 pm »
Buenas noches,
 
Tengo un pequeño inconveniente para separar autogestion en 2 sitios diferentes. En la actualidad tenemos un solo, y la idea es separarlo en /docentes y /alumnos.
Viendo algunas respuestas a la misma consulta, intentè aplicarlas pero sin resultado positivo :(

Tengo varias dudas:
1- Teniendo en alias.conf la definiciòn por default, se agregan 2 nuevas para definir las rutas de cada una y demas seteos de este archivo ::

Alias /ambiente "/usr/local/proyectos/g3w3/src/siu/www/"
Alias /docentes "/usr/local/proyectos/g3w3/src/pers/docentes/www/"
Alias /alumnos "/usr/local/proyectos/g3w3/src/pers/alumnos/www/"

<Directory "/usr/local/proyectos/g3w3/src/siu/www/">
        Options FollowSymLinks
        DirectoryIndex index.php
        Order allow,deny
        Allow from all
        Require all granted
         AddDefaultCharset ISO-8859-1
         include /usr/local/proyectos/g3w3/instalacion/rewrite.conf
</Directory>

<Location /ambiente>
        SetEnv ACC_ID des01
        SetEnvIf always_match ^ ACC_ALIAS=/ambiente
</Location>
<Location /docentes>
        SetEnv ACC_ID iddocentes
        SetEnvIf always_match ^ ACC_ALIAS=/docentes
</Location>
<Location /alumnos>
        SetEnv ACC_ID idalumnos
        SetEnvIf always_match ^ ACC_ALIAS=/alumnos
</Location>

Y luego dentro del archivo config.php definì lo antes nombrado (1 codigo para alumnos y otro para docentes)

'accesos' =>
                array(
                        'idalumnos' => //personalizacion para alumnos
                        array(
                                'personalizacion' => array('ambiente', 'alumnos'),
                                'database' =>
                                array(
                                        'vendor' => 'pgsql',
                                        'dbname' => 'toba_3_3',
                                        'schema' => 'negocio',
                                        'schema_toba' => 'desarrollo',
                                        'host' => '192.168.xx.x,
                                        'port' => 5432,
                                        'pdo_user' => 'postgres',
                                        'pdo_passwd' => 'guarani..123',
                                ),

Dentro de la carpeta /usr/local/proyectos/g3w3/src/pers tengo las carpetas de alumnos y docentes que contienen sus www (copiè el contenido de usr/local/proyectos/g3w3/src/siu/www/ para ver si funcionaba)
alumnos  composer.json   docentes  ejemplo01  ejemplo02 ejemplo03  ejemplo_saml_arai

Estas 2 carpetas les cambie los permisos con sudo chown $(whoami):www-data -R /usr/local/proyectos/g3w3/src/pers.

Al intentar acceder desde el navegador a la url localshot/alumnos y localhost/docentes tengo el siguiente error "Forbidden You don't have permission to access this resource."

Bueno, espero hayan podido entender lo que intento hacer.
Desde ya muchas gracias!!!!
Saludos.




11
Técnicos / Error al crear BD Preinscripciòn
« on: Julio 31, 2020, 06:02:57 pm »
Buenas tardes que tal?

Tengo un inconveniente al ejecutar el script de creaciòn de base de datos preinscripciòn. 
Tomando como referencia https://documentacion.siu.edu.ar/wiki/SIU-Guarani/preinscripcion3.11.0/instalacion_desde_cero/instalacion, en la secciòn de creacion de Base de Datos, se ejecuta el comando psql -d preinscripcion -h localhost < creacion_preinscripcion3_postgresql.sql -U postgres, al se crea la base de datos pero tengo varios errores en la salida del comando.

postgres@debian-DB:/home/usuario$ psql -d preinscripcion -h localhost < creacion_preinscripcion3_postgresql.sql -U postgres
Contraseña para usuario postgres:
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE TABLE
ALTER TABLE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
CREATE TABLE
ALTER TABLE
CREATE SEQUENCE
CREATE TABLE
ALTER TABLE
REVOKE
CREATE FUNCTION
 plpgsql_created
-----------------
 f
(1 fila)

DROP FUNCTION
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe0 0xe1 0xc1
ERROR:  no existe la función f_limpiar_acentos(text)
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe1 0x73 0x69
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xed 0x74 0x75
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
DELETE 0
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6e 0x65
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf1 0x6f 0x20 0x64
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xed 0x73 0x20
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xfa
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x69 0x63
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x64 0x69 0x67
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x66 0x6f
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xed 0x73 0x20
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xda 0x6c
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xda 0x6c
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6c 0x75
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x64 0x69 0x67
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x66 0x6f
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x6c
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x6c
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x61
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x64 0x69 0x67
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x66 0x6f
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6d 0x69
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6d 0x69
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6d 0x69
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x6d 0x69
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xc1 0x72
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xfa
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x65
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x65
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x65
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6d 0x69 0x63
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xc1 0x72
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf1 0x6f 0x20 0x64
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x76 0x69 0x6c
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x73 0x27
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x73 0x27
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe9 0x73 0x27
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe1 0x6e 0x27
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe1 0x73 0x71
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xfa
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf1 0xed 0x61 0x20
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xed 0x6f 0x64
INSERT 0 1
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x76
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xbf
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6d 0x69 0x63
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x64
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x67
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x27 0x29
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xfa
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xe1 0x70 0x69
INSERT 0 1
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6d 0x69 0x63
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xfa
INSERT 0 1
DELETE 0
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1
INSERT 0 1498
CREATE INDEX
ALTER TABLE
CREATE INDEX
ALTER TABLE
CREATE INDEX
ALTER TABLE
CREATE INDEX
ERROR:  inserción o actualización en la tabla «sga_campos_conf» viola la llave foránea «fk__sga_campos_conf__sga_campos_form»
DETALLE:  La llave (columna)=(fecha_registro) no está presente en la tabla «sga_campos_form».
CREATE INDEX
ALTER TABLE
CREATE INDEX
ALTER TABLE
CREATE INDEX
ALTER TABLE
CREATE INDEX
ALTER TABLE
CREATE INDEX
CREATE INDEX
ALTER TABLE
ALTER TABLE
ALTER TABLE
ERROR:  secuencia de bytes no válida para codificación «UTF8»: 0xf3 0x6e 0x20 0x33

Asi es que me surge la duda si todas las bases deben estar como UTF8 o como LATIN1, ya que las que tengo antes de preinscripcion son UTF8

postgres=# \l
                                   Listado de base de datos
     Nombre               |  Dueño   | Codificación |   Collate   |    Ctype    |      Privilegios     
----------------+----------+--------------+-------------+-------------+-----------------------
 postgres                  | postgres | UTF8         | es_AR.UTF-8 | es_AR.UTF-8 |
 preinscripcion     | postgres | UTF8         | es_AR.UTF-8 | es_AR.UTF-8 |
 template0               | postgres | UTF8         | es_AR.UTF-8 | es_AR.UTF-8 | =c/postgres          +
                                        |                                              |                               |                                | postgres=CTc/postgres
 template1                | postgres | UTF8         | es_AR.UTF-8 | es_AR.UTF-8 | =c/postgres          +
                                        |                                               |                              |                               |  postgres=CTc/postgres
 toba_3_3                   | postgres | UTF8         | es_AR.UTF-8 | es_AR.UTF-8 |
(5 filas)



Espero puedan guiarme para subsanar estos errores.
Desde ya muchas grarcias! saludos.



12
Buenas tardes, como estàn?

Tengo un problema que seguramente serà un error mio, pero del que aun no puedo salir.  Estamos haciendo la instalaciòn desde cero de la version 3.18.0 de G3 en un ambiente de desarrollo. Nos encontramos en el punto 4 del documento https://documentacion.siu.edu.ar/wiki/SIU-Guarani/version3.18.0/instalacion/3w en la secciòn 4 "Editar los archivos de configuración". En esta secciòn al hacer la modificaciòn de paràmetros en  el archivo alias.conf dice que el ID <bloque de acceso> se corresponde con la entrada en el archivo config.yml, este archivo no lo encuentro en ningun lado... :(

<Location /<nombre del alias>>
        # representa el id interno de la unidad académica. Se correponde con la entrada
        # en el archivo config.yml ua_<ACC_ID>. Ej: ua_VET
        SetEnv ACC_ID <bloque de acceso>

        # se setea de esta manera para que esta variable sea accesible desde mod_rewrite
        # ATENCIç?N: el alias debe empezar con '/'
        SetEnvIf always_match ^ ACC_ALIAS=/<nombre del alias>
</Location>

Este archivo se debiò hacer generado al instalarse? O de donde puedo sacar ese dato?
Desde ya muchas gracias, perdonen la molestia.

Saludos cordiales.

13
Buenas, como estan?

Estamos con la instalaciòn de la version 3.18 , teniendo separados la aplicacion en una vm y postgres en otra vm. Al terminar de correr el comando <composer-install> al terminar tenemos el siguiente error:

yarn: error: no such option: --modules-folder
Script yarn add ckeditor@4.11 jquery@3.4 jquery-migrate@3.0 siu-js-app-launcher@1.0.4 --modules-folder www/js/packages/ handling the post-install-cmd event returned with error code 2
Script composer run-script post-install-cmd -d ./vendor/siu-toba/framework/ handling the post-install-cmd event returned with error code 2


Alguna idea de como resolverlo?
Desde ya muchas gracias! saludos

14
Técnicos / Dimensionamiento Server y BD para Guaraní 3.17
« on: Mayo 19, 2020, 09:12:03 am »
Buenos dias,
Estuve buscando información y encontré sobre los requerimientos para un servidor de tipo chico, mediano y grande. Mi pregunta es si se tiene alguna formula para:

Cantidad de conexiones recurrentes en Postgres para  dimensionar memoria del server de BD
Cantidad de conexiones recurrentes en Frontend para dimensionar memoria de servidor de Guarani
* Eso en cuanto a recursos de hardware, memoria puntualmente,  ya que se prevee un crecimiento del 100% anual en la cantidad de alumnos de la UNLC, y el tener dimensionado para este crecimiento nos puede ahorrar dolores de cabeza en el futuro.
 
Organización de carpetas y archivos del servidor linux  que contenga la base de datos de postgres
Organización de carpetas y archivos del servidor linux que contenga guaraní 
* Esto en cuanto a que por ejemplo tener diferenciado los archivos de  logs en otra unidad diferenciada  de la instalación de postgres, para evitar por ejemplo crecimiento de logs y que afecten al espacio del servidor y a la base de datos.

Para lo que es organización de las instalación en los linux, se entiende que la pregunta es si existen algunas propuestas de "buenas prácticas" provisto por SIU o por la experiencia de las personas que ya tienen un largo camino en este proyecto.

Desde ya muchas gracias!
Saludos desde San Luis :)
 

Páginas: [1]