Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - estebanv

Páginas: [1] 2
1
SUDOCU - Técnicos / Canal dedicado al lanzamiento de versiones
« on: Julio 05, 2021, 10:56:08 am »
Buenas,
Quería saber si es posible implementar un canal dedicado a la publicación de nuevas versiones de EEI. Por lo general solo me entero mirando el changelog de expedientes, pero no hay forma de que la notificación me llegue directamente.
Saludos, Esteban.

2
SUDOCU - Técnicos / Re:Tableros y herramientas de Monitoreo
« on: Julio 05, 2021, 10:53:25 am »
Nosotros estamos usando ELK. Pide bastante fierro, pero la solución es excelente, entre los beats y el driver de docker no se escapa nada. Las contras serian los requerimientos y la complejidad (tampoco tanto igual).
Saludos, Esteban.

3
Araí - Usuarios / Re:Desbloqueo masivo de usuarios
« on: Junio 30, 2021, 04:26:50 pm »
Hola Sergio,
La verdad no me parece coherente que por default estén todos los usuarios bloqueados, mas cuando se trata de miles de agentes. Cual seria el inconveniente? De esa forma cada cual puede gestionar su clave desde olvide mi contraseña. Yo creo que salvo que alguien específicamente lo desee, el estado de todos los nuevos usuarios importados debiera ser desbloqueado.
Volver a importar no es lo mas feliz para mi ahora, ya que acabo de hacerlo por que la versión 1.1.0 no le gustaban los símbolos en el identificador de la cuenta. Salvo que correr la importación una segunda vez solo actualice valores, en ese caso puede ser .
Yo creo que tendría que haber alguna clase de acción grupal para poder bloquear/desbloquear. También seria bueno otra acción que fuerce la regeneración de las claves de las personas en el grupo.
Saludos, Esteban.

4
Araí - Usuarios / Desbloqueo masivo de usuarios
« on: Junio 30, 2021, 11:12:03 am »
Buenas!
Bueno, simplemente eso, quería saber si existe alguna manera masiva de desbloquear usuarios, ya que es el estado que tienen por defecto después de la importación.
Otra cosa aparte: hay algún canal oficial donde publiquen la salida de nuevas versiones de EEI? Yo para no andar chequeando a mano el sitio de expedientes.
Saludos, Esteban.

5
SUDOCU - Técnicos / Re:Problemas con Autorizaciones post actualizacion
« on: Diciembre 03, 2020, 07:27:32 pm »
Hola,,
Agrego esto:
Cita
acceso { api: 'http://docs-api/docs/rest/backend',
  api_front: null,
  user: 'documentos',
  pass: 'docs123' }

Esa no es la pass que tenemos configurada en el secreto. La verifique desde adentro del contenedor.
Gracias.

6
Buenas!
Estamos probando el firmador siu (versión 1.0 desde el gdrive), lo instalamos y al querer ejecutarlo obtenemos la leyenda:

Código: [Seleccionar]
No se pudo obtener la solicitud de firma - verifique que no haya expirado o que ya haya sido firmada
Estamos probando en un windows 10 y en un ubuntu 20.04 con el jre de oracle version 1.8.0_261 y nos da el mismo error. Despues de esto la app se cierra sola.
Saludos, Esteban.

7
SIU - Huarpe / Re:Bundles SIU - Acceso al código y manuales de instalación
« on: Noviembre 06, 2020, 07:39:07 pm »
Hola Sergio,
Luego de configurar lo que sugerís, se arregló el error anterior pero apareció otro:
Código: [Seleccionar]
app.ERROR: Client error: `GET https://mapuche-pruebas3.unlu.edu.ar/siu6/mapuche/rest/agentes/2558` resulted in a `401 Unauthorized` response: {     "mensaje": "autenticaci\\ufffdn cancelada" }  [] [], referer: https://portal.unlu.edu.ar/perfilSi pruebo la url del get en un browser, me puedo autenticar con los datos que use en el archivo de configuración, así que la API de mapuche y los datos de conexión están bien.
Saludos, Esteban.

8
SUDOCU - Técnicos / Re:Sudocu api - error en deploy
« on: Noviembre 06, 2020, 12:44:48 pm »
Cambiando el valor
Código: [Seleccionar]
image: ungs/sudocu-api-server:1.0.12 por
Código: [Seleccionar]
image: ungs/sudocu-api-server:1.0.9  salio andando. ¿Es un bug esto o un problema de nuestra implementación?
Saludos, Esteban.

9
SUDOCU - Técnicos / Sudocu api - error en deploy
« on: Noviembre 06, 2020, 12:18:45 pm »
Buenas!
Estamos tratando de instalar sudocu usando el deploy docker/swarm. Levanta todo bien menos el sudocu_api-server. El contenedor muestra la leyenda:
Cita
Sudocu setup fail version_check_fail_mismatch_{"persisted":"1.0.9","pjson":"1.0.12"
Estamos usando la ultima versión de expedientes y relizamos todos los seteos indicados.

10
SIU - Huarpe / Re:Bundles SIU - Acceso al código y manuales de instalación
« on: Noviembre 04, 2020, 08:56:19 am »
Hola Sergio,
Gracias por la respuesta. Por lo que estuve viendo, es toda documentación desactualizada, osea que no sirve para el deploy usando docker y swarm. Para activar los bundles hay que hacer algo especifico? . o es alguna configuración indirecta? (setear alguna variable del env), Nosotros tenemos instalada la version 2.2.6 de huarpe y lo único que veo es una bandeja de entrada en el menu.
Gracias, Esteban.

11
Buenas!
Estamos queriendo instalar los distintos bundles que tiene el SIU para Huarpe (diaguita, mapuche, etc). Estuve buscando tanto la documentación como el código y no pude encontrar nada.
Saludos, Esteban.

12
Hola Esteban,
El problema era el atributo full_url al final.  Claramente los sp's toba están armando los endpoints para saml usando esa url.

consulta.. la instalacion de Pilaga que mencionas estaba en docker o era manual?.





Instalación  manual Richard.
Abrazo

13
El problema era el atributo full_url al final.  Claramente los sp's toba están armando los endpoints para saml usando esa url. Cambiando eso junto con limpieza de caches y demás, salio todo andando. Quizás estaría bueno aclararlo en la [url]documentación de integración con pilaga[https://expedientes.siu.edu.ar/docs/pilaga/]. Otra cosa que vi es que se indica que el nombre de la aplicación, a la hora de registrarla como SP sea 'pilaga' y el comando exportación de cuentas de usuario de una instalación standart de pilaga esta usando 'SIU-Pilagá'. Si se quiere importar cuentas así, nunca matchean.
Saludos.

14
Hola Sergio,
Como te comentaba en el primer post, seguí la guía al pie de la letra, la pestaña de configuración de SAML de la aplicación dada de alta muestra lo siguiente:

Código: [Seleccionar]
{
   "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/default-sp": {
      "AssertionConsumerService": "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/?acs",
      "SingleLogoutService": "https://pruebaspilaga.unlu.edu.ar/pilaga_portal/?sls"
   }
}

Esa aplicación la cree y borre varias veces de hecho, con el mismo resultado. Otra prueba que hice fue la de borrarla y no cargarla y el error sigue siendo el mismo, puede ser que sea algo mal configurado en el SP? Cuando se instalo por primera vez estaba mal configurado el parametro full_url y encontre el mismo string (http://localhost/pilaga_portal/) en algunos logs locales de pilaga que no estaban relacionados directamente, pero fueron los únicos que encontré. Cambie el parametro full_url que esta en el instancia.ini, pero sigue siendo lo mismo.
Avisame si necesitas que te suba algo.
Gracias.

15
Buenas!

Estamos integrando las 2 aplicaciones a nuestra instalación de Arai. Seguimos los pasos del instructivo en https://expedientes.siu.edu.ar/docs/pilaga/, verificamos que los archivos de instancia y el de saml:onelogin esten bien, pero nos aparece la pantalla: Ocurrio un error.
En los logs del IPD tengo la siguiente leyenda:
Código: [Seleccionar]
[Thu Oct 29 13:10:45.117433 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] SimpleSAML\\Error\\MetadataNotFound: METADATANOTFOUND('%' => '\\'http://localhost/pilaga_portal/default-sp\\'')
[Thu Oct 29 13:10:45.117495 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] Backtrace:
[Thu Oct 29 13:10:45.117515 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 3 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:340 (SimpleSAML\\Metadata\\MetaDataStorageHandler::getMetaData)
[Thu Oct 29 13:10:45.117532 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 2 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/lib/SimpleSAML/Metadata/MetaDataStorageHandler.php:360 (SimpleSAML\\Metadata\\MetaDataStorageHandler::getMetaDataConfig)
[Thu Oct 29 13:10:45.117548 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 1 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/modules/saml/lib/IdP/SAML2.php:380 (SimpleSAML\\Module\\saml\\IdP\\SAML2::receiveAuthnRequest)
[Thu Oct 29 13:10:45.117565 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] 0 /usr/local/app/idp/vendor/simplesamlphp/simplesamlphp/www/saml2/idp/SSOService.php:21 (N/A)
[Thu Oct 29 13:10:45.117614 2020] [php7:notice] [pid 35] [client 10.0.3.23:34732] simplesamlphp ERR [27bbda7e1e] Error report with id 3a90b9c3 generated.
10.0.3.23 - - [29/Oct/2020:13:10:45 -0300] "GET /idp/saml2/idp/SSOService.php?SAMLRequest=hVNdb9owFH3nV6C8Qz4GlFqQKYN9IDGISLqHvVS3zqVEcmzPHyv993PidGVVxfzi6Pqe43OObxYaGiZJZs2JH%2FCXRW0GQ7fODeOadIfLwCpOBOhaEw4NamIoKbLvW5KMIyKVMIIKFryBXUeB1qhMLbiHbdbLYL%2F7vN1%2F3ezuj0kC83kyo5MJhWmMH25uZtVDNKmSGG6PFY3oFLEC6qE%2FUGnHswwcbTDwbFpb3HBtgBtXj5JoFEej5LaMZySek2ny00PXzmzNwXTwkzFSkzCUQhlgY8uZHWNlx6DCupJhaynpvopiX6D6XVMcy5P0THkfwqeaVzV%2FvO79wTdp8q0s81G%2BL0pPkr1kshJc2wZVf83dYevlOXVMUGAnoU0oawaPcO%2Flhh%2BB6iDtaBatVNJloNL%2FwCo8gmVmpOUivIS9EkmycwY261ywmj539XZ9EaoBF25PcOeUZ5QKy03wtydjTDytFILBZWCUxWAY%2FsPczxtW3fQ51wbPZrgSjQRV6%2FZR8AzU9L5evV22r5gbpQMe06vTRglt%2B1w5d9uTUFX7Ykjd3aUCrts4%2BgTeJfeqwyuy08HL8eWvlP4B&RelayState=https%3A%2F%2Fpruebaspilaga.unlu.edu.ar%2Fpilaga_portal%2F HTTP/1.1" 302 772
 

Me imagino que el problema es;  ERR [27bbda7e1e] SimpleSAML\\Error\\MetadataNotFound: METADATANOTFOUND('%' => '\\'http://localhost/pilaga_portal/default-sp\\'')
El tema es que no tengo esa URL así en ningún lado. Hay alguna forma de debuggear mejor?
Gracias.

Páginas: [1] 2