Mostrar Mensajes

Esta sección te permite ver todos los mensajes hechos por este usuario, recuerda que solo puedes ver los mensajes en áreas en donde tu tienes acceso.


Mensajes - Rodrigo Miranda [SIU]

Páginas: [1] 2 3 ... 11
1
SIU-Kolla - Técnicos / Re:Vincular datos de guarani con kolla
« on: Agosto 12, 2022, 11:08:16 am »
Federico, si accedés a la consola swagger mediante la url

Código: [Seleccionar]
https://157.92.115.35/rest
Con el usuario que definiste en la configuración del archivo cliente.ini de Guaraní

Código: [Seleccionar]
ue_g3
Y vas al endpoint

Código: [Seleccionar]
https://157.92.115.35/rest/unidad-gestion
que respuesta obtenés?.

2
SIU-Tehuelche - Técnicos / Re:cURL error 60 SSL certificate problem
« on: Agosto 08, 2022, 01:28:48 pm »
Al parecer tienen un problema con la configuración de la cadena de certificados. Podrías chequear esto junto a la gente de IT de la institución para poder resolverlo?.

Pueden chequear que certificado está enviando el servidor en este enlace https://whatsmychaincert.com/?guarani.unju.edu.ar

3
SIU-Tehuelche - Técnicos / Re:cURL error 60 SSL certificate problem
« on: Agosto 05, 2022, 11:05:05 am »
Hola Alfredo, creo que se trata de un problemas de certificados. Acá hay algo de info al respecto https://foro.comunidad.siu.edu.ar/index.php?topic=11192.msg48444#msg48444

Probablemente tenga que ver con la forma en la que se instaló curl. Si lo descargaste vía repos (con apt por ejemplo), las configuraciones adicionales dejan los certificados donde corresponden. De otro modo si lo compilaste por ejemplo, es probable que esté faltando algún ajuste adicional. Podrías chequear por ese lado.

Está actualizado el sistema operativo?.

4
SIU-Kolla - Técnicos / Re:Vincular datos de guarani con kolla
« on: Agosto 02, 2022, 10:54:57 am »
Hola Federico, con respecto a este error

Cita
ago 01 13:50:36 KOLLA-TEST apachectl[1217]: Invalid command 'RewriteEngine', perhaps misspelled or defined by a module not included in the server configuration

Falta habilitar el módulo mod_rewrite de Apache.

Código: [Seleccionar]
sudo a2enmod rewrite
Luego reiniciar Apache.

5
Becas / Re:Error al sincronizar
« on: Julio 29, 2022, 01:03:00 pm »
Que versión de Guaraní tenían anteriormente?

6
Becas / Re:Error al sincronizar
« on: Julio 29, 2022, 12:31:35 pm »
Caro, revisa bien en detalle el instructivo que te pasé. No tenés que agregar nada nuevo sino modificar lo existente.

7
Becas / Re:Error al sincronizar
« on: Julio 29, 2022, 11:57:18 am »
Caro, te pido que hagas una modificación en el método validar_datos_censales del archivo:

Código: [Seleccionar]
php/nucleo/convocatorias/procesador_ws_convocatoria_aspirantes.php
Tenés que reemplazar la siguiente línea:

Código: [Seleccionar]
if ($pos === false) {
por ésta otra:

Código: [Seleccionar]
if (!$dato_censal['es_dependiente'] && $pos === false) {
Además te pido que reemplaces el método es_censal_dependiente en el archivo:

Código: [Seleccionar]
php/nucleo/convocatorias/consultas_convocatorias.php
por este otro

Código: [Seleccionar]
public function es_censal_dependiente($dato_censal)
    {
        $id = toba::db()->quote($dato_censal);

        $sql = "SELECT  COUNT(dato_censal_padre) AS tiene_padre
                FROM    sg_dato_censal_dep sdcd
                WHERE   sdcd.dato_censal_hijo = $id";
       
        $res = toba::db()->consultar_fila($sql);
       
        return $res['tiene_padre'] != 0;
    }

Y que intentes nuevamente la sincronización.




8
Becas / Re:Error al sincronizar
« on: Julio 29, 2022, 10:11:08 am »
Te voy a pedir que edites el método validar_datos_censales del archivo:

Código: [Seleccionar]
php/nucleo/convocatorias/procesador_ws_convocatoria_aspirantes.php
Y agregues lo siguiente un código para dumpear los valores de los datos censales que se traen en la solicitud del aspirante y los que tiene la convocatoria:

Código: [Seleccionar]
function validar_datos_censales($datos_censales, $datos_censales_convocatoria)
    {
        //$datos_censales son los datos censales del aspirante recibidos en la solicitud + el id en tehue + si es dependiente o no
        //$datos_censales_convocatoria son los datos censales conocidos por tehuelche (arreglo de ids)
        toba::logger()->info('Censales Aspirante');
        toba::logger()->error($datos_censales);
        toba::logger()->info('Censales Convocatoria');
        toba::logger()->error($datos_censales_convocatoria);

Luego intentá nuevamente la sincronización y revisá el siguiente archivo en busca de que datos censales está recibiendo desde guaraní y cuáles son los de la convocatoria. Adjuntanos este archivo así podemos revisarlo.

Código: [Seleccionar]
instalacion/i__produccion/p__tehuelche/logs/sistema.log

9
Becas / Re:Error al sincronizar
« on: Julio 28, 2022, 11:45:21 am »
En que momento obtenés este error?. Podrías adjuntarme pantallas de la operación? Si los datos son los mismos no debería darte este error porque la comparación se hace con los valores definidios en el campo dato_censal. Si son exactamente los mismos, esto no debería pasar. Podrías adjuntar el resultado de esa SQL y también una captura de los datos censales definidos en Guaraní?.

10
Becas / Re:Error al sincronizar
« on: Julio 28, 2022, 10:35:33 am »
Hola Carolina, como primera medida te pediría que revises en Tehuelche, que datos censales se trajeron en la primera sincornización de la convocatoria. Vas a necesitar el ID de la convocatoria para ejecutar la siguiente consulta en la base de Tehuelche (reemplazando $ID por el ID de la convocatoria con la que tenés problemas):

Código: [Seleccionar]
SET search_path TO tehuelche;
SELECT  dato_censal,
campo,
descripcion
FROM    mgb_convocatoria_dato_censal
NATURAL JOIN sg_dato_censal
WHERE   mgb_convocatoria_dato_censal.convocatoria = $ID;

El resultado de la consulta deberías compararlo con los datos censales definidos en Guaraní.

El error que se ve en pantalla indica que hay una diferencia entre estos datos censales y necesitamos saber que fue lo que pasó ya que la sincronización inicial te trae todos estos datos. De ahí en más, si el relevamiento entró en vigencia, quedan fijos y no se pueden editar.

11
SIU-Kolla - Técnicos / Re:Error al actualizar Kolla 4.3.2 a 4.7.1
« on: Julio 19, 2022, 10:06:58 am »
Perfecto, esos warnings son solo advertencias que te indican que algunos títulos cambiaron de nombre. Es simplemente para que estén al tanto.

12
SIU-Kolla - Técnicos / Re:Error al actualizar Kolla 4.3.2 a 4.7.1
« on: Julio 19, 2022, 09:30:36 am »
Bien Estela, gracias por la info sobre la versión en la que arracaron. Te cuento que según el instalador ya sortearon el primer error, eso es una buena noticia. Para el que tienen ahora les paso la siguiente sql que deben aplicar en la base antes de volver a a intentar la actualización.

Código: [Seleccionar]
BEGIN;
SET client_encoding TO LATIN1;
INSERT INTO kolla.mug_dptos_partidos (dpto_partido, nombre, provincia, estado) VALUES ( 5498000, 'Jurisdicción Federal de la Republica Argentina', 5498, 'A' );
COMMIT;

Por lo tanto van a tener que levantar el backup que tenían, utilizar el parche del php que le pasé anteriormente y antes de actualizar aplicar este parche en la base de kolla.

En cuanto al código de Kolla, un tip para la actualización es que para volver a intentarla (además de restaurar el backup de la base) deben simplemente eliminar este directorio:

Código: [Seleccionar]
/usr/local/kolla470/4.7.1/instalacion

13
SIU-Kolla - Técnicos / Re:Error al actualizar Kolla 4.3.2 a 4.7.1
« on: Julio 18, 2022, 11:32:00 am »
Hola Estela, contame cuál fue la primera versión de Kolla que instalaron. Es fundamental saber esto porque creo que tiene que ver con esto el error que tienen actualmente.

Más allá de eso, según el log veo que el archivo que envié no fue reemplazado porque se está intentando ejecutar la misma SQL que el primer error. Podrían chequear que el contenido y el nombre del archivo que les envié sea el correcto?

14
SIU-Kolla - Técnicos / Re:Error al actualizar Kolla 4.3.2 a 4.7.1
« on: Julio 15, 2022, 10:06:15 pm »
Hola María. Según veo en el log lo que está fallando son sentencias DROP a funciones que no existen. Consulta, la primera versión de Kolla que instalaron fue la 4.3.2? O vienen desde alguna más vieja?. Más allá de eso te paso el parche para poder continuar con la actualización. Renombra este archivo (por ejemplo kolla_migracion_4_4_0.php.old)  y reemplazalo por el que te adjunto:

Código: [Seleccionar]
php/modelo/migraciones/kolla_migracion_4_4_0.php
Tené en cuenta que para volver a intentar la actualización tenés que restaurar el backup de la base de Kolla ya que durante el proceso de instalación se rompe.

Cualquier duda nos escribís.

15
SIU-Kolla - Técnicos / Re:Anonimización de base de datos
« on: Julio 15, 2022, 01:58:04 pm »
Bárbaro Fernando. Gracias!.

Páginas: [1] 2 3 ... 11