Autor Tema: [SOLUCIONADO] UNPA_Consulta sobre instalación de arai 2.0  (Leído 492 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pvidal

  • Sr. Member
  • ****
  • Mensajes: 341
    • Ver Perfil
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Paola Beatriz Vidal
  • Sistema: SIU-Mapuche, SIU-Pilaga
  • Teléfono laboral: 0297-4854888 int. 114
[SOLUCIONADO] UNPA_Consulta sobre instalación de arai 2.0
« on: Diciembre 03, 2018, 11:07:18 am »
Buenos dias,
El motivo del presente surge por lo siguiente. Actualmente nos encontramos en la versión 3.1.4 de pilaga, 2.5.0 de diaguita y 1.1.0 de arai. Hemos instalado arai para sincronizar los proveedores entre los sistemas Pilaga y Diaguita. Pero NO tenemos funcionando la plataforma completa de Arai. Solo proveedores.
Ahora bien, dado a que tenemos que actualizar pilaga a la versión 3.2.3, para poder hacer el cierre de ejercicio, cuando se está ejecutando el actualizador, nos sale un error. Esto es porque arai está corriendo bajo postgres 9.1, y no soporta la sentencia IF NOT EXITS mientras se está creando un esquema.

Para poder finalizar la actualización de pilaga, pegamos nuestra carpeta arai instalada en la v1.1.0 en un server de prueba, que tiene postgres 9.4. Y asi funciono.

Dado a que se nos presentaron varios inconvenientes debido a la diferencias de versiones porque arai v1.1.0, utiliza versiones muy viejas de sw, es que necesitamos actualizar a la versión 2.0, la cual corre sobre versiones de postgres, apache y php más actuales.

El tema es que solo necesitamos el catalogo de proveedores. La versión de arai 1.1.0 traía un instalador web. En la versión 2.0 hay uno disponible o como hacemos para actualizar?


Desde ya muchas gracias!

Saludos
Paola
UNPA

« Última Modificación: Diciembre 26, 2018, 02:38:57 pm por Sergio F. Vier »

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 788
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:UNPA_Consulta sobre instalación de arai 2.0
« Respuesta #1 on: Diciembre 26, 2018, 02:34:23 pm »
Hola Paola, voy respondiendo por partes.

Buenos dias,
El motivo del presente surge por lo siguiente. Actualmente nos encontramos en la versión 3.1.4 de pilaga, 2.5.0 de diaguita y 1.1.0 de arai. Hemos instalado arai para sincronizar los proveedores entre los sistemas Pilaga y Diaguita. Pero NO tenemos funcionando la plataforma completa de Arai. Solo proveedores.

Y aquí está la gran diferencia. Lo que nosotros llamamos SIU-Araí se refiere a la plataforma en general (el login centralizado con la gestión de usuarios, componentes usuarios, registry, huarpe) y es lo que está en la versión 2.0, 2.1, etc.

En cambio, la parte de sincronización de proveedores se conoció al principio como SIU-Araí Proveedores y está todo este esquema de instalación basado en una base intermedia, versiones 1.0 y 1.1 si mal no recuerdo. Ahora están en la nueva versión 1.2.3 que ya viene integrado los scripts con los instaladores de Diaguita/Pilagá. Esto es muy muy distinto a la "plataforma SIU-Araí".

Ahora bien, dado a que tenemos que actualizar pilaga a la versión 3.2.3, para poder hacer el cierre de ejercicio, cuando se está ejecutando el actualizador, nos sale un error. Esto es porque arai está corriendo bajo postgres 9.1, y no soporta la sentencia IF NOT EXITS mientras se está creando un esquema.

Para poder finalizar la actualización de pilaga, pegamos nuestra carpeta arai instalada en la v1.1.0 en un server de prueba, que tiene postgres 9.4. Y asi funciono.

Dado a que se nos presentaron varios inconvenientes debido a la diferencias de versiones porque arai v1.1.0, utiliza versiones muy viejas de sw, es que necesitamos actualizar a la versión 2.0, la cual corre sobre versiones de postgres, apache y php más actuales.

El tema es que solo necesitamos el catalogo de proveedores. La versión de arai 1.1.0 traía un instalador web. En la versión 2.0 hay uno disponible o como hacemos para actualizar?

Te recomiendo que lo posteen acá http://foro.comunidad.siu.edu.ar/index.php?board=57.0, es un subforo de SIU-Araí dedicado a lo de catálogos y proveedores. Ahí están los post con la info sobre requerimientos y demás.

Saludos!
happy coding!!