Autor Tema: Actualizar 3.1.5 a 3.2.3 Errores  (Leído 464 veces)

0 Usuarios y 1 Visitante están viendo este tema.

nbaglietto

  • Jr. Member
  • **
  • Mensajes: 62
    • Ver Perfil
  • Institución: Espacio para la memoria
  • Nombre y apellido: Nahuel Baglietto
  • Sistema: comdoc diaguita pilaga
  • Teléfono laboral: 47029920
  • Utilizo algun sistéma del SIU: Sí
Actualizar 3.1.5 a 3.2.3 Errores
« on: Diciembre 12, 2018, 04:55:36 pm »
Tengo una duda es posible actualizar pilaga 3.1.5 a 3.2.3? es necesario actualizar php? yo en el mismo entorno tengo funcionando pilaga diaguita, toba , arai proveedores. Todas estas versiones trabajaran con php 7> ?

Gracias

Aca paso el resultado de los comando:


root@pilaga:/var/www/SIU-Pilaga_3.2.3# ./bin/instalador proyecto:actualizar --instalacion-anterior /var/www/siu/
Error, no se ejecuto el comando 'composer install'
root@pilaga:/var/www/SIU-Pilaga_3.2.3# composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for siu/api-afip v1.0.0 -> satisfiable by siu/api-afip[v1.0.0].
    - siu/api-afip v1.0.0 requires ext-soap * -> the requested PHP extension soap is missing from your system.
  Problem 2
    - Installation request for symfony/config v4.1.6 -> satisfiable by symfony/config[v4.1.6].
    - symfony/config v4.1.6 requires php ^7.1.3 -> your PHP version (5.6.38) does not satisfy that requirement.
  Problem 3
    - Installation request for myclabs/deep-copy 1.8.1 -> satisfiable by myclabs/deep-copy[1.8.1].
    - myclabs/deep-copy 1.8.1 requires php ^7.1 -> your PHP version (5.6.38) does not satisfy that requirement.
  Problem 4
    - Installation request for phpdocumentor/reflection-docblock 4.3.0 -> satisfiable by phpdocumentor/reflection-docblock[4.3.0].
    - phpdocumentor/reflection-docblock 4.3.0 requires php ^7.0 -> your PHP version (5.6.38) does not satisfy that requirement.
  Problem 5
    - Installation request for phpunit/php-token-stream 2.0.2 -> satisfiable by phpunit/php-token-stream[2.0.2].
    - phpunit/php-token-stream 2.0.2 requires php ^7.0 -> your PHP version (5.6.38) does not satisfy that requirement.
  Problem 6
    - symfony/config v4.1.6 requires php ^7.1.3 -> your PHP version (5.6.38) does not satisfy that requirement.
    - robmorgan/phinx 0.10.6 requires symfony/config ^2.8|^3.0|^4.0 -> satisfiable by symfony/config[v4.1.6].
    - Installation request for robmorgan/phinx 0.10.6 -> satisfiable by robmorgan/phinx[0.10.6].

  To enable extensions, verify that they are enabled in those .ini files:
    - /etc/php/5.6/cli/php.ini
    - /etc/php/5.6/cli/conf.d/10-opcache.ini
    - /etc/php/5.6/cli/conf.d/10-pdo.ini
    - /etc/php/5.6/cli/conf.d/15-xml.ini
    - /etc/php/5.6/cli/conf.d/20-calendar.ini
    - /etc/php/5.6/cli/conf.d/20-ctype.ini
    - /etc/php/5.6/cli/conf.d/20-curl.ini
    - /etc/php/5.6/cli/conf.d/20-dom.ini
    - /etc/php/5.6/cli/conf.d/20-exif.ini
    - /etc/php/5.6/cli/conf.d/20-fileinfo.ini
    - /etc/php/5.6/cli/conf.d/20-ftp.ini
    - /etc/php/5.6/cli/conf.d/20-gd.ini
    - /etc/php/5.6/cli/conf.d/20-gettext.ini
    - /etc/php/5.6/cli/conf.d/20-iconv.ini
    - /etc/php/5.6/cli/conf.d/20-json.ini
    - /etc/php/5.6/cli/conf.d/20-mbstring.ini
    - /etc/php/5.6/cli/conf.d/20-mcrypt.ini
    - /etc/php/5.6/cli/conf.d/20-pdo_pgsql.ini
    - /etc/php/5.6/cli/conf.d/20-pgsql.ini
    - /etc/php/5.6/cli/conf.d/20-phar.ini
    - /etc/php/5.6/cli/conf.d/20-posix.ini
    - /etc/php/5.6/cli/conf.d/20-readline.ini
    - /etc/php/5.6/cli/conf.d/20-shmop.ini
    - /etc/php/5.6/cli/conf.d/20-simplexml.ini
    - /etc/php/5.6/cli/conf.d/20-sockets.ini
    - /etc/php/5.6/cli/conf.d/20-sysvmsg.ini
    - /etc/php/5.6/cli/conf.d/20-sysvsem.ini
    - /etc/php/5.6/cli/conf.d/20-sysvshm.ini
    - /etc/php/5.6/cli/conf.d/20-tokenizer.ini
    - /etc/php/5.6/cli/conf.d/20-wddx.ini
    - /etc/php/5.6/cli/conf.d/20-xmlreader.ini
    - /etc/php/5.6/cli/conf.d/20-xmlwriter.ini
    - /etc/php/5.6/cli/conf.d/20-xsl.ini
    - /etc/php/5.6/cli/conf.d/20-zip.ini
  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.

msastre

  • Moderador Global
  • *****
  • Mensajes: 153
    • Ver Perfil
  • Institución: Sistema de Información Universitaria (SIU)
  • Nombre y apellido: Mariana Sastre
  • Sistema: SIU-Pilagá
Re:Actualizar 3.1.5 a 3.2.3 Errores
« Respuesta #1 on: Diciembre 14, 2018, 10:15:55 am »
Hola, no hay inconveniente para actualizar el php a 7.1 ya que SIU-Diaguita 2.5 y SIU-Pilaga  3.2.3 funcionan sin problema.
Saludos
Mariana
Mariana Sastre
Equipo SIU-Pilagá
Sistema de Información Universitaria (SIU)
Teléfono: +54 11 5217-3101
Web: http://www.siu.edu.ar