Autor Tema: [SOLUCIONADO] Problemas al instalar arai-usuarios - LDAP  (Leído 512 veces)

0 Usuarios y 1 Visitante están viendo este tema.

iluthje

  • Newbie
  • *
  • Mensajes: 34
    • Ver Perfil
    • Email
  • Institución: UNIPE (Universidad Pedagógica Nacional)
  • Nombre y apellido: Ivan Luthje
  • Sistema: Pilagá-Diaguita-Mapuche
  • Teléfono laboral: (011)4307-7500
  • Utilizo algun sistéma del SIU: Sí
[SOLUCIONADO] Problemas al instalar arai-usuarios - LDAP
« on: Marzo 14, 2019, 12:21:11 pm »
Hola, estoy teniendo un inconveniente con openldap al instalar arai-usuarios en una maquina virtual. Me salta un error de invalid credentials y al reconfigurar el servicio de slapd me salta otro error que me informa que no puede conectarse al servidor.  Saludos
« Última Modificación: Marzo 22, 2019, 03:15:36 pm por Sergio F. Vier »

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 788
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Problemas al instalar arai-usuarios
« Respuesta #1 on: Marzo 18, 2019, 02:09:31 pm »
Hola Ivan,

La instalación de OpenLdap depende mucho del S.O. y la versión que utilicen.  En un debian 9 yo estuve realizando los pasos mas o menos así:
Código: [Seleccionar]
sudo apt install slapd ldap-utils
# configuracion inicial, dc=unx,dc=edu,dc=ar
sudo dpkg-reconfigure slapd

# convertir y copiar schemas para estructura de ldap
# ver https://wiki.debian.org/LDAP/OpenLDAPSetup#For_SAMBA_LDAP_support
sudo scp cn=\{* "/etc/ldap/slapd.d/cn=config/cn=schema"

sudo chown openldap:openldap "/etc/ldap/slapd.d/cn=config/cn=schema" -R

sudo service slapd restart

# test schemas cargados
ldapsearch -LLLQY EXTERNAL -H ldapi:/// -b cn=schema,cn=config "(objectClass=olcSchemaConfig)" dn

# cargar estructura arai-usuarios
ldapadd -x -W -D "cn=admin,dc=unx,dc=edu,dc=ar" -f estructura-arai-usuarios.ldif

# test que todo se haya cargado
ldapsearch -x -W -D "cn=admin,dc=unx,dc=edu,dc=ar" -b "dc=unx,dc=edu,dc=ar"

Espero te sea de utilidad, slapd es "especial" y van a tener que aprender a trabajar con él y sus mañas.
happy coding!!

iluthje

  • Newbie
  • *
  • Mensajes: 34
    • Ver Perfil
    • Email
  • Institución: UNIPE (Universidad Pedagógica Nacional)
  • Nombre y apellido: Ivan Luthje
  • Sistema: Pilagá-Diaguita-Mapuche
  • Teléfono laboral: (011)4307-7500
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas al instalar arai-usuarios
« Respuesta #2 on: Marzo 20, 2019, 09:19:44 am »
Muchas gracias Sergio, seguí todos los pasos y funcionó correctamente. Saludos