Autor Tema: [SOLUCIONADO] Error generar key "paragonie/halite" (apache 2.4 y php 7.2.19)  (Leído 510 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pblanco

  • General Mapuche
  • *
  • Mensajes: 36
    • Ver Perfil
  • Institución: UNR
  • Nombre y apellido: Pablo J. Blanco
  • Sistema: Toba
  • Teléfono laboral: 0341-4201245
Estimados, estoy teniendo problemas al generar key y registrar un proyecto
  • La instalacion de toba se realizo con  apache 2.4 y php 2.7.19

  • El archivo composer.json tiene lo siguiente entre otras cosas

    "require": {
        "siu-toba/framework": "3.2.2",
       "siu/arai-cli": "^2.5.0"
      },
    "autoload": {
        "psr-4": { "": "src" }
      }


  • al correr el comando "arai-cli arai:generar-key" arroja el siguiente error

    C:\weme\bin>arai-cli arai:generar-key --destino "C:\weme"
    Se requiere la librería "paragonie/halite" para poder utilizar AraiCrypto

  • Se modifica el archivo composer .json agregando esa libreria (Segun la version de php instalada debe ir con la version ^4)
    "require": {
        "siu-toba/framework": "3.2.2",
       "siu/arai-cli": "^2.5.0",
       "paragonie/halite": "^4"
      }

  • Al correr composer update arroja el siguiente error

    C:\weme\bin>composer update
    No composer.json in current directory, do you want to use the one at C:\weme? [Y,n]? y
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - Conclusion: remove siu/arai-cli v2.7.2
        - Conclusion: don't install siu/arai-cli v2.7.2
        - Conclusion: don't install siu/arai-cli v2.7.1
        - Conclusion: don't install siu/arai-cli v2.7.0
        - Conclusion: don't install siu/arai-cli v2.6.2
        - Conclusion: don't install siu/arai-cli v2.6.1
        - Installation request for paragonie/halite ^4 -> satisfiable by paragonie/halite[v4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.x-dev, v4.1.0, v4.2.0, v4.3.0, v4.3.1, v4.4.0, v4.4.1, v4.4.2, v4.5.0, v4.5.1, v4.5.2, v4.5.3].
        - Conclusion: don't install siu/arai-cli v2.6.0
        - siu/arai-cli v2.5.0 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - siu/arai-cli v2.5.1 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - siu/arai-cli v2.5.2 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - Conclusion: don't install siu/arai-json-parser v2.0.0
        - Installation request for siu/arai-cli ^2.5.0 -> satisfiable by siu/arai-cli[v2.7.2, v2.5.0, v2.5.1, v2.5.2, v2.6.0, v2.6.1, v2.6.2, v2.7.0, v2.7.1].


Podrian ayudarnos a ver cual es el problema ?
« Última Modificación: Septiembre 16, 2019, 12:02:11 pm por Sergio F. Vier »

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 788
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Error generar key "paragonie/halite" (apache 2.4 y php 7.2.19)
« Respuesta #1 on: Junio 25, 2019, 08:23:16 am »
Buenos días Pablo,

Perdón por la demora, se me pasó este post totalmente.

Vamos por partes. En esta página están los requerimientos actuales de la plataforma SIU-Araí. Así como las versiones compatibles de los componentes. En particular, tienen que tener en cuenta esta librería Sodium. Tiene requerimientos estrictos de compatibilidad.

Por establecer el soporte a versiones previas de PHP, estamos todavía atados a una versión de la libería Halite que no es compatible con PHP 7.2. Esperamos a fin de año tener todo en lugar para realizar la transición y evitar dicha dependencia de Halite totalmente.

Saludos
happy coding!!