Autor Tema: Instalacion toba 3.2 - problemas con arai  (Leído 581 veces)

0 Usuarios y 1 Visitante están viendo este tema.

pblanco

  • General Mapuche
  • *
  • Mensajes: 40
    • Ver Perfil
  • Institución: UNR
  • Nombre y apellido: Pablo J. Blanco
  • Sistema: Toba
  • Teléfono laboral: 0341-4201245
Instalacion toba 3.2 - problemas con arai
« on: Junio 06, 2019, 08:55:17 am »
Estimados, estoy teniendo problemas al generar key y registrar un proyecto luego de la instalacion de toba 3.2.2
  • La instalacion de toba se realizo con  apache 2.4 y php 7.2.19

  • El archivo composer.json tiene lo siguiente entre otras cosas

    "require": {
        "siu-toba/framework": "3.2.2",
       "siu/arai-cli": "^2.5.0"
      },
    "autoload": {
        "psr-4": { "": "src" }
      }


  • al correr el comando "arai-cli arai:generar-key" arroja el siguiente error

    C:\weme\bin>arai-cli arai:generar-key --destino "C:\weme"
    Se requiere la librería "paragonie/halite" para poder utilizar AraiCrypto

  • Se modifica el archivo composer .json agregando esa libreria (Segun la version de php instalada debe ir con la version ^4)
    "require": {
        "siu-toba/framework": "3.2.2",
       "siu/arai-cli": "^2.5.0",
       "paragonie/halite": "^4"
      }

  • Al correr composer update arroja el siguiente error

    C:\weme\bin>composer update
    No composer.json in current directory, do you want to use the one at C:\weme? [Y,n]? y
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

      Problem 1
        - Conclusion: remove siu/arai-cli v2.7.2
        - Conclusion: don't install siu/arai-cli v2.7.2
        - Conclusion: don't install siu/arai-cli v2.7.1
        - Conclusion: don't install siu/arai-cli v2.7.0
        - Conclusion: don't install siu/arai-cli v2.6.2
        - Conclusion: don't install siu/arai-cli v2.6.1
        - Installation request for paragonie/halite ^4 -> satisfiable by paragonie/halite[v4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.x-dev, v4.1.0, v4.2.0, v4.3.0, v4.3.1, v4.4.0, v4.4.1, v4.4.2, v4.5.0, v4.5.1, v4.5.2, v4.5.3].
        - Conclusion: don't install siu/arai-cli v2.6.0
        - siu/arai-cli v2.5.0 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - siu/arai-cli v2.5.1 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - siu/arai-cli v2.5.2 requires siu/arai-json-parser ~2.0 -> satisfiable by siu/arai-json-parser[v2.0.0].
        - Conclusion: don't install siu/arai-json-parser v2.0.0
        - Installation request for siu/arai-cli ^2.5.0 -> satisfiable by siu/arai-cli[v2.7.2, v2.5.0, v2.5.1, v2.5.2, v2.6.0, v2.6.1, v2.6.2, v2.7.0, v2.7.1].


Podrian ayudarnos a ver cual es el problema ?
« Última Modificación: Junio 06, 2019, 09:30:14 am por pblanco »

richard

  • Moderador Global
  • *****
  • Mensajes: 3064
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Instalacion toba 3.2 - problemas con arai
« Respuesta #1 on: Junio 06, 2019, 10:32:26 am »
Hola Pablo,

el problema es la version de PHP en ppio y como consecuencia de ello la version de Halite.

Si te fijas en el composer.json de arai-cli, vas a ver que para dev esta requiriendo la version 1.6.0 de Halite... esa es la version que deberias estar poniendo en tu .json .

El problema con esa version es que requiere de una version especifica de sodium, que se puede instalar hasta PHP 7.1... mi  consejo seria :

 -  downgrade a PHP 7.1.30
 -  reinstall de sodium
 - agregar halite 1.6.0 a composer.json y  composer update

Con eso deberias tener solucionado el tema de halite para generar la key, igual creo que en esa version de cli podes elegir el backend por defecto que usa, seleccionate SODIUM.

Saludos
« Última Modificación: Junio 06, 2019, 10:41:14 am por richard »
Twitter es al incontinente verbal,  lo que los dulces al diabetico.