Autor Tema: [SOLUCIONADO] Error al registrar arai usuarios  (Leído 418 veces)

0 Usuarios y 1 Visitante están viendo este tema.

salegria

  • Jr. Member
  • **
  • Mensajes: 54
    • Ver Perfil
  • Institución: UNNE
  • Nombre y apellido: Sergio Alegría
  • Utilizo algun sistéma del SIU: Sí
[SOLUCIONADO] Error al registrar arai usuarios
« on: Septiembre 11, 2019, 11:16:21 am »
buenas, tengo un problema al querer resgistrar arai-usuarios en registry.

root@arai:/usr/local/siu/usuarios# ./bin/arai-cli registry:add --maintainer-email  hluque@unne.edu.ar --maintainer hluque http://registry.unne.local/arai-registry
Detectando proveedores de servicio 'service:siu/sso-saml-idp': 1
Procesando proveedor 'service:siu/sso-saml-idp': configurado con 'http://usuarios.unne.edu.ar/idp/saml2/idp/metadata.php'
Detectando proveedores de servicio 'app:siu/huarpe': 0
Detectando clientes de api 'api:siu/arai-usuarios': 0
SQL ERROR: SQLSTATE[42P01]: Undefined table: 7 ERROR:  no existe la relación «aplicaciones»
LINE 1: UPDATE aplicaciones SET inactiva = 1 WHERE 1 = 1 AND en_regi...
               ^
UPDATE aplicaciones SET inactiva = 1 WHERE 1 = 1 AND en_registry = '1'

por lo que veo es una relación que no encuentra en la tabla APLICACIONES.

Alguna sugerencia?, desde ya muchas gracias.

saludos.-

« Última Modificación: Septiembre 16, 2019, 12:00:53 pm por Sergio F. Vier »

salegria

  • Jr. Member
  • **
  • Mensajes: 54
    • Ver Perfil
  • Institución: UNNE
  • Nombre y apellido: Sergio Alegría
  • Utilizo algun sistéma del SIU: Sí
Re:Error al registrar arai usuarios
« Respuesta #1 on: Septiembre 12, 2019, 12:34:48 pm »
Solucionado,  en el archivo de conf del arai.usuarios.conf, antes de instalar el proyecto, tiene que ir como nombre de esquema de la base  "usuarios".


saludos.-
« Última Modificación: Noviembre 11, 2019, 07:55:46 am por salegria »