Autor Tema: Toba 3.2 - Visualización y generación de código php  (Leído 800 veces)

0 Usuarios y 1 Visitante están viendo este tema.

mmunoz

  • General
  • *
  • Mensajes: 159
    • Ver Perfil
    • Email
  • Institución: UNPSJB
  • Nombre y apellido: Marcelo Alejandro Muñoz
  • Sistema: Siu-Araucano - Siu-kolla
  • Teléfono laboral: 0297-4557856 int 116
Toba 3.2 - Visualización y generación de código php
« on: Marzo 18, 2020, 12:11:07 pm »
Buenos días:
                         Les comento que a partir de una versión determinada de toba 3.2, no recuerdo bien cual (> 3.2.6) no podemos generar los archivos php desde el entorno de Siu-Toba. Da un error de Class 'PHP_Highlight' not found.
                         El SO de las máquinas virtuales que estamos usando es debian 9, con php 7.1.
                         Estará faltando alguna librería en nuestro composer.json o alguna librería de php?

Desde ya muchas gracias por su atención.

Saludos,

Marcelo.

richard

  • Moderador Global
  • *****
  • Mensajes: 3064
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Toba 3.2 - Visualización y generación de código php
« Respuesta #1 on: Marzo 20, 2020, 12:16:01 pm »
Hola Marcelo,

efectivamente se perdio en toba_autoload esa clase, lo solucione en su momento en develop y me quedo pendiente el merge a la rama de soporte de 3.2.
Merge y version listos.
Gracias por el aviso.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.

mmunoz

  • General
  • *
  • Mensajes: 159
    • Ver Perfil
    • Email
  • Institución: UNPSJB
  • Nombre y apellido: Marcelo Alejandro Muñoz
  • Sistema: Siu-Araucano - Siu-kolla
  • Teléfono laboral: 0297-4557856 int 116
Re:Toba 3.2 - Visualización y generación de código php
« Respuesta #2 on: Marzo 31, 2020, 09:52:35 am »
Hola Richard:
                          Muchas gracias por la respuesta. Te cuento que quise hacer composer update y me dió un problema de dependencias.
                                    - siu/instalador dev-develop requires php >=7.3.0 -> your PHP version (7.1.33) does not satisfy that requirement.
                          Miré en hitlab y en un composer de la versión de mapuche 3.9.0 y yo tenía en el proyecto la versión dev-develop para "siu/instalador" lo cambié a la versión 1.9.0, hice luego un composer update y corrió bien. Además de arreglar el problema que tenía con la clase.

                          Ahora bien...como saber que versión de cada paquete debemos usar? supongo que esto daría para otro tema dentro del foro...
Saludos,

Marcelo.


pblanco

  • General Mapuche
  • *
  • Mensajes: 40
    • Ver Perfil
  • Institución: UNR
  • Nombre y apellido: Pablo J. Blanco
  • Sistema: Toba
  • Teléfono laboral: 0341-4201245
Re:Toba 3.2 - Visualización y generación de código php
« Respuesta #3 on: Abril 01, 2020, 12:09:32 pm »
Hola Richard.

Estamos en lo mismo por aqui. Sabes cuando se soluciona?

richard

  • Moderador Global
  • *****
  • Mensajes: 3064
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Toba 3.2 - Visualización y generación de código php
« Respuesta #4 on: Abril 01, 2020, 07:06:34 pm »
Hola Marcelo,
                          Muchas gracias por la respuesta. Te cuento que quise hacer composer update y me dió un problema de dependencias.
                                    - siu/instalador dev-develop requires php >=7.3.0 -> your PHP version (7.1.33) does not satisfy that requirement.
                          Miré en hitlab y en un composer de la versión de mapuche 3.9.0 y yo tenía en el proyecto la versión dev-develop para "siu/instalador" lo cambié a la versión 1.9.0, hice luego un composer update y corrió bien. Además de arreglar el problema que tenía con la clase.

respecto de la version del instalador, nosotros vamos continuamente subiendo cosas a la rama develop.. asi que no es lo mas seguro quedarse ahi, si necesitas algo puntual que esta en esa rama... quizas lo mejor es que subas un issue o un gds solicitando que saquen una version nueva. En alguna ocasion he usado versiones asi pero solo cuando no me queda otra.

Lo mismo con Toba.. por ahi esta tranquilo durante semanas y en dos dias luego mergeo 5 ramas feature.. que pueden incluir cambios de requerimientos, mas que dev-develop... lo mejor es saber cual es el ultimo release si necesitas algo mas nuevo.

Cita
                          Ahora bien...como saber que versión de cada paquete debemos usar? supongo que esto daría para otro tema dentro del foro...

En rigor, deberias tener las versiones con las que salio el sistema (en este caso Mapuche), si algo falla y no fue detectado a tiempo... tenes dos opciones:

- Cargarles un GdS haciendoles notar el problema y esperando a que liberen una version de tercer digito

- Actualizar vos por tu cuenta, sabiendo que estas corriendo off-specs y lidiar con eso... si todo funciona bien, informando al equipo correspondiente para que pueda sacar una version con las libs actualizadas cuanto antes (ya que hiciste de alfa tester), si algo falla.. entonces vas a tener que ir al paso 1.

Saludos

Twitter es al incontinente verbal,  lo que los dulces al diabetico.

richard

  • Moderador Global
  • *****
  • Mensajes: 3064
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Ricardo Dalinger
  • Sistema: SIU-Toba
Re:Toba 3.2 - Visualización y generación de código php
« Respuesta #5 on: Abril 01, 2020, 07:07:59 pm »
Hola Pablo,
Hola Richard.
Estamos en lo mismo por aqui. Sabes cuando se soluciona?

en lo mismo seria trabado por una restriccion del sistema o con el problema del editor en Toba?.. si es lo ultimo, actualizando a 3.2.13 al menos se te soluciona.

Saludos
Twitter es al incontinente verbal,  lo que los dulces al diabetico.