Autor Tema: [RESUELTO] Error en instalación de versión 4.3.1  (Leído 469 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Seba_UNL

  • Guarani Kolla
  • *
  • Mensajes: 50
    • MSN Messenger - seba_sls@hotmail.com
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Litoral
  • Nombre y apellido: Sebastián Schinner
  • Sistema: SIU Guarani - SIU Kolla - SIU Diaguita - SIU-Pilaga - SIU-Mapuche
  • Teléfono laboral: 0342-4571110
[RESUELTO] Error en instalación de versión 4.3.1
« on: Septiembre 28, 2020, 11:15:09 am »
Buenos días...

Estoy teniendo un inconveniente en la actualización de la versión 4.2.0 a la 4.3.1.
Siguiendo la explicación de https://documentacion.siu.edu.ar/wiki/SIU-Kolla/Version_4.3.0/actualizacion cuando llego al punto de "./bin/instalador proyecto:actualizar" y se genera un inconveniente cuando solicita la ruta de la instalación anterior:

Código: [Seleccionar]
4) Verificación del proyecto existente
======================================


 Ingrese la ruta completa del directorio donde esta instalada la version anterior del proyecto:
 > '/usr/local/siu/kolla/instalacion'


 [ ERROR ] El parametro "--instalacion-anterior" del directorio de instalación anterior es obligatorio en actualizaciones desatendidas

 [ ERROR ] El directorio "" no tiene permisos de lectura
PHP Warning:  parse_ini_file(/i__produccion/instancia.ini): failed to open stream: No such file or directory in /usr/local/siu/kolla/aplicacion431/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 197

 [ ERROR ] No se pudo leer el archivo "/proyecto.ini"
PHP Warning:  parse_ini_file(/i__produccion/instancia.ini): failed to open stream: No such file or directory in /usr/local/siu/kolla/aplicacion431/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 214
PHP Warning:  array_key_exists() expects parameter 2 to be array, null given in /usr/local/siu/kolla/aplicacion431/vendor/siu/instalador/src/SIU/Instalador/Toba/Paso/VerificarProyectoExistente.php on line 216

 [ ERROR ] El archivo "/i__produccion/instancia.ini" debe tener configurado el parámetro usar_perfiles_propios = "1" en la entrada [kolla], para que se puedan migrar los perfiles funcionales.
« Última Modificación: Septiembre 28, 2020, 02:26:27 pm por Seba_UNL »

Seba_UNL

  • Guarani Kolla
  • *
  • Mensajes: 50
    • MSN Messenger - seba_sls@hotmail.com
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional del Litoral
  • Nombre y apellido: Sebastián Schinner
  • Sistema: SIU Guarani - SIU Kolla - SIU Diaguita - SIU-Pilaga - SIU-Mapuche
  • Teléfono laboral: 0342-4571110
[RESUELTO] Re:Error en instalación de versión 4.3.1
« Respuesta #1 on: Septiembre 28, 2020, 02:25:57 pm »
Se ejecutó nuevamente la instalación según lo enviado por GDS con el parámetro "--instalacion-anterior /usr/local/siu/kolla" y anduvo sin ningún inconveniente.

Luego saltaron unos problemas de estilos dado que hubo un error al descompirmir el rar de la versión 4.3.1.
Esto fue reparado, recreando post instalación los enlaces simbólicos, parados en "www":
Código: [Seleccionar]
ln -s ../vendor/components/ assets
ln -s ../php/extension_toba/bootstrap/assets/ bt-assets