Autor Tema: Error en Yarn al instalar el núcleo  (Leído 327 veces)

0 Usuarios y 1 Visitante están viendo este tema.

aamaya

  • Full Member
  • ***
  • Mensajes: 147
    • Ver Perfil
  • Institución: Universidad Nacional General Sarmiento
  • Nombre y apellido: Agustín Amaya
  • Sistema: SIU-Mapuche
  • Teléfono laboral: 4469-7716
  • Utilizo algun sistéma del SIU: Sí
Error en Yarn al instalar el núcleo
« on: Enero 25, 2021, 09:19:20 am »
Buenas,

Estamos intentando instalar el núcleo y recibimos el siguiente error:

Código: [Seleccionar]
Generating autoload files
> composer run-script post-install-cmd -d ./vendor/siu-toba/framework/
> yarn add ckeditor4@4.15 jquery@3.5 jquery-migrate@3.2 siu-js-app-launcher@1.0.5 --modules-folder www/js/packages/
/usr/local/siu/sanaviron_1.4.10/sq_pagos/bin/.nvm/versions/node/v4.5.0/lib/node_modules/yarn/lib/cli.js:46100
  let {
      ^

SyntaxError: Unexpected token {
    at exports.runInThisContext (vm.js:53:16)
    at Module._compile (module.js:373:25)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/usr/local/siu/sanaviron_1.4.10/sq_pagos/bin/.nvm/versions/node/v4.5.0/lib/node_modules/yarn/bin/yarn.js:24:13)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
Script yarn add ckeditor4@4.15 jquery@3.5 jquery-migrate@3.2 siu-js-app-launcher@1.0.5 --modules-folder www/js/packages/ handling the post-install-cmd event returned with error code 1
Script composer run-script post-install-cmd -d ./vendor/siu-toba/framework/ handling the post-install-cmd event returned with error code 1

(Adjunto captura)

Lo raro es que es una instalación nueva y veo que algunas rutas apuntan a la instalación de Sanavirón 1.4.10.

Cuál puede ser el problema?

aamaya

  • Full Member
  • ***
  • Mensajes: 147
    • Ver Perfil
  • Institución: Universidad Nacional General Sarmiento
  • Nombre y apellido: Agustín Amaya
  • Sistema: SIU-Mapuche
  • Teléfono laboral: 4469-7716
  • Utilizo algun sistéma del SIU: Sí
Re:Error en Yarn al instalar el núcleo
« Respuesta #1 on: Enero 25, 2021, 09:28:13 am »
Buenas,

La variable de entorno $PATH tenía dentro de sus valores la ruta de la instalación de sanaviron 1.4.10.

Eliminé este dato que había quedado de la instalación anterior y desapareció el problema.

Saludos