Autor Tema: Error en instalación 4.1.0  (Leído 617 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Error en instalación 4.1.0
« on: Marzo 26, 2021, 12:22:10 pm »
Estimados:  Acabo de instalar la nueva versión 4.1.0 necesaria para la integración con Guaraní y Kolla.   El proceso se generó correctamente, pero cuando ingreso vía web me salta el siguiente mensaje de error:    Se ha detectado un nombre de parámetro, atributo o columna no definidos.

Al  chequear el log de postgres se visualiza el siguiente detalle:

2021-03-26 11:57:09.208 -03 [32327] postgres@tehuelche ERROR:  no existe la columna «requiere_segundo_factor» en carácter 601
2021-03-26 11:57:09.208 -03 [32327] postgres@tehuelche : SELECT       usuario as                                                  id,
                                                nombre as                                   nombre,
                                                email as                                    email,
                                                parametro_a as                              parametro_a,
                                                parametro_b as                              parametro_b,
                                                parametro_c as                              parametro_c,
                                                COALESCE(requiere_segundo_factor,0) as     require_2do_factor
                                        FROM    apex_usuario u
                                        WHERE   usuario IN ('toba') -- toba_log: 558

Agradezco cualquier ayuda que puedan brindarme para poder avanzar
« Última Modificación: Marzo 26, 2021, 12:25:34 pm por sserafino »

Myriam Céspedes

  • Moderador Global
  • *****
  • Mensajes: 369
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Myriam Céspedes
  • Sistema: Equipo SUDOCU | Proyecto EEI
Re:Error en instalación 4.1.0
« Respuesta #1 on: Marzo 26, 2021, 01:51:55 pm »
Buenas tardes,
con qué versión de Guaraní estarán vinculando?

Con 3.18.1 pueden instalar directamente la 4.1.2 de Tehuelche.

Te consulto para analizar el problema que presentas, estabas actualizando la versión de Tehuelche, o era una instalación de cero?

Saludos!
Myriam

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #2 on: Marzo 26, 2021, 01:56:48 pm »
Hola, ahora en abril estaremos en versión 3.18.0 de Guaraní y necesito Tehuelche funcionando.   La versión que me indicás sirve igual? sino, cómo resuelvo el problema generado en la instalación de la 4.1.0?
Se armó una nueva Virtual Machine para la instalación desde cero de la versión 4.  Se instaló esa sin problemas, luego surgió la necesidad de actualizar a la 4.1 para la integración con Guaraní y Kolla.  Esta actualización se intentó sobre la misma máquina pero daba error, así que se volvió atrás con eso y se instaló directamente esta versión 4.1

Gracias.
Saludos.
Sandra.-
« Última Modificación: Marzo 26, 2021, 01:59:08 pm por sserafino »

Myriam Céspedes

  • Moderador Global
  • *****
  • Mensajes: 369
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Myriam Céspedes
  • Sistema: Equipo SUDOCU | Proyecto EEI
Re:Error en instalación 4.1.0
« Respuesta #3 on: Marzo 26, 2021, 04:04:20 pm »
El problema que veo es la versión que instalaron de Tehuelche. Guaraní 3.18.0 no es compatible con las 4.1.X.
  • Si están con 3.18.0, pueden instalar Tehuelche 4.0.1.
  • En cuanto puedan pasar a 3.18.1, podrán ir directamente a 4.1.2.

Saludos!
Myriam

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #4 on: Marzo 29, 2021, 08:30:49 am »
Gracias...  cambié la versión porque me informaron que Guaraní requería esta nueva para la 3.18, pero no se tuvo en cuenta el cambio entre 3.18.0 y 3.18.1 para la versión de Tehuelche. Iré entonces a 4.0.1.
Saludos.
Sandra.-

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #5 on: Marzo 31, 2021, 01:10:17 pm »
Miriam... máquina nueva para instalar la Versión 4.0.1 siguiendo las directivas que existen en la documentación y ahora me aparece el error que te adjunto...

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #6 on: Marzo 31, 2021, 01:38:22 pm »
Buenas tardes Sandra,
qué versión de composer tienen instalada?
Agrego: desde qué branch de tehuelche están instalando?

Saludos

3
« Última Modificación: Marzo 31, 2021, 02:25:08 pm por M Clara Casalini »

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #7 on: Marzo 31, 2021, 03:52:07 pm »
La versión es la 2.0.11

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #8 on: Abril 05, 2021, 08:35:25 am »
del indicado en su sitio de documentación como instalación desde cero (https://documentacion.siu.edu.ar/wiki/SIU-Tehuelche/version_4.0/instalacion)
Branch: 
git clone --branch 4.0.0 https://hub.siu.edu.ar/siu/tehuelche.git


Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla y SIU-Tehuelche
Re:Error en instalación 4.1.0
« Respuesta #9 on: Abril 05, 2021, 10:57:45 am »
Hola Sandra.

Para instalar la versión de SIU-Kolla que desean deben correr el siguiente comando de descarga de la misma:

Código: [Seleccionar]
git clone --branch 4.0.1 https://hub.siu.edu.ar/siu/tehuelche.git
En la versión que se indica ya debería estar corregido en Toba el error que les arroja.

Por otro lado, la versión de composer que recomendamos es la 1.8.

Saludos!

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #10 on: Abril 07, 2021, 08:26:09 am »
Perfecto-, pude instalar.  Ahora me surge otro tema y es con la pantalla inicial de la aplicación.  Se rompe al cargarla para el proyecto Tehuelche pero no pasa esto ni con Toba_usuarios ni con Toba_Editor.  Adjunto pantallas para que puedan orientarme con esto.  Muchas gracias.

Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla y SIU-Tehuelche
Re:Error en instalación 4.1.0
« Respuesta #11 on: Abril 07, 2021, 10:35:50 am »
Hola Sandra.

Abriendo la consola del desarrollador, podes ver que arroje algún error?

Corriste el comando del instalador para cambiar los permisos? De manera de otorgarle al usuario de Apache los permisos necesarios.

Saludos, Germán

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #12 on: Abril 07, 2021, 11:19:55 am »
- Si cambié los permisos de acuerdo a lo  indicado por el instructivo.  Si esos tienen ser asignados a algún usuario del sistema en particular, decime.  En este momento el dueño de los archivos del proyecto es root y el grupo del servidor Apache es www-data.  Pero la otra instalación puse lo mismo y funcionó sin problemas.
- Respecto de la consola del desarrollador, no se a qué te referís especificamente.  Desde el Toba_editor no visualizo errores, tampoco apache tiene errores en su log.  Lo que me resulta raro es que los otros proyectos asociados funcionan pero no Tehuelche, ... , en realidad no es que no funciona sino que se rompe la vista.  Si fuera un problema de permisos no debería afectar a todos?  Puede ser que sea algo asociado a la carga de la tabla sg_propuestas que debo traer de Guarani?, porque no tengo eso aún

Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla y SIU-Tehuelche
Re:Error en instalación 4.1.0
« Respuesta #13 on: Abril 07, 2021, 12:08:23 pm »
Sandra.

Proba asignándole los permisos como propietario a otro usuario que no sea root, y avisanos si funciona.

A la consola que me refería en el posteo anterior es a la consola del navegador, y esta bien que solo Tehuelche no funcione porque lo que no esta levantando son los estilos de Bootstrap propios del módulo SIU-Tehuelche. Lo que sospechamos es que no tenga los permisos adecuados para poder accederlos. Tampoco esta relacionado a la tabla de propuestas.

Saludos.

6
« Última Modificación: Abril 08, 2021, 09:13:49 am por Germán Lodovskis »

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #14 on: Abril 07, 2021, 02:12:01 pm »
Sigue igual, así que volví a root que es como tengo otros proyectos funcionando. Te mando imagen de los permisos y dueños que tiene cada carpeta para que puedas ver...