Autor Tema: Error en instalación 4.1.0  (Leído 582 veces)

0 Usuarios y 1 Visitante están viendo este tema.

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #15 on: Abril 07, 2021, 03:57:37 pm »
El debugger del browser me indica los archivos que dan error,   por ejemplo falla al cargar https://siutehuelche.unnoba.edu.ar/toba_tehuelche/siu/manejador_salida_bootstrap/js/bootstrap/css/bootstrap.min.css
(adjunto imagen)
Pero al ir a la carpeta correspondiente, la misma está vacía... en realidad sólo tiene una subcarpeta /img con algunos archivos tipo favicon.ico
Al buscar el archivo indicado lo encuentra pero en otros directorios...
>>root@tehuelche-test:/home/tehuelche/www/siu/manejador_salida_bootstrap# ls
img
>>root@tehuelche-test:/home/tehuelche/www/siu/manejador_salida_bootstrap/img# ls
favicon.ico  kolla_nombre.png  logo-iso.png  logo-kolla-iso2.png  logo-nombre.png  silueta.png
>>root@tehuelche-test:/home/tehuelche# find -name "bootstrap.min.css"
./vendor/phpoffice/phpspreadsheet/samples/bootstrap/css/bootstrap.min.css
./vendor/phpunit/php-code-coverage/src/Report/Html/Renderer/Template/css/bootstrap.min.css

Puede ser un problema de paths o de instalación incompleta , pese a que el instalador indicó Instalación Completa?


M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #16 on: Abril 08, 2021, 09:03:32 am »
Buen día Sandra,
no conocemos cómo están definidos los alias en toba.conf pero creería que la url que estas compartiendo es en realidad del alias de toba, por lo tanto ese archivo se está buscando en el path:
Código: [Seleccionar]
/home/tehuelche/vendor/siu/manejador_salida_bootstrap/js/bootstrap/css/bootstrap.min.cssConfirmá que en esa ruta tengas efectivamente los archivos del manejador de salida, no sería raro que aparezcan problemas de distinto tipo si se trabaja todo bajo el usuario root.
Entiendo que puedan tener instalaciones funcionando así pero no es recomendable dejar un esquema de permisos como ese, en especial para un sistema que tendrá acceso desde la web, puede generarles problemas de seguridad.
Saludos!
3

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #17 on: Abril 09, 2021, 10:05:34 am »
En esa ruta no tengo carpeta css

root@tehuelche-test:/home/tehuelche/vendor/siu/manejador-salida-bootstrap# ls
bin  CHANGELOG.md  composer.json  README.md  src

Aparecen dentro de la carpeta src.   Adjunto imagen

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #18 on: Abril 09, 2021, 10:18:44 am »
Perdón Sandra, construí mal el path que quise pasarte.
Si "siutehuelche.unnoba.edu.ar/toba_tehuelche/" es efectivamente el alias de toba, y de acuerdo a cómo veo que debes tener instalado tehuelche el path que debería construirse es este:

/home/tehuelche/vendor/siu-toba/framework/www/siu/manejador_salida_bootstrap/js/bootstrap/css/bootstrap.min.css

porque el alias se reemplaza por "/home/tehuelche/vendor/siu-toba/framework/www" y luego está el resto de la url que te indica el browser "/siu/manejador_salida_bootstrap/js/bootstrap/css/bootstrap.min.css"

Saludos.

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #19 on: Abril 09, 2021, 04:37:55 pm »
Parte del nuevo link que me indicas  no lo tengo.   En particular llego hasta www (root@tehuelche-test:/home/tehuelche# cd /home/tehuelche/vendor/siu-toba/framework/www/).  El resto de las carpetas no siguen esa lógica (..."siu/manejador_salida_bootstrap/js/bootstrap...).   Adjunto imagen

La carpeta manejador_salida_bootstrap aparece sólo en la siguiente dirección y su contenido sólo contiene /img, tal como ya te había mencionado antes
root@tehuelche-test:/home/tehuelche/www/siu/manejador_salida_bootstrap# ls
img



M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #20 on: Abril 12, 2021, 08:21:57 am »
Sandra,
si no tuvieron ningún mensaje durante el composer install que indicara alguna dificultad descargando parte de los requerimientos, revisen con atención el archivo instalador.log a ver si ahí detectan algo. Eso es parte del framework toba que necesita el módulo para funcionar correctamente.
Saludos.

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #21 on: Abril 19, 2021, 05:53:27 pm »
Hola, logré recuperar un backup de una instalación previa de esta versión que ya tenía instalada y que se rompió al intentar actualizarla .   Ya está funcionando el sistema, pero ahora necesito integrar a Guaraní3w 3.18.0.   Ya he configurado los servicios correspondientes y el sistema está funcionando en https, sin embargo cuando intento avanzar con la sincronización de alguna convocatoria, me tira:
Se han encontrado los siguientes problemas:
 Se ha producido un error al intentar actualizar la definición de la convocatoria, comunique el siguiente mensaje a su administrador.
 cURL error 77: error setting certificate verify locations:\n CAfile: /etc/ssl/start_unnoba_edu.ar-.rt\n CApath: /etc/ssl/certs (see http://curl.haxx.se/libcurl/c/libcurl-errors.html)

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #22 on: Abril 20, 2021, 08:59:53 am »
Buen día,
según el mensaje de error y la url que te provee ese mensaje como documentación, lo que está ocurriendo es que cURL no está pudiendo leer el certificado por problemas en el path o por problemas de permisos.
Necesitan chequear el funcionamiento de cURL con los certificados que tengan en ese servidor.
Saludos.
4

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #23 on: Abril 22, 2021, 02:47:48 pm »
Estimados:  Gracias por la respuesta.   Se validó el uso de los certificados, incluso se actualizaron.  La VM funciona bien y el sistema también, excepto la sincronización dónde sigue dándome el mismo error ya indicado.  Incluso mostrando en el path los certificados que ya no están  porque fueron reemplazados.   

sserafino

  • Newbie
  • *
  • Mensajes: 41
    • Ver Perfil
  • Institución: UNNOBA
  • Nombre y apellido: Sandra Serafino
  • Sistema: COMDOC
Re:Error en instalación 4.1.0
« Respuesta #24 on: Abril 23, 2021, 11:43:45 am »
Resuelto:  El problema estaba en el archivo php.ini donde habían quedado seteados los paramétros curlinfo y openssl con los certificados viejos.   Ya está funcionando la conexión con Guaraní, y ahora tira un error al sincronizar pero con Kolla que estamos revisando.
Gracias !!!

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Error en instalación 4.1.0
« Respuesta #25 on: Abril 23, 2021, 12:03:17 pm »
Qué buena noticia Sandra!
Cualquier duda con Kolla nos avisan.
Saludos!