Autor Tema: Confusion siguiendo la guia de instalacion  (Leído 121 veces)

0 Usuarios y 1 Visitante están viendo este tema.

erwin.stangholzer

  • Newbie
  • *
  • Mensajes: 24
    • Ver Perfil
  • Institución: UNViMe
  • Nombre y apellido: Erwin Amadeo Stang Holzer
  • Sistema: Guarani, Kolla, Diaguita, Pilaga, ComDoc, Mapuche
  • Teléfono laboral: 2657244750
  • Utilizo algun sistéma del SIU: Sí
Confusion siguiendo la guia de instalacion
« on: Abril 19, 2021, 01:25:20 pm »
En la siguiente pagina de documentacion https://documentacion.siu.edu.ar/wiki/SIU-Arai/Requerimientos en la seccion Requerimientos del servidor de aplicaciones indica que para PHP 7.1 se requiere usar la version 2.0.0 a 2.1.x de SIU-Arai: Registry.

Entonces voy a la siguiente pagina para instalar SIU-Arai: Registry con esa version indicada . La instalacion mediante docker parece no tener documentacion, entonces me voy a la instalacion manual https://hub.siu.edu.ar/siu-arai/arai-registry/-/blob/master/doc/install/INSTALACION_MANUAL.md.

Para ejecutar el comando: git clone --branch <VERSION> https://hub.siu.edu.ar/siu-arai/arai-registry.git
Debo cambiar <VERSION> por la version que necesite, sin embargo el comando no funciona escribiendo la version 2.1.3 que encontré en https://hub.siu.edu.ar/siu-arai/arai-registry/-/tags.

El comando si que funciona utilizando master pero la version actual en master es la 2.3.0. Volviendo a la documentacion del principio de este post. En esa pagina la ultima version utilizable que aparece es la 2.1.3 o mejor dicho 2.1.x.

Las guias de instalacion y los requisitos me confunden y parecen no concordar.
Hay algo que no estoy interpretando bien sobre las versiones quizas?

Sergio F. Vier

  • Desarrollador SIU
  • Moderador Global
  • *****
  • Mensajes: 773
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Sergio Fabian Vier
Re:Confusion siguiendo la guia de instalacion
« Respuesta #1 on: Abril 19, 2021, 05:52:24 pm »
Hola!

La documentación que estas mirando, corresponde a la versión 2 de la plataforma SIU-Araí (esta incluye arai-usuarios, arai-registry, huarpe).

A partir de la versión 3 de la plataforma SIU-Araí, es que se comienza a tener soporte a Docker, junto con el despliegue de la solución EEI y su documentación. En esta versión, arai-registry está discontinuado y no funciona en un ambiente Docker... (si llegara el caso, hay caminos para soportar una instalación manual pre-existente, pero no la recomendamos para una instalación desde cero).

Adicionalmente, la documentación de arai-usuarios nueva es esta. Si esto no les orienta, contanos bien en detalle que quieren instalar, cómo, etc. para poder guiarlos mejor!

Saludos!
happy coding!!