Autor Tema: Actualización 2.3>2.6 (RESPONDIDO)  (Leído 299 veces)

0 Usuarios y 1 Visitante están viendo este tema.

lrodriguez

  • Jr. Member
  • **
  • Mensajes: 50
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Leandro Efrain Rodriguez
  • Sistema: Pilaga
Actualización 2.3>2.6 (RESPONDIDO)
« on: Abril 23, 2021, 12:30:41 pm »
Buenos días, como están? Estoy haciendo una actualización de Diaguita en un entorno de prueba. Ya que hoy en día estamos en producción con la versión 2.3. La idea es progresivamente ponernos al día con las actualizaciones durante este año. Estoy intentando actualizar a la versión 2.6.0 pero en medio del proceso tengo algunos errores.

Cita
[ WARNING ] PHP Notice:  Undefined index: items in /usr/local/siu/SIU-Diaguita260/vendor/siu-toba/framework/php/modelo/toba_modelo_proyecto.php on line 601
PHP Warning:  array_keys() expects parameter 1 to be array, null given in /usr/local/siu/SIU-Diaguita260/vendor/siu-toba/framework/php/modelo/toba_modelo_proyecto.php on line 601
PHP Warning:  Invalid argument supplied for foreach() in /usr/local/siu/SIU-Diaguita260/vendor/siu-toba/framework/php/modelo/toba_modelo_proyecto.php on line 601
 ATENCION! No fue posible cargar por completo el 'perfil_admin', posiblemente a causa de que al menos una operaci▒n, restricci▒n o derecho ha dejado de existir en 'diaguita'. A continuaci▒n el detalle:

 ERROR ejecutando SQL:
  [CODIGO]: 7
  [SQLSTATE]: db_23503
  [MENSAJE]: ERROR:  inserci▒n o actualizaci▒n en la tabla ▒apex_usuario_grupo_acc_item▒ viola la llave for▒nea ▒apex_usu_item_fk_item▒
 DETAIL:  La llave (proyecto, item)=(diaguita, 4000004) no est▒ presente en la tabla ▒apex_item▒.
  [SQL EJECUTADA]: INSERT INTO apex_usuario_grupo_acc_item (proyecto, usuario_grupo_acc, item_id, item) VALUES ('diaguita', 'admin', NULL, '4000004');

 De todas formas se contin▒a la carga, se recomienda revisar la definici▒n de este perfil.

Después de ese error siguió bien hasta que se detuvo a partir del siguiente error.
Cita
=== Generando conversión de base de datos ===
-----------------------------------------------

-Generando conversión de la base de datos de negocio

1/1 [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓] 100%


 [ ERROR ] No se pudo realizar la conversión de la base de datos para la versión 2.6.0, ejecutando el archivo de conversión /usr/local/siu/SIU-Diaguita260/sql/repositorio_conversion/2.6.0.sql




Los requerimientos y el resto de la instalación funcionó ok, les muestro algunos datos:
Cita
[ OK ] PHP: Versión esperada desde 7.0.0 hasta 7.2.0, versión instalada 7.0.33

 [ OK ] PHP: La extensión pdo_pgsql se encuentra instalada en el sistema.

 [ OK ] POSTGRES: Versión esperada desde 9.4.0, versión instalada 9.6.20



Espero que puedan ayudarme a resolverlo.

Muchas gracias!

Saludos!

Leandro
« Última Modificación: Abril 23, 2021, 01:19:12 pm por mdeganis »

Pablo Boyko

  • Full Member
  • ***
  • Mensajes: 116
  • Desarrollador SIU-Diaguita
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: Pablo Boyko
  • Sistema: SIU Diaguita
Re:Actualización 2.3>2.6
« Respuesta #1 on: Abril 23, 2021, 01:09:38 pm »
Hola Leandro,
La recomendación siempre es realizar las actualizaciones sin saltear las versiones de 2do dígito.

Principalmente en este caso, donde la versión 2.4 fue la ultima donde se utilizó el instalador/actualizador web.
La recomendación seria que actualicen primero a 2.4 con el actualizador web y luego actualicen a 2.5 con el actualizador por consola.

Cualquier cosa si tienen algún problema puntual en esas actualizaciones nos podrían pasar los detalles por GDS para analizarlo.
Saludos.



lrodriguez

  • Jr. Member
  • **
  • Mensajes: 50
    • Ver Perfil
  • Institución: UNTREF
  • Nombre y apellido: Leandro Efrain Rodriguez
  • Sistema: Pilaga
Re:Actualización 2.3>2.6
« Respuesta #2 on: Abril 23, 2021, 01:11:51 pm »
Ok, voy de versión en versión entonces.

Muchas gracias!

Saludos!