Autor Tema: Problemas para instalar Kolla 4.5.0  (Leído 283 veces)

0 Usuarios y 1 Visitante están viendo este tema.

lpetrora

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Facultad de Ingeniería - UBA
  • Nombre y apellido: Leonardo Mauricio Petrora
  • Sistema: Julio Argentino Roca
  • Utilizo algun sistéma del SIU: Sí
Problemas para instalar Kolla 4.5.0
« on: Mayo 05, 2021, 05:18:16 pm »
Hola, buenas tardes. Soy Leonardo Petrora, de la Facultad de Ingeniería de la UBA. Estamos intentando instalar la última versión de Kolla (4.5.0) y estamos teniendo varios problemas.
El entorno de instalación es un contenedor docker a partir de la imagen siutoba/docker-toba:v1.4. La imagen incorpora PHP 7.3.13 y todas las dependencias necesarias. El motor de base de datos es Postgres 11. Según la documentación (https://documentacion.siu.edu.ar/wiki/SIU-Kolla/Version_4.5.0/instalacion_desde_cero) ambas versiones están soportadas.

Luego del proceso de build de la imagen ejecutamos un contenedor y podemos crear los usuarios sin problemas, sin embargo, al ingresar a la aplicación obtenemos  mensajes de error del tipo STRICT STANDARD. Por ejemplo, en Configuración -> Unidades de Gestión:

Warning: Declaration of ext_bootstrap\componentes\interfaz\bootstrap_ei_cuadro_salida_html::generar_botones() should be compatible with toba_ei_cuadro_salida_html::generar_botones($clase = '') in /srv/kolla/4.5.0/php/extension_toba/bootstrap/componentes/interfaz/bootstrap_ei_cuadro_salida_html.php on line 4

Pensé que tal vez 7.3 no sería compatible y traté de instalarlo partir de la imagen siutoba/docker-toba:v1.3 que integra la versión de PHP 7.1.25 pero al correr composer install  obtengo errores de dependencias (incluyendo de SIU) que requieren 7.3, por ejemplo:


    - Installation request for siu/arai-cli v3.0.0 -> satisfiable by siu/arai-cli[v3.0.0].
    - siu/arai-cli v3.0.0 requires php >=7.3 -> your PHP version (7.1.25) does not satisfy that requirement.


¿Alguien tuvo algún problema similar? ¿Alguna sugerencia de cómo resolverlo?

Muchas gracias!

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #1 on: Mayo 06, 2021, 12:11:44 pm »
Buen día Leonardo,
La versión de php que deben usar con Kolla 4.5 es la 7.3, no es compatible con 7.1.
Con respecto al warning que comentas, sabemos de esos avisos y estamos trabajando actualmente en cuestiones de la interfaz que deberían resolver esas diferencias. De todas maneras al ser un warning no debería ser bloqueante para el funcionamiento del módulo, en producción la directiva display_errors de php siempre se recomienda en Off.
Si una vez configurado php de este modo detectan alguna dificultad en el uso del módulo por supuesto nos comentan y lo vemos.
Saludos.
2


lpetrora

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Facultad de Ingeniería - UBA
  • Nombre y apellido: Leonardo Mauricio Petrora
  • Sistema: Julio Argentino Roca
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #2 on: Mayo 06, 2021, 12:57:47 pm »
Muchas gracias por la pronta respuesta, Clara. Sí, con el contenedor de PHP 7.3 y apagando la salida por pantalla de errores funciona correctamente.  Te hago dos consultas más:

Saludos y muchas gracias!


M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #3 on: Mayo 07, 2021, 11:12:46 am »
Hola,
1. ¿Buscas algo para generar toda la base completa (negocio y toba) o solamente el esquema de negocio? ¿Están trabajando en entorno de desarrollo o de producción?
2. También está la documentación de Guaraní, en el enlace se apunta a la documentación de la versión 3.19 porque no se cuál están usando pero pueden encontrar esa misma documentación para la versión que deseen.
Allí verán cómo configurar Guaraní para comunicarse correctamente con Kolla y consumir los datos de acuerdo a los perfiles de datos (unidades de gestión) que deseen.

Saludos!
2

lpetrora

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Facultad de Ingeniería - UBA
  • Nombre y apellido: Leonardo Mauricio Petrora
  • Sistema: Julio Argentino Roca
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #4 on: Mayo 10, 2021, 10:12:33 am »
Busco generar la base completa. Armamos una imagen de docker para Kolla en modo producción que está funcionando correctamente y en el futuro vamos a tener que levantar algún entorno de pruebas en base a esa imagen. Entonces lo que pretendemos hacer es camibar la configuración de la base de datos (para apuntarla a un server de test) y generar las ambas bases sin tener que reinstalar todo el proyecto.

Saludos,

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #5 on: Mayo 10, 2021, 01:49:59 pm »
Hola,
para eso lo más práctico y seguro sería que una vez que tengan todo funcionando hagan un dump completo de la base. De esa manera luego pueden usar el dump para levantar otra base en cualquier servidor y apuntar esa u otra instalación a la base obtenida.
Saludos!
2

lpetrora

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Facultad de Ingeniería - UBA
  • Nombre y apellido: Leonardo Mauricio Petrora
  • Sistema: Julio Argentino Roca
  • Utilizo algun sistéma del SIU: Sí
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #6 on: Mayo 10, 2021, 03:08:29 pm »
Perfecto, tengo un dump de cuando se instaló el sistema, usaré eso como planilla en caso de levantar otro entorno.

Muchas gracias por toda la ayuda. Ya tenemos el contenedor de Kolla andando!

M Clara Casalini

  • Moderador Global
  • *****
  • Mensajes: 786
    • Ver Perfil
  • Institución: SIU
  • Nombre y apellido: M. Clara Casalini
  • Sistema: Kolla
  • Teléfono laboral: -sin teléfono actualmente-
Re:Problemas para instalar Kolla 4.5.0
« Respuesta #7 on: Mayo 11, 2021, 08:37:42 am »
Excelente!  Cualquier cosa estamos en contacto.
Saludos.