Autor Tema: Error de usuarios al actualizar a versión 3.14.0  (Leído 558 veces)

0 Usuarios y 1 Visitante están viendo este tema.

ayelen.rodriguez

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Unahur
  • Nombre y apellido: Ayelen Rodriguez
  • Sistema: Diaguita, Wichi, Pilagá
  • Utilizo algun sistéma del SIU: Sí
Error de usuarios al actualizar a versión 3.14.0
« on: Junio 02, 2021, 05:08:20 pm »
Estimados/as,
   actualizamos Mapuche desde la versión 3.9.1 a 3.14.0, al correr el comando :
Código: [Seleccionar]
"./bin/instalador proyecto:actualizar --instalacion-anterior /RUTA_INSTALACION_ANTERIOR"No arrojó errores y proseguimos con los pasos post-instalación.
Al momento de probar el portal, ingreso a la página de inicio pero al loguear con un el usuario administrador, sale el siguiente error:
Cita
"El usuario no posee permisos para acceder al ítem solicitado."

Esto pasa al intentar ingresar tanto en Mapuche como en toba_usuarios.

Algunos pasos que tal vez sean de relevancia para encontrar la solución:
- Antes de correr la instalación verificamos que el archivo instancia.ini tenga el parámetro 'usar_perfiles_propios="1"', tal como dice la documentación.
-También antes de actualizar se cambio de clúster de PostgreSQL ya que la versión anterior pedía postgresl9.6 y la 3.14.0 solicita PostgreSQL 11, se reapuntó el bases.ini y se probó que todo funcionara correctamente.

Que podría estar generando esto o donde es que se aplican estos permisos?
Muchas gracias por la ayuda, saludos.

Ayelen Rodriguez

Mariela Alonso

  • Moderador
  • *****
  • Mensajes: 429
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error de usuarios al actualizar a versión 3.14.0
« Respuesta #1 on: Junio 03, 2021, 01:34:40 pm »
Hola Ayelén, ¿modificaron el archivo bases.ini? ¿Está correcto a la  base que hace referencia en las entradas toba_usuarios, mapuche?
Saludos,
Mariela


3
Mariela Alonso
Equipo SIU-Mapuche/Pampa
SIU
http://www.siu.edu.ar

ayelen.rodriguez

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Unahur
  • Nombre y apellido: Ayelen Rodriguez
  • Sistema: Diaguita, Wichi, Pilagá
  • Utilizo algun sistéma del SIU: Sí
Re:Error de usuarios al actualizar a versión 3.14.0
« Respuesta #2 on: Junio 03, 2021, 02:22:46 pm »
Buenas, si, modificamos el archivo bases.ini apuntando al clúster de postgresql11 antes de actualizar y probamos que funcionara bien.  Hasta antes de correr la actualización se podía ingresar con el usuario normalmente.

Mariela Alonso

  • Moderador
  • *****
  • Mensajes: 429
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error de usuarios al actualizar a versión 3.14.0
« Respuesta #3 on: Junio 03, 2021, 02:26:33 pm »
Me podrías pasar los dos bases.ini antes  (el que te funciona) y despues de las modificaciones?
Gracias,
Mariela
Mariela Alonso
Equipo SIU-Mapuche/Pampa
SIU
http://www.siu.edu.ar

ayelen.rodriguez

  • Newbie
  • *
  • Mensajes: 6
    • Ver Perfil
  • Institución: Unahur
  • Nombre y apellido: Ayelen Rodriguez
  • Sistema: Diaguita, Wichi, Pilagá
  • Utilizo algun sistéma del SIU: Sí
Re:Error de usuarios al actualizar a versión 3.14.0
« Respuesta #4 on: Junio 04, 2021, 11:37:22 am »
Buenas, te adjunto ambos archivos, lo único que cambia es el puerto de los clúster ya que creamos la base con el mismo nombre y mismo encoding.

Mariela Alonso

  • Moderador
  • *****
  • Mensajes: 429
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Mariela Alonso
  • Sistema: Mapuche
  • Teléfono laboral: 42200 int 131
Re:Error de usuarios al actualizar a versión 3.14.0
« Respuesta #5 on: Junio 04, 2021, 03:36:31 pm »
Hola, la base Mapuche que se encuentra en el puerto 5433 es la misma que la que se encuetra en el puerto 5435 pero actualizada?. ¿Si es así como la actualizaron?

6
Mariela Alonso
Equipo SIU-Mapuche/Pampa
SIU
http://www.siu.edu.ar