Autor Tema: instalar version 4.5.1: problemas con el composer  (Leído 354 veces)

0 Usuarios y 1 Visitante están viendo este tema.

rbravo

  • Newbie
  • *
  • Mensajes: 41
  • Ricardo Bravo
    • Ver Perfil
  • Institución: Universidad de Buenos Aires - Subscretaría de Transformación Digital y Modernización
  • Nombre y apellido: Ricardo Bravo
  • Sistema: Guaraní
  • Teléfono laboral: +54-11-5285-6100
instalar version 4.5.1: problemas con el composer
« on: Julio 14, 2021, 01:39:03 pm »
hola, saludos para tod@s en esta primera vez en el Mundo Kolla! :-)

les consulto porque estamos teniendo problema con la instalación inicial de la versión 4.5.1. Todos los requisitos están cumplidos, salvo el paquete "php_com_dotnet" (que entendemos es una DLL para Windows).

al correr composer install surge el siguiente problema:

Código: [Seleccionar]
Your lock file does not contain a compatible set of packages. Please run composer update.
corrimos composer update y surge otro problema:

Código: [Seleccionar]
[root@kollawtest 4.5.1]# composer update
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires siu-toba/framework ~3.3, it is satisfiable by siu-toba/framework[v3.3.0, ..., v3.3.20] from composer repo (https://repo.packagist.org) but siu-toba/framework[dev-trunk, 2.7.0, ..., 2.7.x-dev] from composer repo (https://satis.siu.edu.ar) has higher repository priority. The packages with higher priority do not match your constraint and are therefore not installable.
See https://getcomposer.org/repoprio for details and assistance.

[root@kollawtest 4.5.1]#

Nos pueden ayudar?

Muchas gracias!

Ricardo Bravo
Ricardo Bravo
UBA / Rectorado / SSTDyM

Germán Lodovskis

  • Moderador Global
  • *****
  • Mensajes: 246
    • Ver Perfil
    • Email
  • Institución: SIU - Bahia Blanca
  • Nombre y apellido: Germán Lodovskis
  • Sistema: SIU-Kolla y SIU-Tehuelche
Re:instalar version 4.5.1: problemas con el composer
« Respuesta #1 on: Julio 15, 2021, 01:00:02 pm »
Buen día Ricardo, y bienvenido al mundo Kolla.

Lo que debe estar sucediendo es que tenes instalado algún Composer 2.x.x, lo cual todavía no esta soportado. Para solucionar esto deberian realizar

Código: [Seleccionar]
composer self-update <parametro>

indicandole como parámetro la versión 1.x.x a la que desean bajar. Sino, para instalar una versión major pueden usar el flag --1, tal como lo indica la documentación de composer - sección Download channels: https://getcomposer.org/download/

Cualquier duda nos consultas.

Saludos, Germán3

rbravo

  • Newbie
  • *
  • Mensajes: 41
  • Ricardo Bravo
    • Ver Perfil
  • Institución: Universidad de Buenos Aires - Subscretaría de Transformación Digital y Modernización
  • Nombre y apellido: Ricardo Bravo
  • Sistema: Guaraní
  • Teléfono laboral: +54-11-5285-6100
Re:instalar version 4.5.1: problemas con el composer
« Respuesta #2 on: Julio 20, 2021, 11:24:16 am »
hola!

muchas gracias! Efectivamente la versión del composer 1.x resolvió el problema.

Mejor dicho permitió avanzar al siguiente problema, je!:

Código: [Seleccionar]
root@kollawtest 4.5.1]# composer install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Package operations: 16 installs, 0 updates, 0 removals
  - Installing siu/arai-crypto (v2.0.0): Cloning b9d1de2551


  [RuntimeException]
  Failed to execute git clone --no-checkout 'https://gitlab.siu.edu.ar/siu-arai/arai-crypto' '/var/www/kolla/4.5.1/vendor/siu/arai-crypto' && cd '/var/www/kolla/4.5.1/ven
  dor/siu/arai-crypto' && git remote add composer 'https://gitlab.siu.edu.ar/siu-arai/arai-crypto' && git fetch composer && git remote set-url origin 'https://gitlab.siu.
  edu.ar/siu-arai/arai-crypto' && git remote set-url composer 'https://gitlab.siu.edu.ar/siu-arai/arai-crypto'

  error: RPC failed; result=22, HTTP code = 422
  fatal: The remote end hung up unexpectedly


install [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--] [<packages>]...

[root@kollawtest 4.5.1]#

dado que el http code es 422 'Unprocessable Entity' interpreto que es una respuesta que está entregando el servidor de Gitlab. Nos pueden ayudar? Muchas gracias, nuevamente!

Ricardo
Ricardo Bravo
UBA / Rectorado / SSTDyM

mforti

  • Moderador Global
  • *****
  • Mensajes: 25
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Mora Forti
  • Sistema: SIU-Kolla | SIU-Tehuelche
Re:instalar version 4.5.1: problemas con el composer
« Respuesta #3 on: Julio 21, 2021, 10:41:13 am »
Hola Ricardo, buen día, ¿Cómo es el ambiente que tienen armado, si es una máquina virtual, que especificaciones tiene, y en qué sistema operativo están trabajando?

Gracias, saludos.

rbravo

  • Newbie
  • *
  • Mensajes: 41
  • Ricardo Bravo
    • Ver Perfil
  • Institución: Universidad de Buenos Aires - Subscretaría de Transformación Digital y Modernización
  • Nombre y apellido: Ricardo Bravo
  • Sistema: Guaraní
  • Teléfono laboral: +54-11-5285-6100
Re:instalar version 4.5.1: problemas con el composer
« Respuesta #4 on: Julio 22, 2021, 04:00:22 pm »
Muchas gracias! La respuesta nos sirvió de inspiración... El problema era la versión del GIT, pasamos de la v1.x a la v2.x y procedió (aparentemente el repositorio gitlab manda un redirect que la ver 1 no comprende).

Ahora tenemos prácticamente terminada la instalación, aunque llegamos al WebCheck y nos encontramos con el siguiente mensaje (aparte de otros, salvables):

Código: [Seleccionar]
Estado Requerimiento
POSTGRES: Versión esperada desde 10 hasta 13, versión instalada 13.3

pese a que el script de instalación validó la version de PostgreSQL y prosiguió hasta el final.

Tiene importancia, o no acepta más que PostgreSQL 13.0 y no las siguientes versiones menores?

Muchas gracias!

Ricardo Bravo
UBA / Rectorado / SSTDyM

mforti

  • Moderador Global
  • *****
  • Mensajes: 25
    • Ver Perfil
    • Email
  • Institución: SIU
  • Nombre y apellido: Mora Forti
  • Sistema: SIU-Kolla | SIU-Tehuelche
Re:instalar version 4.5.1: problemas con el composer
« Respuesta #5 on: Julio 26, 2021, 02:28:01 pm »
Hola Ricardo, no deberían tener problema con la versión de postgres.

Saludos