Autor Tema: Error_Actualización kolla v4.2.1 a v4.5.1  (Leído 541 veces)

0 Usuarios y 1 Visitante están viendo este tema.

faraya

  • General Guarani
  • *
  • Mensajes: 191
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Fernando Daniel Araya
  • Sistema: SIU-GUARANI
  • Teléfono laboral: 0297-4854888 int 114
Error_Actualización kolla v4.2.1 a v4.5.1
« on: Agosto 25, 2021, 03:05:39 pm »
Buenas tardes!
En la UNPA estamos probando la actualización de kolla de la v4.2.1 a v4.5.1. El ambiente de prueba es Debian 9, PHP 7.3 y Postgres 13.
Después de realizar la actualización y darle los permisos de ejecución, modificamos el virtualhost generado para el sistema de la siguiente forma:

<VirtualHost *:80>
        ServerName cys-kollaPas.sistemas.unpa.edu.ar
        RewriteEngine on
        LogLevel warn
        RewriteCond %{SERVER_PORT} !^443$
        RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [L,R]
RewriteCond %{SERVER_NAME} =cys-kollaPas.sistemas.unpa.edu.ar
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

<VirtualHost *:443>
        ServerName cys-kollaPas.sistemas.unpa.edu.ar
        ServerAdmin rys@unpa.edu.ar
        SSLEngine on
        DocumentRoot /var/pas/kolla_4.5.1/www/
        <Directory /var/pas/kolla_4.5.1/www/>
                DirectoryIndex inicial.php
                Options FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>
                ErrorLog /var/log/apache2/error.log
LogLevel warn
        CustomLog /var/log/apache2/access.log combined
        ServerSignature Off
        include /var/pas/kolla_4.5.1/instalacion/toba.conf
        SSLCertificateFile /etc/letsencrypt/live/kolla.sistemas.unpa.edu.ar/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/kolla.sistemas.unpa.edu.ar/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>

Cabe aclarar que solo hemos modificado las siguientes lineas del VH:

DocumentRoot /var/pas/kolla_4.5.1/www/
        <Directory /var/pas/kolla_4.5.1/www/>

include /var/pas/kolla_4.5.1/instalacion/toba.conf

y cuando queremos ingresar al sistema, nos sale el siguiente error:

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.3.0".

Mirando las ultimas lineas del sistema.log se ve lo siguiente:

Fecha: 25-08-2021 12:51:05
Operacion: Autentificaci�n de Usuarios
Usuario: no_autentificado
Version-PHP: 7.1.30-1+0~20190531112744.19+jessie~1.gbpab9d28
Servidor: cys-kollapas.sistemas.unpa.edu.ar
URI: /pas/kolla/aplicacion.php?fs=1
Referrer: https://cys-kollapas.sistemas.unpa.edu.ar/pas/kolla/aplicacion.php?tm=1&tcm=central&ai=kolla||38000148
Host: 10.0.30.34
==========
[INFO][toba] Se detecto cambio de operaci�n. Se limpia la memoria de la operacion
[INFO][kolla] PUNTO MONTAJE: se carg� la clase extension_toba/kolla_usuario.php del punto de montaje proyecto. El path del mismo es /var/pas/kolla/aplicacion/php
[INFO][kolla] PUNTO MONTAJE: se carg� la clase operaciones/login/ci_login.php del punto de montaje proyecto. El path del mismo es /var/pas/kolla/aplicacion/php
[INFO][toba] componente(200000003): No hay se�ales de un servicio anterior, no se atrapan eventos
[INFO][toba] componente(200000003): [ callback ] 'conf__login' no fue atrapado
[INFO][kolla] PUNTO MONTAJE: se carg� la clase extension_toba/bootstrap/componentes/interfaz/bootstrap_formulario_login.php del punto de montaje proyecto. El path del $
-o-o-o-o-o-
Fecha: 25-08-2021 12:51:05
Operacion: Autentificaci�n de Usuarios
Usuario: no_autentificado
Version-PHP: 7.1.30-1+0~20190531112744.19+jessie~1.gbpab9d28
Servidor: cys-kollapas.sistemas.unpa.edu.ar
URI: /pas/kolla/aplicacion.php?ah=st612666e96ed716.04115721&ai=kolla%7C%7C200000004
Referrer: https://cys-kollapas.sistemas.unpa.edu.ar/pas/kolla/aplicacion.php?fs=1
Host: 10.0.30.34
==========
[INFO][kolla] PUNTO MONTAJE: se carg� la clase operaciones/login/ci_login.php del punto de montaje proyecto. El path del mismo es /var/pas/kolla/aplicacion/php
[INFO][toba] componente(200000003): No hay se�ales de un servicio anterior, no se atrapan eventos
[INFO][toba] componente(200000003): [ callback ] 'conf__login' no fue atrapado
[INFO][kolla] PUNTO MONTAJE: se carg� la clase extension_toba/bootstrap/componentes/interfaz/bootstrap_formulario_login.php del punto de montaje proyecto. El path del $

Espero me puedan ayudar.
Saludos Fernando Araya. UNPA.



Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 201
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #1 on: Agosto 25, 2021, 03:32:25 pm »
Hola Fernando, creo que el problema está con la versión de composer. Puede ser que tengan instalada la versión 2? Si es así, deberían instalar la versión 1 ya que actualmente Toba no soporta correctamente la versión 2.

faraya

  • General Guarani
  • *
  • Mensajes: 191
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Fernando Daniel Araya
  • Sistema: SIU-GUARANI
  • Teléfono laboral: 0297-4854888 int 114
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #2 on: Agosto 26, 2021, 08:01:28 am »
Efectivamente tengo instalada la versión 2 de composer, cuando instale composer en Debian 9 se instalo por defecto.
Voy a instalar la versión 1 para ver lo que pasa. Muchas gracias por la respuesta!

Saludos Fernando.

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 201
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #3 on: Agosto 26, 2021, 08:15:33 am »
Buscando en el foro porblemas con composer 2 me encontré con este otro problema y una posible solución https://foro.comunidad.siu.edu.ar/index.php?topic=20861.msg92947#msg92947 y también con ésta otra solución para tu problema puntual https://php.watch/articles/composer-platform-check

Fijate si agregando esto a tu composer.json te funciona

Código: [Seleccionar]
{
    "config": {
        "platform-check": false
    }
}

faraya

  • General Guarani
  • *
  • Mensajes: 191
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Fernando Daniel Araya
  • Sistema: SIU-GUARANI
  • Teléfono laboral: 0297-4854888 int 114
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #4 on: Septiembre 10, 2021, 11:13:03 am »
Buen día! estamos actualizando el sistema kolla de la versión  v4.2.1 a v4.5.1 y al momento de ejecutar composer install, nos salen los siguientes mensajes:

Skipped installation of bin bin/toba for package siu-toba/framework:
name conflicts with an existing file
Skipped installation of bin bin/toba_docker for package
siu-toba/framework: name conflicts with an existing file

Installing tecnickcom/tcpdf (6.3.5): Downloading (100%)
components/bootstrap suggests installing components/bootstrap-default
(Provide a theme for Bootstrap as components/bootstrap only provides the
CSS as file assets)
guzzlehttp/psr7 suggests installing laminas/laminas-httphandlerrunner
(Emit PSR-7 responses)
laminas/laminas-validator suggests installing laminas/laminas-db
(Laminas\Db component, required by the (No)RecordExists validator)
laminas/laminas-validator suggests installing laminas/laminas-filter
(Laminas\Filter component, required by the Digits validator)
laminas/laminas-validator suggests installing laminas/laminas-i18n
(Laminas\I18n component to allow translation of validation error messages)
laminas/laminas-validator suggests installing
laminas/laminas-i18n-resources (Translations of validator messages)
laminas/laminas-validator suggests installing laminas/laminas-math
(Laminas\Math component, required by the Csrf validator)
laminas/laminas-validator suggests installing
laminas/laminas-servicemanager (Laminas\ServiceManager component to
allow using the ValidatorPluginManager and validator chains)
laminas/laminas-validator suggests installing laminas/laminas-session
(Laminas\Session component, ^2.8; required by the Csrf validator)
paragonie/random_compat suggests installing ext-libsodium (Provides a
modern crypto API that can be used to generate random bytes.)
paragonie/sodium_compat suggests installing ext-libsodium (PHP < 7.0:
Better performance, password hashing (Argon2i), secure memory management
(memzero), and better security.)
mjohnson/decoda suggests installing ext-memcached (Cache data using
Memcache)
mjohnson/decoda suggests installing ext-redis (Cache data using Redis)
doctrine/cache suggests installing alcaeus/mongo-php-adapter (Required
to use legacy MongoDB driver)
pear/math_biginteger suggests installing ext-bcmath (Allows using the
BCMath extension internally for computation. Faster than native
implementation.)
pear/math_biginteger suggests installing ext-gmp (Allows using the GNU
Multiple Precision extension internally for computation. If you are
doing a lot of computation this is the recommended extension.)
phpoffice/phpspreadsheet suggests installing dompdf/dompdf (Option for
rendering PDF with PDF Writer (doesn't yet support PHP8))
phpoffice/phpspreadsheet suggests installing jpgraph/jpgraph (Option for
rendering charts, or including charts with PDF or HTML Writers)
phpoffice/phpspreadsheet suggests installing mpdf/mpdf (Option for
rendering PDF with PDF Writer)
phpmailer/phpmailer suggests installing hayageek/oauth2-yahoo (Needed
for Yahoo XOAUTH2 authentication)
phpmailer/phpmailer suggests installing league/oauth2-google (Needed for
Google XOAUTH2 authentication)
phpmailer/phpmailer suggests installing stevenmaguire/oauth2-microsoft
(Needed for Microsoft XOAUTH2 authentication)
symfony/polyfill-intl-normalizer suggests installing ext-intl (For best
performance)
symfony/polyfill-intl-idn suggests installing ext-intl (For best
performance)
dapphp/securimage suggests installing ext-pdo_mysql (For MySQL database
support)
dapphp/securimage suggests installing ext-pdo_sqlite (For SQLite3
database support)
siu-toba/framework suggests installing simplesamlphp/simplesamlphp
(Permite conectarse a un IDP centralizado (see onelogin))
siu-toba/framework suggests installing siu-toba/jasper (Permite imprimir
reportes via Jasper desde SIU-Toba)
siu-toba/framework suggests installing siu/arai-reportes (Permite
imprimir reportes via un servidor Jasper desde SIU-Toba)
siu-toba/framework suggests installing siu/manejador-salida-bootstrap
(Permite generar un marcado HTML responsive)
symfony/service-contracts suggests installing symfony/service-implementation
symfony/console suggests installing symfony/event-dispatcher
symfony/console suggests installing symfony/lock
monolog/monolog suggests installing aws/aws-sdk-php (Allow sending log
messages to AWS services like DynamoDB)
monolog/monolog suggests installing doctrine/couchdb (Allow sending log
messages to a CouchDB server)
monolog/monolog suggests installing ext-amqp (Allow sending log messages
to an AMQP server (1.0+ required))
monolog/monolog suggests installing ext-mongo (Allow sending log
messages to a MongoDB server)
monolog/monolog suggests installing graylog2/gelf-php (Allow sending log
messages to a GrayLog2 server)
monolog/monolog suggests installing mongodb/mongodb (Allow sending log
messages to a MongoDB server via PHP Driver)
monolog/monolog suggests installing php-amqplib/php-amqplib (Allow
sending log messages to an AMQP server using php-amqplib)
monolog/monolog suggests installing php-console/php-console (Allow
sending log messages to Google Chrome)
monolog/monolog suggests installing rollbar/rollbar (Allow sending log
messages to Rollbar)
monolog/monolog suggests installing ruflin/elastica (Allow sending log
messages to an Elastic Search server)
monolog/monolog suggests installing sentry/sentry (Allow sending log
messages to a Sentry server)
siu/check-constraints suggests installing siu/toba-ldap (Permite
realizar chequeos a un servicio LDAP)
siu/instalador suggests installing siu/anonimizador (Permite anonimizar
los datos de una base de datos para un proyecto)
Package container-interop/container-interop is abandoned, you should
avoid using it. Use psr/container instead.
Generating autoload files
25 packages you are using are looking for funding.
Use the composer fund command to find out more!

Si continuamos con la actualización llegamos al paso que compila y nos muestra el siguiente mensaje de error:

Compilando metadatos del proyecto toba_usuarios

6000/6000
[▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓]
100%


In Filesystem.php line 105:

   Failed to create "/var/pas/kolla_4.5.1/www/temp/": mkdir(): File exists

No se que podra ser? estamos actualizando en Debian 9, PHP 7.3 y Postgres 13.
Adjunto el log del instalador. Saludos Fernando.

Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 201
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #5 on: Septiembre 10, 2021, 11:36:43 am »
Hola Fernando, el primer error que veo en el log del instalador es en la línea 126. Hay una configuración de acceso que falta en el pg_hba.conf para poder conectarse a la base correctamente.

Código: [Seleccionar]
[ TOBA ] [MENSAJE]: FATAL:  no hay una línea en pg_hba.conf para «127.0.0.1», usuario «kolla», base de datos «kolla451», SSL activo 
Podrías chequear esto y volver a intentar la actualización? Porque es probable que esto sea el desencadenante para el resto de los errores.

Al tratarse de una actualización de versión, los parámetros en instalador.env deberían apuntar a la base de la versión 4.2.1 y veo que tenés estos:

Código: [Seleccionar]
[ PARAMETROS db_proyecto ] dbname => 'kolla451'
[ PARAMETROS db_toba ] dbname=>'kolla451'

Es correcto?.

faraya

  • General Guarani
  • *
  • Mensajes: 191
    • Ver Perfil
    • Email
  • Institución: Universidad Nacional de la Patagonia Austral
  • Nombre y apellido: Fernando Daniel Araya
  • Sistema: SIU-GUARANI
  • Teléfono laboral: 0297-4854888 int 114
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #6 on: Septiembre 10, 2021, 11:58:26 am »
Hola Rodrigo!
vamos a revisar este mensaje y corregirlo.
[ TOBA ] [MENSAJE]: FATAL:  no hay una línea en pg_hba.conf para «127.0.0.1», usuario «kolla», base de datos «kolla451», SSL activo

en cuanto este mensaje:
[ PARAMETROS db_proyecto ] dbname => 'kolla451'
[ PARAMETROS db_toba ] dbname=>'kolla451'

Lo que hicimos es crear la base kolla451 y restaurarle el bkp de la base 421. Pero en realidad es la base de la versión que queremos actualizar

Saludos Fernando.


Rodrigo Miranda [SIU]

  • Moderador Global
  • *****
  • Mensajes: 201
    • Ver Perfil
    • Email
  • Institución: SIU
Re:Error_Actualización kolla v4.2.1 a v4.5.1
« Respuesta #7 on: Octubre 01, 2021, 07:51:16 am »
Hola Fernando, pudieron resolver este tema?